FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Sep 2013
    Location
    Scotland
    Posts
    4

    My Laptop always boots to Windows instead of giving an OS option

    Hi all,

    Just wondering if anyone can help me get Fedora to dual boot please. I have been a Fedora user since 2013, however this is the first time I've used it on a laptop that also runs windows.
    As you will see by my profile I've been here since 2013 and this is the first question I have ever asked. I prefer to find solutions myself but this time I'm stumped. It's probably glaringly obvious but I could do with help from a more experienced user please.

    I have installed Fedora workstation 25 to my laptop drive on its own partition. When i restart my laptop it always runs Windows 10 except when I go to advanced restart. When I do this I'm able to choose to run Fedora and everything works really well.

    There just isn't any way I can choose which OS without first running Windows and then doing an advanced restart.

    If anyone has any ideas how to solve this or can lead me in the right direction it would be much appreciated.

    Thank you

    Chris

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,284

    Re: My Laptop always boots to Windows instead of giving an OS option

    For whatever reason you don't have a grub boot menu appearing when you turn the notebook on. check if your notebook is set to boot in uefi mode. It probably is. in W10 hold down start+R together and type in msinfo32.exe. then press enter

    locate the BIOS mode line. if it says uefi, then you may want to try refind

  3. #3
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,566

    Re: My Laptop always boots to Windows instead of giving an OS option

    You might want to mention which make/model of laptop you have. It could simply be that your UEFI firmware has W10 as the first in boot order. Once you have Fedora booted up, in a command terminal enter the efibootmgr command. One of the items shown will be "BootOrder:", which shows boot order. Please post the full output of the efibootmgr command.

    The efibootmgr program is capable of changing the boot order, but if you happen to have one of certain HP model laptops, like mine, the HP UEFI firmware will always make the W10 entry the first in the boot order on each start up. If that's the case with you, there is a way around this.

  4. #4
    Join Date
    Sep 2013
    Location
    Scotland
    Posts
    4

    Re: My Laptop always boots to Windows instead of giving an OS option

    Quote Originally Posted by PabloTwo
    You might want to mention which make/model of laptop you have. It could simply be that your UEFI firmware has W10 as the first in boot order. Once you have Fedora booted up, in a command terminal enter the efibootmgr command. One of the items shown will be "BootOrder:", which shows boot order. Please post the full output of the efibootmgr command.

    The efibootmgr program is capable of changing the boot order, but if you happen to have one of certain HP model laptops, like mine, the HP UEFI firmware will always make the W10 entry the first in the boot order on each start up. If that's the case with you, there is a way around this.
    Hi PabloTwo, thank you for your help. Great guess, I have a HP laptop using UEFI firmware. I had just got my issue resolved before rechecking the forum here. I basically changed to legacy boot which gives me a boot option on startup. So issue solved.

    Thank you again, it's much appreciated

    ---------- Post added at 09:18 PM ---------- Previous post was at 09:13 PM ----------

    Quote Originally Posted by antikythera
    For whatever reason you don't have a grub boot menu appearing when you turn the notebook on. check if your notebook is set to boot in uefi mode. It probably is. in W10 hold down start+R together and type in msinfo32.exe. then press enter

    locate the BIOS mode line. if it says uefi, then you may want to try refind
    Thank you antikythera, I managed to get my issue solved shortly before coming back to the forum here. I can't believe it was was such an obvious solution after searching everywhere. Still I live and learn.

    Thank you for your help it's really valued

  5. #5
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,284

    Re: My Laptop always boots to Windows instead of giving an OS option

    no problem, if you install any more operating systems alongside those two in future, refind would come into it's own.

  6. #6
    Join Date
    Sep 2013
    Location
    Scotland
    Posts
    4

    Re: My Laptop always boots to Windows instead of giving an OS option

    Quote Originally Posted by antikythera
    no problem, if you install any more operating systems alongside those two in future, refind would come into it's own.
    Thank you, I don't plan at present to install any other Operating Systems but have made a note of the url as it looks like a really practical tool. Great share

Similar Threads

  1. F20: Laptop boots only after going into BIOS
    By tkalfaoglu in forum Hardware & Laptops
    Replies: 9
    Last Post: 11th April 2014, 01:24 PM
  2. Strange problem - laptop boots all by itself
    By Dan in forum Hardware & Laptops
    Replies: 14
    Last Post: 10th October 2011, 06:17 PM
  3. trying to install ipw2100 on laptop and giving up
    By kamarul in forum Hardware & Laptops
    Replies: 1
    Last Post: 29th May 2006, 05:53 PM
  4. Boots XP. Never see Fedora option in a Dual Boot display
    By djcarpenter in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 13th December 2005, 04:29 AM
  5. GRUB boot up only giving windows option
    By iusefedora in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 27th December 2004, 01:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •