FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    398

    Upgrade to FC26 may kill USB3.0

    as funny as it may seem, I am now on my fourth box which I had to "reinstall from scratch" FC26,
    after doing a fedup from FC25 on all 4, somehow USB3.0 stopped working. i.e. the devices would not even show up.
    Plugging them into the USB2.0 (black) ports worked though.

    Then after a full reinstall (i.e. wipe clean and start anew), they (the blue USB3.0 ports) now work fine.

    funky. I suspect some library conflict somewhere.

  2. #2
    Join Date
    Jan 2010
    Posts
    7,156

    Re: Upgrade to FC26 may kill USB3.0

    Fedora 26 is still in alpha, isn't it?
    I gave it a try on a UX31E and it just aborted after selecting language.

    I don't know how many people aside from the mods pay attention to what section you're using for a post (I suspect most of us just do what I do and look for new posts), but you might want to, for the moment, move the Fedora 26 stuff to the F26 development forum. (or not... like I said, I think few people notice, and these days, the mods don't threaten to ban for posting in the wrong forum, but...)

    Anyway, a lot depends upon how much effort you want to put into helping to test. If you're duplicating this on several machines, it may be worth filing the bug.

  3. #3
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,223

    Re: Upgrade to FC26 may kill USB3.0

    as smr54 points out, please keep F26 discussion including any upgrades from earlier versions to the development section of the forum only. thread moved

  4. #4
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    398

    Re: Upgrade to FC26 may kill USB3.0

    OK I will.

  5. #5
    gordon64 Guest

    Re: Upgrade to FC26 may kill USB3.0

    I have had no luck with F26 boot up so thanks for reporting

    looking at usb 3 I think your
    Code:
    journalctl -b | grep xhci
    should show xhci which apparently is the driver for usb 3

    and another search shows
    Code:
    lusb -t
    might help too

    below is my F25 results
    NOT OP
    journalctl -b | grep xhci
    Apr 29 10:49:24 f.e.org kernel: xhci_hcd 0000:00:14.0: xHCI Host Controller
    Apr 29 10:49:24 f.e.org kernel: xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
    Apr 29 10:49:24 f.e.org kernel: xhci_hcd 0000:00:14.0: hcc params 0x200077c1 hci version 0x100 quirks 0x00009810
    Apr 29 10:49:24 f.e.org kernel: xhci_hcd 0000:00:14.0: cache line size of 64 is not supported
    Apr 29 10:49:24 f.e.org kernel: usb usb3: Manufacturer: Linux 4.10.10-200.fc25.x86_64 xhci-hcd
    Apr 29 10:49:24 f.e.org kernel: xhci_hcd 0000:00:14.0: xHCI Host Controller
    Apr 29 10:49:24 f.e.org kernel: xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 4
    Apr 29 10:49:24 f.e.org kernel: usb usb4: Manufacturer: Linux 4.10.10-200.fc25.x86_64 xhci-hcd
    Apr 29 10:49:24 f.e.org kernel: usb 3-3: new low-speed USB device number 2 using xhci_hcd
    Apr 29 10:49:25 f.e.org kernel: usb 3-4: new low-speed USB device number 3 using xhci_hcd


    lsusb -t
    /: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
    /: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/14p, 480M
    |__ Port 3: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 4: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 4: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
    /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
    /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
    offtopic

    my tower has 2 front usb ports that are supposed to be usb 3 so that makes them BUS 3// usb 3 and 4 port numbers.

    but you can see there is a duplication of port number 4 for reasons I know not.

    Port number 4 device number 3 is showing 2 outcomes but both are usb 3 standard

  6. #6
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    523

    Re: Upgrade to FC26 may kill USB3.0

    FWIW:

    During the Alpha stage of a release I install to a USB 3.0 WD passport. I do a from scratch net install each time a new release candidate is posted up. I did find that kernel 4.11.0-0.rc7.git0.1.fc26.x86_64 would not boot ( via USB 3) after installation. However, kernel 4.11.0-0.rc8.git0.1.fc26.x86_64 is running just fine.

    I do the fresh install just to be sure I am evaluating the actual state of the release vs migration issues between what can be unstable or incomplete content.


    (posted from my F26 Alpha evaluation boot )
    Laptop: ASUS K61IC/ Intel T6600 2.20Ghz x2/ 4GB/ 320GB SataII/ NVidia G96M/ fc27.x86_64
    Tower: GigaByte (990FXA)/ AMD 1100T 3.3Ghz x6/ 16GB/ 7.5TB Sata III/ AMD 6770HD/ fc27.x86_64
    Bookshelf: Shuttle DS61 (H61)/ i3-3225 3.3Ghz x2/ 16GB/ 320GB Sata II/ Intel HD 4000/ fc26.x86_64
    Embedded: BeagleBone Blk / ARM AM3358 1 GHz x1/ 512MB/ 2GB eMMC/ PowerVR SGX530/ fc26.armv7hl

  7. #7
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    523

    Re: Upgrade to FC26 may kill USB3.0

    offtopic

    my tower has 2 front usb ports that are supposed to be usb 3 so that makes them BUS 3// usb 3 and 4 port numbers.

    but you can see there is a duplication of port number 4 for reasons I know not.

    Port number 4 device number 3 is showing 2 outcomes but both are usb 3 standard
    Note that the device is presenting 2 interfaces to the port ( 0 and 1). In my case the device is a Logitech keyboard that has both a keyboard and media control functions ( play, pause, and mute music and videos )
    Last edited by Kobuck; 29th April 2017 at 07:12 PM.
    Laptop: ASUS K61IC/ Intel T6600 2.20Ghz x2/ 4GB/ 320GB SataII/ NVidia G96M/ fc27.x86_64
    Tower: GigaByte (990FXA)/ AMD 1100T 3.3Ghz x6/ 16GB/ 7.5TB Sata III/ AMD 6770HD/ fc27.x86_64
    Bookshelf: Shuttle DS61 (H61)/ i3-3225 3.3Ghz x2/ 16GB/ 320GB Sata II/ Intel HD 4000/ fc26.x86_64
    Embedded: BeagleBone Blk / ARM AM3358 1 GHz x1/ 512MB/ 2GB eMMC/ PowerVR SGX530/ fc26.armv7hl

Similar Threads

  1. fedup FC25 -> FC26 not working (yet?)
    By bobx001 in forum F26 Development Forum
    Replies: 3
    Last Post: 29th April 2017, 11:00 PM
  2. FC26, small issue with FONTS
    By bobx001 in forum F26 Development Forum
    Replies: 1
    Last Post: 28th April 2017, 01:46 AM
  3. FC26 nice log entry
    By bobx001 in forum F26 Development Forum
    Replies: 4
    Last Post: 27th April 2017, 07:35 PM
  4. [SOLVED] FC26 - Konqueror under blackbox not showing images
    By bobx001 in forum Desktop Environments / Window Managers
    Replies: 1
    Last Post: 27th April 2017, 07:07 PM
  5. F20 USB3.0 harddrive not moutable on USB3 port
    By serendip82 in forum Using Fedora
    Replies: 2
    Last Post: 21st February 2014, 01:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •