FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2017
    Location
    Aarhus
    Posts
    2

    Question mark symbol after installing fedora

    I have recently installed fedora on my Macbook Pro, at first it worked great, but then suddenly when using MacOS it froze and when i turned my macbook on again the macbook showed the folder with a question mark, which I found out means my computer cannot find a bootable device. Then when trying to use internet recovery the installer could not find the drive. But then when I tried using a Ubuntu Live USB on my computer, it could suddenly see my harddrive and upon restarting it my computer booted fine to MacOS, but everytime my computer closes I have to restart from my USB to get into MacOS. I have tried a lot of different methods but i have not found one which is working jet.

  2. #2
    Join Date
    May 2010
    Posts
    1,058

    Re: Question mark symbol after installing fedora

    Sounds like a hardware problem, since it has affected normal behavior during early boot when only the firmware is active:

    - NVRAM is pointing to the wrong boot volume; this sometimes gets corrupted hence command-option-p-r at boot time to "zap pram". Clearing it fixes corruption, but doesn't necessarily fix booting, the correct entries need to be put back into NVRAM.

    - Boot volume corruption, or device hardware issue. If even one sector is returning spurious information you can get the behavior you're reporting. There's literally dozens of causes. Maybe the best and easiest way to fix this is if you can still boot macOS, even over the internet with internet recovery, and at the menu of options, go to the Utilities menu and run Terminal. There you can issue:

    Code:
    diskutil list
    Find your primary drive in that long list of devices (probably by size).

    For me when I boot off internet recovery it's disk11. Also you want the actual drive itself, not one of the logical devices. e.g. for me /dev/disk11 has a core storage partition, disk11s2, and that becomes virtual device disk12 which is where macOS and all my stuff is. I run the command on disk11, the one that has the ~200MB EFI partition, not disk12.

    Code:
    diskutil repairdisk diskX
    That repairs the GPT, and all found volumes, it'll run fsck on the EFI system partition, core storage structures, HFS+ and JHFS+, all in one whack. The alternative is you have to check these things with separate tools like gdisk, fsck.vfat, fsck.hfsplus, individually.

    Also while you're in Fedora with live boot:
    Code:
    dnf install smartmontools
    smartctl -x /dev/sda
    That'll give a complete listing for drive SMART data, it might reveal if there are problems with the drive. So attach those results as a file, or you can dump it into fpaste and post the URL.

    Code:
    smartctl -x /dev/sdX | fpaste

  3. #3
    Join Date
    Apr 2017
    Location
    Aarhus
    Posts
    2

    Re: Question mark symbol after installing fedora

    The repair did not work here is the result of running smartctl -x /dev/sdX: https://paste.fedoraproject.org/past...YhyRLivL9gydE=

Similar Threads

  1. [SOLVED] Wifi symbol turned to a queston mark
    By ttsdinesh in forum Hardware & Laptops
    Replies: 10
    Last Post: 4th May 2016, 12:38 PM
  2. Wifi connected but showing question mark
    By rossman_2 in forum Servers & Networking
    Replies: 2
    Last Post: 17th December 2014, 07:12 AM
  3. left to right mark problem in fedora
    By asemaneahvaz in forum Hardware & Laptops
    Replies: 0
    Last Post: 27th July 2011, 10:35 PM
  4. Replies: 2
    Last Post: 9th September 2009, 05:05 PM
  5. FC9 flashing question mark ibook G3
    By hohum3001 in forum Mac Chat
    Replies: 6
    Last Post: 20th November 2008, 02:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •