FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2013
    Location
    UK
    Posts
    213

    No HDMI sound using nouveau or Nvidia

    Yesterday I changed the sound output to headphone and now when I switch back to HDMI in phonon I have no sound. However if I swirch to any other HDMI profile other than the correct one (HDMI2) I get sound through the headphones. I am using an Nvidia card andKDE.

    I have tried undoing the last system update in case that was the issue but am unable to do so, due to some random package being unavalible (it changes each time)

    Code:
    user-001@elrond ~$ sudo dnf history undo 367
    
    No package libreoffice-data-1:5.2.6.2-4.fc25.noarch available.
    Error: An operation cannot be undone
    
    user-001@elrond ~$ sudo dnf history undo 367
    
    No package chromium-0:56.0.2924.87-3.fc25.x86_64 available.
    Error: An operation cannot be undone
    
    user-001@elrond ~$ sudo dnf history undo 367
    
    No package gvfs-mtp-0:1.30.3-1.fc25.x86_64 available.
    Error: An operation cannot be undone
    
    user-001@elrond ~$ sudo dnf history undo 367 -force
    Last metadata expiration check: 0:59:38 ago on Wed Apr  5 06:44:42 2017.
    Found more than one transaction ID!
    Error: Failed history undo
    Changing from the (correct) HDMI2 profile to another one results in the following:
    Switching to the audio playback device GK104 HDMI Audio Controller Digital Stereo (HDMI 2)
    which has higher preference or is specifically configured for this stream.
    The audio playback device GK104 HDMI Audio Controller Digital Stereo (HDMI 2) does not work.
    Falling back to Built-in Audio Analog Stereo.
    I have also tried installing the Nvidia driver which makes no difference, nither does using a different kernel.

    journalctl output.
    Last edited by wintonian; 5th April 2017 at 08:03 AM.

  2. #2
    Join Date
    Jul 2013
    Location
    UK
    Posts
    213

    Re: No HDMI sound using nouveau or Nvidia

    Never mind turning the speakers on and off solved the problem. :-|

Similar Threads

  1. FC22, nouveau, nvidia chipset: No sound from HDMI
    By StefanJ in forum Installation, Upgrades and Live Media
    Replies: 11
    Last Post: 5th December 2015, 04:29 AM
  2. f18 nvidia hdmi sound
    By b4time in forum Using Fedora
    Replies: 1
    Last Post: 4th April 2013, 12:12 PM
  3. [SOLVED] No sound when using Nvidia hdmi
    By nathan082000 in forum Hardware & Laptops
    Replies: 19
    Last Post: 6th June 2012, 10:08 PM
  4. [SOLVED] Nvidia HDMI audio/sound
    By jtang613 in forum Hardware & Laptops
    Replies: 6
    Last Post: 23rd September 2010, 07:19 PM
  5. sound thru nvidia hdmi
    By rhiakath in forum Hardware & Laptops
    Replies: 2
    Last Post: 18th April 2010, 10:13 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •