[SOLVED] Update xorg-x11-drv-amdgpu 1.3.0-1.fc25 forces Xorg to use ati module?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2014
    Location
    London
    Posts
    19

    Thumbs down Update xorg-x11-drv-amdgpu 1.3.0-1.fc25 forces Xorg to use ati module?

    Anybody else succesfully using Fedora 25's new amdgpu 1.3 yet? It hit @updates about 2 days ago but left me unusable with Xorg erroring that it can't find module "ati" which is obviously blacklisted as I'm trying to use the amdgpu, not ati module. I thought it may be built for kernel 4.10 but today I see 4.10.3 is available and that does not fix the issue. Only fix is to

    Code:
    $ dnf downgrade xorg-x11-drv-amdgpu
    
    Downgraded:
      xorg-x11-drv-amdgpu.x86_64 1.1.2-3.20160929git97d7386c.fc25
    I'm not sure if it's Fedora packaging or AMD's trainwreck transition to open source drivers, but this has been my most unstable graphics configuration since 2001.



    Any help is appreciated! No changes to xorg conf appear to be made between versions. Has AMD really reverted back to ati module in some fashion? Maybe there's a missing dependency here?

    Thx
    JohnnyB

    Code:
    ~> sudo grep EE /var/log/Xorg.0.log 
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    84.551] (EE) Failed to load module "ati" (module does not exist, 0)
    [    85.155] (EE) AMDGPU(0): failed to set mode: Invalid argument
    [    85.275] (EE) AMDGPU(0): failed to set mode: Invalid argument

  2. #2
    Join Date
    Mar 2017
    Location
    USA
    Posts
    71

    Re: Update xorg-x11-drv-amdgpu 1.3.0-1.fc25 forces Xorg to use ati module?

    Yes. I reinstalled F25 yesterday. I have

    Code:
    xorg-x11-drv-amdgpu.x86_64                                              1.3.0-1.fc25
    and it's working well.

    Tim

  3. #3
    Join Date
    Jan 2014
    Location
    London
    Posts
    19

    Thumbs up Re: Update xorg-x11-drv-amdgpu 1.3.0-1.fc25 forces Xorg to use ati module?

    Thanks for the reply. Can I ask what card you're using?

    I'm running a polaris 470:

    Code:
    28:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] (rev cf)
    Persistent firmware issue (not built into initrd or something) though it is present and it works fine with 1.2.x:

    Code:
    $  sudo dmesg | grep -i firmware
    [    3.251763] amdgpu 0000:28:00.0: Direct firmware load for amdgpu/polaris10_mc.bin failed with error -2
    [    3.251764] mc: Failed to load firmware "amdgpu/polaris10_mc.bin"
    [    3.251929] [drm:gmc_v8_0_sw_init [amdgpu]] *ERROR* Failed to load mc firmware!
    [   74.732133] [drm] Found UVD firmware Version: 1.79 Family ID: 16
    [   74.733633] [drm] Found VCE firmware Version: 52.4 Binary ID: 3
    Also can I compare mods?

    Code:
    $  lsmod | egrep -i 'amd|ati|radeon'
    amdgpu               1155072  35
    amdkfd                139264  1
    amd_iommu_v2           20480  1 amdkfd
    i2c_algo_bit           16384  1 amdgpu
    drm_kms_helper        155648  1 amdgpu
    ttm                    98304  1 amdgpu
    drm                   352256  16 amdgpu,ttm,drm_kms_helper
    Thanks

  4. #4
    Join Date
    Jan 2014
    Location
    London
    Posts
    19

    Thumbs up [Solved] Update xorg-x11-drv-amdgpu 1.3.0-1.fc25 forces Xorg to use ati module?

    Hmph nevermind. I finally took time to troubleshoot fully and found it works fine if I just remove the

    /usr/share/X11/xorg.conf.d/10-amdgpu.conf

    that is present in the updated package. Autoconfigure sorts itself out where it wasn't a problem for me in the last release. Odd.

    Thanks! Hope this helps anyone else having the same issue.

Similar Threads

  1. Replies: 8
    Last Post: 12th October 2016, 07:43 AM
  2. yum update xorg-x11-server-Xorg error
    By bharat211 in forum Using Fedora
    Replies: 0
    Last Post: 16th March 2009, 02:23 PM
  3. Replies: 2
    Last Post: 19th April 2008, 01:02 PM
  4. Beryl broken afteer xorg-x11-server-Xorg update
    By bowens44 in forum Using Fedora
    Replies: 5
    Last Post: 10th June 2007, 07:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •