FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2017
    Location
    UK
    Posts
    2

    L2TP vpn connection doesn't work on F25

    Hi all,

    I've been using Fedora 25 since the beginning of this year (2017) for both personal and work purposes and it's great in all aspects, so when I needed to work from home I thought "no problem, I'll just connect to our network via our watchguard vpn" ... wrong! I have researched the internet and there does not seem to exist a solution to the problem I am facing, so if anyone has any ideas or knows how to solve this, it would be great.

    I installed 'NetworkManager-l2tp-gnome' as required, which in turn installed/updated the following packages:
    ================================================== ==============================
    Package Arch Version Repository Size
    ================================================== ==============================
    Installing:
    NetworkManager-l2tp x86_64 1.2.4-1.fc25 updates 94 k
    NetworkManager-l2tp-gnome x86_64 1.2.4-1.fc25 updates 44 k
    libreswan x86_64 3.19-1.fc25 updates 1.2 M
    unbound-libs x86_64 1.5.10-1.fc25 fedora 372 k
    xl2tpd x86_64 1.3.8-2.fc25 updates 100 k

    Transaction Summary
    ================================================== ==============================
    Install 5 Packages

    Then just followed the usual steps;
    1. Settings > Network
    2. In the bottom left pane, click add ( + )
    3. Selected 'Point-to-Point Tunneling Protocol (L2TP)
    4. Filled in the required fields with the necessary details and credentials
    - Name: my company name
    - Firewall Zone: Default
    - Gateway: my company server gateway
    - User name: my user name
    - NT Domain: my company DOMAIN (in caps)
    - IPsec Settings... enable IPsec tunnel to L2TP host; group name; pre-shared key; enforce UDP encapsulation;
    - PPP Settings... default
    5. Applied settings

    Then tried to connect... it seems to attempt to connect but after a few seconds i get the following notice:

    Connection failed
    Activation of network connection failed

    I queried the the settings with:
    # ipsec verify
    ...and it came back failed on kernel support:
    "...Libreswan U3.19/K(no kernel code presently loaded) on 4.9.13-201.fc25.x86_64
    Checking for IPsec support in kernel [FAILED]"

    So I also installed the following packages in case it was a question of dependencies missing:

    NetworkManager-libreswan-gnome.x86_64 : NetworkManager VPN plugin for libreswan
    : - GNOME files
    NetworkManager-libreswan.x86_64 : NetworkManager VPN plug-in for IPsec VPN

    I stopped and restarted the service
    # systemctl ipsec stop
    # systemctl ipsec start

    Rerun ipsec verify and all is [OK].

    So went back to perform the steps to connect and... still not able to connect...


    Anyone has a solution, or at least some ideas I can try?

    Any help is welcome!

    Many thanks in advance.

    Cheers
    Beats

  2. #2
    Join Date
    Sep 2005
    Location
    Denmark
    Posts
    130

    Re: L2TP vpn connection doesn't work on F25

    I got it working on Fedora 26 the following way:

    Installed these packages from main repo with `dnf install`

    Code:
    xl2tpd
    NetworkManager-l2tp
    NetworkManager-l2tp-gnome
    NetworkManager-openvpn
    NetworkManager-openvpn-gnome
    NetworkManager-pptp
    NetworkManager-pptp-gnome
    NetworkManager-strongswan
    NetworkManager-strongswan-gnome
    (I experimentet a bit, and therefore there might be unnecessary packages in the list above)

    Restarted NetworkManager:

    Code:
    service NetworkManager restart
    1. Open “Settings” via “Activities” or the menu next to your battery indicator.
    2. Go to "Network" and press the [+] button in the bottom left corner of the dialog.
    3. Choose "Point-to-Point Tunneling Protocol (PPTP)"
    4. Fill in "Name", "Gateway" and "User name"
    5. Press the "IPsec Settings" button
    6. Select "Enable IPsec tunnel to L2TP host"
    7. Fill in "Pre-shared key"
    8. Press "OK", then "Apply"


    Connect by setting the connect button from “OFF” til “ON”

  3. #3
    Join Date
    Feb 2017
    Location
    UK
    Posts
    2

    Re: L2TP vpn connection doesn't work on F25

    Thanks for sharing Marie! I'm happy you've managed to get it working... unfortunately I still can't say the same;


    I don't have the "IPsec Settings" button in the PPTP VPN dialog, it's only present in the L2TP one... do you have any other NetworkManager or IPsec related packages installed?


    I'm still having to use my workaround for when I'm working from home, which involves a Windows VM where I have the WatchGuard VPN client (that's what my company uses)... I don't like it but it's the lesser evil when I have to work from home.


    Cheers
    Beats

  4. #4
    Join Date
    Sep 2005
    Location
    Denmark
    Posts
    130

    Thumbs up Re: L2TP vpn connection doesn't work on F25

    Sorry for the late reply. It's been a busy summer :-/

    I needed the vpn today and suddenly it wasn't working. This is most likely because of a recent update. I had 1330 package updates waiting

    I noticed that the "IPsec Settings" button had disappeared from "Point-to-Point Tunneling Protocol (PPTP)". Instead I am using "Layer 2 Tunneling Protocol (L2TP)".

    But still it wasn't working, so I've been Googling and experimenting for a few hours. For me, the answer was here: https://askubuntu.com/questions/9042...u-16-04/909380

    Apparently the VPN server is using a legacy cipher that resent strongSwan versions consider to be broken.

    So now I set it up like this:

    1. Open “Settings” via “Activities” or the menu next to your battery indicator.
    2. Go to "Network" and press the [+] button in the bottom left corner of the dialog.
    3. Choose "Layer 2 Tunneling Protocol (L2TP)"
    4. Fill in "Name", "Gateway" and "User name"
    5. Press the "IPsec Settings" button
    6. Select "Enable IPsec tunnel to L2TP host"
    7. Fill in "Pre-shared key" (I leave the "Gateway ID" field empty)
    8. Set "Phase1 Algorithms" to 3des-sha1-modp1024
    9. Set "Phase2 Algorithms" to 3des-sha1
    10. Press "OK", then "Apply"




    Hope this helps

Similar Threads

  1. How to configure L2tp connection on Fedora 20
    By darrennn in forum Servers & Networking
    Replies: 0
    Last Post: 4th October 2014, 04:11 PM
  2. Replies: 0
    Last Post: 13th August 2011, 06:18 PM
  3. [SOLVED] NetworkManager vpn connection doesn t work after fc15 upgrading
    By bruno2040 in forum Servers & Networking
    Replies: 7
    Last Post: 1st June 2011, 10:02 PM
  4. GPRS connection doesn`t work | Help
    By taorapp in forum Using Fedora
    Replies: 0
    Last Post: 15th May 2009, 09:43 PM
  5. Simple internet connection but it doesn't work
    By Ford in forum Servers & Networking
    Replies: 0
    Last Post: 25th February 2008, 05:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •