[SOLVED] Alsamixer settings
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    494

    Alsamixer settings

    Not sure exactly where to post this question, but this forum doesn't seem too far off.

    For two builds (F23 and F24, IIRC), I could not get alsamixer to save it's settings. Using F6 under alsamixer, it's not clear what the default is, but when I select the correct sound card, I always find my headphone output is muted.

    The command alsactl store is supposed to save the settings. It did for me once (and forever more) in F25, until I re-installed F25 last month when I replaced my hard drive. Now I can't get the settings to stick across reboots. Selecting the right soundcard and turning on output for the headphones is now a habit.

    I tried that alsactl command under root and rebooted to no effect. Under the usual user logon, I get the following error:
    Code:
    $ file /var/lib/alsa/asound.state lock error: File exists
    Should I delete the file and try again? Are there any work-arounds?

    Thanks

  2. #2
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    948

    Re: Alsamixer settings

    Question, do you only want to work with Alsa ?

    what happens if you install "pavucontrol" (Pulse Audio front end), and you select the "Configuration" Tab to Analog Out , and then on your Output Devices, Select Headphones.

    then quit out of the dialog, make sure you can play sound via your Headphones, and reboot.
    and PTG it works ......

  3. #3
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    494

    Re: Alsamixer settings

    I've never tried pavucontrol, bobx. But that sounds like it's worth a shot. So I will - thanks.

  4. #4
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,810

    Re: Alsamixer settings

    Check if your alsa-state.service is running.
    Code:
    $ systemctl --no-pager status alsa-state.service
    ● alsa-state.service - Manage Sound Card State (restore and store)
       Loaded: loaded (/usr/lib/systemd/system/alsa-state.service; static; vendor preset: disabled)
       Active: active (running) since Mon 2017-02-13 18:58:56 EST; 41min ago
     Main PID: 751 (alsactl)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/alsa-state.service
               └─751 /usr/sbin/alsactl -s -n 19 -c -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf --initfile=/lib/alsa/i...
    
    Feb 13 18:58:56 Brody systemd[1]: Started Manage Sound Card State (restore and store).
    Feb 13 18:58:56 Brody alsactl[751]: alsactl 1.1.1 daemon started
    I recall that several releases ago, before pulseaudio really took over, in order to get "alsactl store" to work, I had to do a chown on the asound.state file as it was (and still is) only writable by root.

    -rw-r--r--. 1 root root 6305 Feb 13 19:04 /var/lib/alsa/asound.state

    But with pulseaudio nowadays, it just seems to work as it should.
    Last edited by PabloTwo; 14th February 2017 at 01:52 AM.

  5. #5
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    948

    Re: Alsamixer settings

    Quote Originally Posted by jbuckley2004
    I've never tried pavucontrol, bobx. But that sounds like it's worth a shot. So I will - thanks.
    Yeah !, when you install it, it will show up under Applications -> Multimedia I think. (don't know what Window Manager you use though).

    and the dialog is usually small when you open it the first time, you need to expand it to the right, so you can see all Tabs. (the key is the last one on the right, called Configuration).

  6. #6
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    494

    Re: Alsamixer settings

    Pablo, I got pretty much the same as you showed for systemctl --no-pager status alsa-state.service.
    It returned
    Code:
    ● alsa-state.service - Manage Sound Card State (restore and store)
       Loaded: loaded (/usr/lib/systemd/system/alsa-state.service; static; vendor preset: disabled)
       Active: active (running) since Mon 2017-02-13 15:55:53 EST; 10h ago
     Main PID: 770 (alsactl)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/alsa-state.service
               └─770 /usr/sbin/alsactl -s -n 19 -c -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf --initfile=/lib/alsa/i...
    
    Feb 13 15:55:53 Pluto systemd[1]: Started Manage Sound Card State (restore and store).
    Feb 13 15:55:53 Pluto alsactl[770]: alsactl 1.1.1 daemon started
    So does that mean the daemon wasn't running before? Or, was it running all along? Man... Us IT people (and I R one) need to learn to write our program's information messages in full English sentences with correct syntax. AMIRIGHT?

    And ls -l for asound.state returns
    -rw-r--r--. 1 root root 17200 Feb 13 16:02 asound.state, just as it should.

    Bobx, I'll be trying pavucontrol in the morning.

  7. #7
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    494

    Re: Alsamixer settings

    Bobx, I just tried pavucontrol, and that seemed to work! After rebooting, my headphones (uh, earbuds, actually) are "on". I'll mark this thread as "solved."

    Pavucontrol needs to have an "apply" or "save config" button, though. Probably a "restore defaults" button too. One has to hold one's breath and hope the selected config is close, and not about to start "Thermonuclear Warfare" (That's a classical reference, as Instapundit fans will recognize).

    I'll have to play with it a bit to get comfortable with all the options, but it sure solved my immediate problem.

  8. #8
    Join Date
    Feb 2008
    Location
    Sydney Australia
    Age
    63
    Posts
    2,588

    Re: Alsamixer settings

    Quote Originally Posted by jbuckley2004
    I'll have to play with it a bit to get comfortable with all the options, but it sure solved my immediate problem.
    There is a basic guide to pavucontrol on the Korora site, https://kororaproject.org/support/do...ol-pavucontrol

Similar Threads

  1. Alsamixer not remembering settings?
    By jbuckley2004 in forum Using Fedora
    Replies: 2
    Last Post: 14th February 2016, 03:04 PM
  2. alsamixer default settings
    By pmreid in forum Using Fedora
    Replies: 2
    Last Post: 22nd February 2006, 12:32 AM
  3. alsamixer settings are not restored
    By makuz in forum Using Fedora
    Replies: 6
    Last Post: 12th April 2005, 12:57 PM
  4. Alsamixer settings: Can't save them!
    By GrahamB in forum Hardware & Laptops
    Replies: 0
    Last Post: 21st March 2005, 01:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •