In Fedora 24, Mouse Wheel Works in Reverse - Page 2
FedoraForum.org - Fedora Support Forums and Community
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 16 to 30 of 32
  1. #16
    Join Date
    Oct 2005
    Location
    British Columbia, Canada
    Posts
    896
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Quote Originally Posted by kldixon
    I have not installed F24 yet but, in F23, the following switch controls the scroll direction, and seems to work:
    /org/gnome/desktop/peripherals/mouse/natural-scroll
    You can change it with dconf-editor or gsettings:
    Code:
    $ gsettings get org.gnome.desktop.peripherals.mouse natural-scroll
    false
    $ gsettings set org.gnome.desktop.peripherals.mouse natural-scroll true
    $ gsettings get org.gnome.desktop.peripherals.mouse natural-scroll
    true
    It is possible that Settings is not working properly,. There is no natural scroll option in F23.
    Hi
    I can attest to the fact that I had a similar problem and I fixed it by using dconf-editor and setting 'natural scroll' to false. I was not sure how it got into that state but this solution fixed it.
    Robert :)

  2. #17
    Join Date
    Aug 2011
    Location
    ~
    Posts
    1,959
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Disabling natural scroll doesn't do anything to fix the VirtualBox problem. I tried lots of things with xinput too (changing the button layout) but nothing seems to work. It's all good and dandy that libinput is the next big thing in driving devices, but it is causing lots of problems. I have been removing the libinput driver on my notebook since F22 or something because it scrolls horribly and doesn't work (yet) with all tools that are made for Xorg/evdev (e.g., easystroke).

    I really don't care about disabling the touchpad when a mouse is plugged in (been there, didn't like it, getting this right requires lots of complexity and for now it is easier to simply don't come too close to the thing). I get that this project is a big clean-up of the way too complicated older stack and in the end will mean that it will work better and will get fancy modern features. However, there are just too many bugs and oversights for this thing to be pushed as heavily as it is. Removing the driver in case of problems seems to work just fine for now and I will keep doing that where necessary.

  3. #18
    Join Date
    Jul 2016
    Location
    Uzbekistan
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    This bug in the kernel 4.6
    Select the old kernel 4.5, scrolling will be normal

    I have this problem. Installed system, all works fine, but after the upgrade, scrolling changed.

    ask.fedoraproject.org

    bugzilla.redhat.com
    Last edited by KOTBMAPT; 29th July 2016 at 01:01 PM.

  4. #19
    Join Date
    Aug 2016
    Location
    London
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile Re: In Fedora 24, Mouse Wheel Works in Reverse

    neither gsettings nor the gnome settings gui made a difference; though the setting ostensibly 'stuck' as true/false;

    KOTBMAPT's ask.fedoraproject.org link has the answer that worked for me though
    Code:
    $ xmodmap -e 'pointer = 1 2 3 5 4'
    to just swap the mouse buttons around

  5. #20
    Join Date
    Oct 2006
    Location
    新加坡
    Posts
    998
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    I used to use the xmodmap also, but now change to use xinput to flip the scrolling distance property. See http://forums.fedoraforum.org/showthread.php?t=298702. At first I was very happy to find there is a new option to turn on the natural scrolling in the Mouse & Touchpad setting, but I was soon disappointed like the other posters in this thread. I observed that flipping the option in the GUI just flips the boolean in the gsettings without actually making any effect on the scrolling itself. To that matter, I still have problem with my mouse sensitivity setting. Sliding the mouse speed slider to either extreme does not appear to take any effect at all!
    YaoWT - Leave no window unbroken ♪ (^。^) 

  6. #21
    Join Date
    Oct 2011
    Posts
    1,917
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    That problems may be at driver level, missing proper support for your mouse, or your mouse is using generic driver but is not acting like most generic mouses in the wild so it needs special code. Try xev. For me button 4 is used for scrolling up and button 5 for down.

    $ grep "Handlers=mouse" -C 6 /proc/bus/input/devices

  7. #22
    Join Date
    Aug 2010
    Location
    México City
    Age
    63
    Posts
    46
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    I found a solution here

    It suggests to installa a package
    dnf install xorg-x11-drv-libinput
    Some say it worked for them.
    It didn't work for me
    El paquete xorg-x11-drv-libinput-0.19.0-2.fc24.x86_64 ya se encuentra instalado, omitiendo.
    Dependencias resueltas.
    Nada por hacer.
    (Package already installed.)

  8. #23
    Join Date
    Aug 2011
    Location
    ~
    Posts
    1,959
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Quote Originally Posted by mackissack
    I found a solution here

    It suggests to installa a package


    Some say it worked for them.
    It didn't work for me

    (Package already installed.)
    That's about the touch pad, not the mouse wheel.

  9. #24
    Join Date
    Oct 2015
    Location
    Seattle
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Scroll wheel is reversed, FC24 under VirtualBox. Natural scrolling and even xmodmap didn't fix it.

    Oh well, maybe next year will be the year of the linux desktop.

  10. #25
    Join Date
    Oct 2006
    Location
    新加坡
    Posts
    998
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    I am using the "system-wide natural scrolling" approach (see the link in my previous post). It works for both the host OS and guest OS. Don't use the Gnome setting to configure it and all should be fine. The only drawback with the xinput approach described in the link is the device id may change when you hot plug the USB and the property id for reversing the direction may also change when evdev driver changes.
    YaoWT - Leave no window unbroken ♪ (^。^) 

  11. #26
    Join Date
    Sep 2006
    Location
    Berlin, Germany
    Age
    39
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    For me the solution with xinput mentioned in the kernel bug report at Red Hat bugzilla worked: https://bugzilla.redhat.com/show_bug.cgi?id=1352159#c35

    What I did:
    1. List the input devices:
      Code:
      xinput | grep pointer
      which showed me the following list:
      Code:
      ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
      ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
      ⎜   ↳ ImExPS/2 BYD TouchPad                   	id=9	[slave  pointer  (2)]
    2. I am sitting on a desktop computer with a logitech mouse. No touchpad here! But I used the touchpad listed to set the property to false (= 0):
      Code:
      xinput set-prop 'ImExPS/2 BYD TouchPad' 'libinput Natural Scrolling Enabled' 0


    That worked. :-)

    Edit: For a permanent solution, see my next next answer which uses gsettings to set the scroll direction permanently per user.
    Last edited by wicking; 19th December 2016 at 07:35 AM.
    Workstation: Fedora 17, AMD Athlon X2 BE-2400, 12 GB RAM, 120 + 300 + 640 GB HDD
    Notebook: Fedora 17 LXDE, IBM Thinkpad X40, 1,5 GB RAM
    Notebook: Fedora 18 LXDE, IBM Thinkpad T23, 256 MB RAM

    Registered Linux User #344145

  12. #27
    Join Date
    Dec 2016
    Location
    Spain
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Quote Originally Posted by wicking
    For me the solution with xinput mentioned in the kernel bug report at Red Hat bugzilla worked: https://bugzilla.redhat.com/show_bug.cgi?id=1352159#c35

    What I did:
    1. List the input devices:
      Code:
      xinput | grep pointer
      which showed me the following list:
      Code:
      ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
      ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
      ⎜   ↳ ImExPS/2 BYD TouchPad                   	id=9	[slave  pointer  (2)]
    2. I am sitting on a desktop computer with a logitech mouse. No touchpad here! But I used the touchpad listed to set the property to false (= 0):
      Code:
      xinput set-prop 'ImExPS/2 BYD TouchPad' 'libinput Natural Scrolling Enabled' 0


    That worked. :-)
    Thanks a lot. This solution worked for me, but I had to enter this command everytime I turned on the computer. Anyway, it helped me to figure up the issue was the system was detecting my mouse as a touchpad. An easier and ultimate solution was configure the touchpad with natural scroll disabled in Dconf.

    This problem only happen to me in xorg desktop. It looks it is fixed on a Wayland session.

    I am sorry for my broken english.

  13. #28
    Join Date
    Sep 2006
    Location
    Berlin, Germany
    Age
    39
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Quote Originally Posted by Garbancito
    Thanks a lot. This solution worked for me, but I had to enter this command everytime I turned on the computer. Anyway, it helped me to figure up the issue was the system was detecting my mouse as a touchpad. An easier and ultimate solution was configure the touchpad with natural scroll disabled in Dconf.

    This problem only happen to me in xorg desktop. It looks it is fixed on a Wayland session.

    I am sorry for my broken english.
    Can you tell me how you got a permanent solution with dconf exactly?
    Workstation: Fedora 17, AMD Athlon X2 BE-2400, 12 GB RAM, 120 + 300 + 640 GB HDD
    Notebook: Fedora 17 LXDE, IBM Thinkpad X40, 1,5 GB RAM
    Notebook: Fedora 18 LXDE, IBM Thinkpad T23, 256 MB RAM

    Registered Linux User #344145

  14. #29
    Join Date
    Dec 2016
    Location
    Spain
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Quote Originally Posted by wicking
    Can you tell me how you got a permanent solution with dconf exactly?
    Run the Dconf editor, search in /org/gnome/desktop/peripherals/touchpad.

    Turn natural-scroll to false.

    Since my desktop has no touchpad, that works perfect for me. I would be in trouble if i had a touchpad and wanted to configure natural scroll different way than the mouse.

    This issue is solved in Fedora 25 under Wayland, where the mouse is properly detected as an actual mouse. But i needed to log on xorg because of other problems.

  15. #30
    Join Date
    Sep 2006
    Location
    Berlin, Germany
    Age
    39
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: In Fedora 24, Mouse Wheel Works in Reverse

    Ok, that means you can set it permanently with
    Code:
    gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false
    in terminal. Great!
    Last edited by wicking; 19th December 2016 at 07:35 AM.
    Workstation: Fedora 17, AMD Athlon X2 BE-2400, 12 GB RAM, 120 + 300 + 640 GB HDD
    Notebook: Fedora 17 LXDE, IBM Thinkpad X40, 1,5 GB RAM
    Notebook: Fedora 18 LXDE, IBM Thinkpad T23, 256 MB RAM

    Registered Linux User #344145

Page 2 of 3 FirstFirst 1 2 3 LastLast

Similar Threads

  1. Fedora 10 Logitech Mouse Wheel
    By tomandnic in forum Hardware & Laptops
    Replies: 2
    Last Post: 1st January 2009, 10:20 PM
  2. Wheel mouse not working in Fedora 2
    By hellonymous in forum Installation, Upgrades and Live Media
    Replies: 9
    Last Post: 27th October 2004, 07:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •