[F24] Screen Blank/Garbled After Suspend
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2016
    Location
    US
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [F24] Screen Blank/Garbled After Suspend

    I have an EliteBook 8440p with an NVidia NVS 3100M running Fedora 24 w/ Nouveau drivers (Gallium 0.4 on NVA8). When the laptop wakes from suspend, the screen is stuck on a blank, white picture. Changing TTY's causes the image to become garbled and flicker across the screen, however the login screen or TTY is barely recognizable through the mess.

    I have tried using the Nvidia proprietary driver and confirmed it fixes this particular issue, however the vast number of other issues brought up by using the Nvidia driver is preventing me from using it. (Switches TTY after boot after a few mins, generally ugly boot process, driver crashes after a couple days, suspend on lid close doesn't work, and kernel updates brick the driver entirely).

    I also replaced the LCD in the laptop with a spare to rule out the issue being related to a faulty LCD. I came from Fedora 23, upgraded to Fedora 24, and have the latest updates from repos installed and the issue has persisted since first installing Fedora.

    [EDIT]: When resuming from suspend with an external monitor connected, the picture on the external monitor is ok, however the laptop LCD is stuck blank. I was able to capture some log output using "journalctl -f" on the second monitor. Attached is the output given.
    This seems to be a common issue that I have been unable to find any resolution for online, aside from "Install Nvidia". These are some additional links to other forum posts detailing the exact issue:
    http://superuser.com/questions/10570...raining-failed
    https://bbs.archlinux.org/viewtopic.php?id=197388
    Attached Files Attached Files
    Last edited by Dolphykins; 8th July 2016 at 12:09 AM. Reason: Attached Journalctl Output, links to other posts detailing same issue, censored journalctl output

  2. #2
    Join Date
    Jul 2016
    Location
    US
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [F24] Screen Blank/Garbled After Suspend

    The issue is still present and I haven't been able to find a fix yet. I noticed when I switch TTY's, the one I was logged into before suspending starts filling up with "Link Training Failed".

    This is the output of dmesg when switching TTY's and the main LCD isn't able to recover from the blank white screen:
    [ 253.725178] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 253.964581] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 253.965611] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link not trained before attach
    [ 262.074933] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 262.081719] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 262.082749] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link not trained before attach
    [ 264.091618] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 264.318266] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 264.319290] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link not trained before attach
    [ 270.115821] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 270.122646] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link training failed
    [ 270.123698] nouveau 0000:01:00.0: disp: outp 00:0006:0344: link not trained before attach

  3. #3
    Join Date
    May 2016
    Location
    Fayetteville, Arkansas, USA
    Posts
    261
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [F24] Screen Blank/Garbled After Suspend

    I found a bug report that is just like what your dealing with. You might want to have a look at it and see what they have to say.

    https://bugs.freedesktop.org/show_bug.cgi?id=91954

    I know how frustrating this must be for you and I hope you get it figured out soon.

    David

  4. #4
    Join Date
    Jul 2016
    Location
    US
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [F24] Screen Blank/Garbled After Suspend

    Thanks, I added onto the Bugzilla thread with details for my case. Looks like they got the issue resolved as of 4.5 for that particular setup, however I'm still running into it on 4.6.3

  5. #5
    Join Date
    Jul 2016
    Location
    US
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [F24] Screen Blank/Garbled After Suspend

    This issue is still occurring and has not been resolved yet.

    Fedora 24, latest updates, Gnome and LXDE both experience issue, along with login screen.
    GDM 3.20.1
    Nouveau running on 4.8.7-200.fc24.x86_64

Similar Threads

  1. Fedora 10 resuming from suspend - blank screen
    By crisponions in forum Hardware & Laptops
    Replies: 28
    Last Post: 24th July 2009, 07:37 PM
  2. Get a Blank/Black Screen when i SUSPEND
    By infernosoft in forum Using Fedora
    Replies: 0
    Last Post: 8th December 2008, 07:47 PM
  3. blank screen after suspend?
    By blackpantha in forum Using Fedora
    Replies: 4
    Last Post: 29th July 2008, 07:36 PM
  4. Dark screen (not blank) after suspend
    By El_BrandO in forum Hardware & Laptops
    Replies: 7
    Last Post: 6th July 2008, 07:38 AM
  5. Blank Screen after Hibernate/suspend
    By Jacky_F7 in forum Hardware & Laptops
    Replies: 3
    Last Post: 25th July 2007, 11:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •