[SOLVED] MATE-Compiz - No ibus chinese input support
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20
  1. #1
    Join Date
    Jan 2011
    Posts
    216
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    MATE-Compiz - No ibus chinese input support

    I have just installed Fedora 23. I like it, but ibus is not working/starting. I get:

    [pedro@localhost ~]$ ibus restart
    Can't connect to IBus.
    [pedro@localhost ~]$ sudo ibus restart
    [sudo] password for pedro:
    Can't connect to IBus.
    [pedro@localhost ~]$
    I first tried sudo dnf reinstall ibus but that did not help. I am using Mate desktop.

    Any tips out there please?

    edit: I started gnome desktop and pinyin input works
    Last edited by Pedroski; 3rd March 2016 at 05:10 AM.

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    7,155
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)

    Re: ibus chinese input can't start

    try this instead:

    Code:
    sudo yum-deprecated distro-sync
    followed by restarting the computer.

  3. #3
    Join Date
    Jan 2011
    Posts
    216
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ibus chinese input can't start

    Thanks! Can you give me that for dnf? Seems yum is out in Fed 23?

  4. #4
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    7,155
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)

    Re: ibus chinese input can't start

    yum-deprecated is the command to run yum

    anyhow, the same applies for dnf but I find yum-deprecated gives more reliable transaction results still

    Code:
    sudo dnf distro-sync

  5. #5
    Join Date
    Jan 2011
    Posts
    216
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ibus chinese input can't start

    Thanks again! Did that,

    [pedro@localhost ~]$ sudo dnf distro-sync
    Last metadata expiration check performed 0:00:58 ago on Fri Mar 4 07:10:38 2016.
    Dependencies resolved.
    Nothing to do.
    Complete!
    [pedro@localhost ~]$

    but still get:

    [pedro@localhost ~]$ ibus restart
    Can't connect to IBus.
    [pedro@localhost ~]$
    No pinyin input in Mate! Not a biggie, I can use gnome. I just wonder why it is not working.

  6. #6
    Join Date
    Aug 2017
    Location
    US
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ibus chinese input can't start

    Edit: This problem has been SOLVED. Please see subsequent posts.

    Quote Originally Posted by Pedroski
    No pinyin input in Mate! Not a biggie, I can use gnome. I just wonder why it is not working.
    I am having a different problem with Fedora MATE 26. The top panel shows ibus is running and the Chinese input engine has started, but I am unable to input Chinese characters.

    I have dnf groupinstalled gnome-desktop, but MATE still does not allow me to input Chinese. I am also not able to switch to gnome desktop.

    I am so used to MATE; right now, I am getting around this problem by:

    1. install official/default Fedora (gnome shell)
    2. dnf groupinstall mate-desktop

    then log into MATE desktop. Then, I can use ibus to input Chinese characters.

    Hope someone can help solve this problem.

    Edit: This problem has been SOLVED. Please see subsequent posts.
    Last edited by pingwu; 24th August 2017 at 06:40 PM.

  7. #7
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    7,155
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    please install ibus-libpinyin if not present on your system and try again

  8. #8
    Join Date
    Aug 2017
    Location
    US
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    Quote Originally Posted by antikythera
    please install ibus-libpinyin if not present on your system and try again
    My system already has ibus-libpinyin, ibus-pinyin and ibus-rime installed.

    I think the problem must be related to the way Fedora's MATE-compiz spin is structured. I don't have problem inputting Chinese characters if I install Fedora first, then use groupinstall to add the MATE desktop.

    The MATE panel clearly shows that the Chinese input engine, such as ibus-libpinyin or ibus-rime, has been activated. But I cannot input Chinese characters. Pressing the trigger keys doesn't show any effect.

  9. #9
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    7,155
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    possibly is then. It's not something I have experience with. I just came across an old bug thread that suggested ibus-libpinyin may not be installed. check it out though as there may be more clues in it about how to get it working without installing Workstation first. be advised it dates back to Fedora 19 so there may be a few differences.

    https://bugzilla.redhat.com/show_bug.cgi?id=1002417

  10. #10
    Join Date
    Apr 2016
    Location
    Malaysia
    Age
    23
    Posts
    165
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    Apparently something change and Ibus Preferences no longer show up where it used to be...

    There used to be a way to access Ibus Preferences from the (drop down?) Menus but seems disappeared or broken (have to check back 25)

    You can unhidden the Ibus Preferences by go to System > Look and Feel > Main Menu

    Or just start from terminal, ibus-setup
    https://github,com/truboxl

  11. #11
    Join Date
    Aug 2017
    Location
    US
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    Right click on the ibus icon on the panel bar will show the preference option.

    I don't have any problem with either Fedora or Fedora MATE doing this.

    The problem is that, after I switched from EN to any kind of Chinese input engine (pinyin, libpinyin, or rime), no Chinese character is shown.

    This problem only occurred with Fedora MATE; it was perfectly OK with Fedora (gnome).

    To recap, everything appeared to be normal with Fedora MATE, but switching from EN to Chinese does not do anything.

  12. #12
    Join Date
    Aug 2017
    Location
    US
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    To further illustrate this problem, I installed to seemingly identical systems: System 1 is "Fedora (gnome) + mate desktop", and System 2 is "Fedora MATE respin".

    System 1 has no problem outputting Chinese characters. 输入中文完全没有问题.

    In System 2, under exactly the same conditions, including the mate panel shows that the ibus has been switched to Chinese input, only English letters came out. No Chinese.

    Again, the "can't input Chinese characters" problem seems to be caused by the way Fedora MATE respin was put together.
    Last edited by pingwu; 21st August 2017 at 09:08 PM.

  13. #13
    Join Date
    Apr 2016
    Location
    Malaysia
    Age
    23
    Posts
    165
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    what do you mean?

    I boot straight from Mate Compiz USB Live and
    then switch to Ibus and
    (drop down preferences isn't there, only EN-US, have to ibus-setup) pick PinYin

    Followed by Win + Tab, I can type 拼音 (pinyin)
    https://github,com/truboxl

  14. #14
    Join Date
    Aug 2017
    Location
    US
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    Quote Originally Posted by TruboXL
    what do you mean?

    I boot straight from Mate Compiz USB Live and
    then switch to Ibus and
    (drop down preferences isn't there, only EN-US, have to ibus-setup) pick PinYin

    Followed by Win + Tab, I can type 拼音 (pinyin)
    Can you describe in better detail what you meant by "switch to ibus"? Thanks! (Looks like there is hope! 看起来这个问题有希望解决了!)

    I burned another Live USB (MATE-Compiz 26), and typed in

    ibus-daemon &

    to start ibus.

    Then I used ibus-setup to add libpinyin (there is no pinyin).

    Everything seems to be as expected, except I still couldn't type Chinese characters.
    Last edited by pingwu; 22nd August 2017 at 08:56 AM.

  15. #15
    Join Date
    Aug 2017
    Location
    US
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: MATE-Compiz - No ibus chinese input support

    Quote Originally Posted by pingwu
    Can you describe in better detail what you meant by "switch to ibus"? Thanks!
    I am answering my own question.

    In Fedora MATE, I have to go to Input Method Selector, select ibus, then log out and re-log in. Problem solved!

    In Fedora Gnome, once I start the ibus-daemon, it appears to be automatically selected. No need to go thru the above step.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. mate-compiz 25.1707.en_GB and mate-compiz 26.1708 custom
    By antikythera in forum Fedora Spins & Remixes
    Replies: 3
    Last Post: 4th August 2017, 10:17 AM
  2. Chinese ibus input not working anymore
    By naix37 in forum Using Fedora
    Replies: 8
    Last Post: 25th July 2013, 03:08 PM
  3. [Fedora 16] iBus Chinese pinyin input method with tone marks wanted
    By machinegodzilla in forum EOL (End Of Life) Versions
    Replies: 0
    Last Post: 9th April 2013, 03:10 PM
  4. chinese input support in fedora 3
    By ksmj in forum Using Fedora
    Replies: 3
    Last Post: 30th December 2004, 05:44 AM
  5. Replies: 9
    Last Post: 25th May 2004, 02:57 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •