FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Oct 2015
    Location
    Oklahoma
    Posts
    1

    Fedora on Mac Pro 3,1 (Early 2008)

    I'm having the infamous "No Screens Found" with Fedora 22. No longer have time to search through logs right now, so i have them saved for you guys...
    Piped startx output:
    Code:
    xauth:  file /root/.serverauth.1799 does not exist
    
    
    X.Org X Server 1.17.1
    Release Date: 2015-02-10
    X Protocol Version 11, Revision 0
    Build Operating System:  3.19.5-200.fc21.x86_64 
    Current Operating System: Linux Jonathans-Pro 4.0.4-301.fc22.x86_64 #1 SMP Thu May 21 13:10:33 UTC 2015 x86_64
    Kernel command line: BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
    Build Date: 11 May 2015  02:32:58PM
    Build ID: xorg-x11-server 1.17.1-11.fc22 
    Current version of pixman: 0.32.6
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 27 21:09:32 2015
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    (EE) 
    Fatal server error:
    (EE) no screens found(EE) 
    (EE) 
    Please consult the Fedora Project support 
    	 at http://wiki.x.org
     for help. 
    (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    (EE) 
    (EE) Server terminated with error (1). Closing log file.
    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    Xorg.0.log
    Code:
    [   360.778] 
    X.Org X Server 1.17.1
    Release Date: 2015-02-10
    [   360.779] X Protocol Version 11, Revision 0
    [   360.780] Build Operating System:  3.19.5-200.fc21.x86_64 
    [   360.781] Current Operating System: Linux Jonathans-Pro 4.0.4-301.fc22.x86_64 #1 SMP Thu May 21 13:10:33 UTC 2015 x86_64
    [   360.781] Kernel command line: BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-22-3 ro rd.live.image quiet rhgb
    [   360.782] Build Date: 11 May 2015  02:32:58PM
    [   360.782] Build ID: xorg-x11-server 1.17.1-11.fc22 
    [   360.783] Current version of pixman: 0.32.6
    [   360.784] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [   360.784] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   360.787] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 27 20:51:39 2015
    [   360.788] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [   360.788] (==) No Layout section.  Using the first Screen section.
    [   360.788] (==) No screen section available. Using defaults.
    [   360.788] (**) |-->Screen "Default Screen Section" (0)
    [   360.788] (**) |   |-->Monitor "<default monitor>"
    [   360.788] (==) No monitor specified for screen "Default Screen Section".
    	Using a default monitor configuration.
    [   360.788] (==) Automatically adding devices
    [   360.788] (==) Automatically enabling devices
    [   360.788] (==) Automatically adding GPU devices
    [   360.788] (==) FontPath set to:
    	catalogue:/etc/X11/fontpath.d,
    	built-ins
    [   360.788] (==) ModulePath set to "/usr/lib64/xorg/modules"
    [   360.788] (II) The server relies on udev to provide the list of input devices.
    	If no devices become available, reconfigure udev or disable AutoAddDevices.
    [   360.788] (II) Loader magic: 0x81ade0
    [   360.788] (II) Module ABI versions:
    [   360.788] 	X.Org ANSI C Emulation: 0.4
    [   360.788] 	X.Org Video Driver: 19.0
    [   360.788] 	X.Org XInput driver : 21.0
    [   360.788] 	X.Org Server Extension : 9.0
    [   360.789] (++) using VT number 2
    
    [   360.791] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_32
    [   360.791] (II) xfree86: Adding drm device (/dev/dri/card0)
    [   360.791] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
    [   360.794] (--) PCI:*(0:2:0:0) 10de:0602:10de:057c rev 162, Mem @ 0x92000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x00002000/128, BIOS @ 0x????????/131072
    [   360.794] (II) LoadModule: "glx"
    [   360.794] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [   360.795] (II) Module glx: vendor="X.Org Foundation"
    [   360.795] 	compiled for 1.17.1, module version = 1.0.0
    [   360.795] 	ABI class: X.Org Server Extension, version 9.0
    [   360.795] (==) AIGLX enabled
    [   360.795] (==) Matched nouveau as autoconfigured driver 0
    [   360.795] (==) Matched nv as autoconfigured driver 1
    [   360.795] (==) Matched nouveau as autoconfigured driver 2
    [   360.795] (==) Matched nv as autoconfigured driver 3
    [   360.795] (==) Matched modesetting as autoconfigured driver 4
    [   360.795] (==) Matched fbdev as autoconfigured driver 5
    [   360.795] (==) Matched vesa as autoconfigured driver 6
    [   360.795] (==) Assigned the driver to the xf86ConfigLayout
    [   360.795] (II) LoadModule: "nouveau"
    [   360.795] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
    [   360.795] (II) Module nouveau: vendor="X.Org Foundation"
    [   360.795] 	compiled for 1.17.1, module version = 1.0.11
    [   360.795] 	Module class: X.Org Video Driver
    [   360.795] 	ABI class: X.Org Video Driver, version 19.0
    [   360.795] (II) LoadModule: "nv"
    [   360.796] (WW) Warning, couldn't open module nv
    [   360.796] (II) UnloadModule: "nv"
    [   360.796] (II) Unloading nv
    [   360.796] (EE) Failed to load module "nv" (module does not exist, 0)
    [   360.796] (II) LoadModule: "modesetting"
    [   360.796] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    [   360.796] (II) Module modesetting: vendor="X.Org Foundation"
    [   360.796] 	compiled for 1.17.1, module version = 1.17.1
    [   360.796] 	Module class: X.Org Video Driver
    [   360.796] 	ABI class: X.Org Video Driver, version 19.0
    [   360.796] (II) LoadModule: "fbdev"
    [   360.796] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [   360.796] (II) Module fbdev: vendor="X.Org Foundation"
    [   360.796] 	compiled for 1.17.1, module version = 0.4.3
    [   360.796] 	Module class: X.Org Video Driver
    [   360.796] 	ABI class: X.Org Video Driver, version 19.0
    [   360.796] (II) LoadModule: "vesa"
    [   360.796] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [   360.796] (II) Module vesa: vendor="X.Org Foundation"
    [   360.796] 	compiled for 1.17.1, module version = 2.3.2
    [   360.796] 	Module class: X.Org Video Driver
    [   360.796] 	ABI class: X.Org Video Driver, version 19.0
    [   360.796] (II) NOUVEAU driver 
    [   360.796] (II) NOUVEAU driver for NVIDIA chipset families :
    [   360.796] 	RIVA TNT        (NV04)
    [   360.796] 	RIVA TNT2       (NV05)
    [   360.796] 	GeForce 256     (NV10)
    [   360.796] 	GeForce 2       (NV11, NV15)
    [   360.796] 	GeForce 4MX     (NV17, NV18)
    [   360.796] 	GeForce 3       (NV20)
    [   360.796] 	GeForce 4Ti     (NV25, NV28)
    [   360.796] 	GeForce FX      (NV3x)
    [   360.796] 	GeForce 6       (NV4x)
    [   360.796] 	GeForce 7       (G7x)
    [   360.796] 	GeForce 8       (G8x)
    [   360.796] 	GeForce GTX 200 (NVA0)
    [   360.796] 	GeForce GTX 400 (NVC0)
    [   360.797] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [   360.797] (II) FBDEV: driver for framebuffer: fbdev
    [   360.797] (II) VESA: driver for VESA chipsets: vesa
    [   360.797] (II) [drm] nouveau interface version: 1.2.1
    [   360.797] (WW) Falling back to old probe method for modesetting
    [   360.797] (WW) Falling back to old probe method for fbdev
    [   360.797] (II) Loading sub module "fbdevhw"
    [   360.797] (II) LoadModule: "fbdevhw"
    [   360.797] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [   360.797] (II) Module fbdevhw: vendor="X.Org Foundation"
    [   360.797] 	compiled for 1.17.1, module version = 0.0.2
    [   360.797] 	ABI class: X.Org Video Driver, version 19.0
    [   360.797] (WW) Falling back to old probe method for vesa
    [   360.797] (EE) No devices detected.
    [   360.797] (EE) 
    Fatal server error:
    [   360.797] (EE) no screens found(EE) 
    [   360.797] (EE) 
    Please consult the Fedora Project support 
    	 at http://wiki.x.org
     for help. 
    [   360.797] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [   360.797] (EE)
    My Mac Pro model is Early 2008 (Mac Pro 3,1) with the 2.8 Ghz Quad Core Xeon. Fedora version is Fedora 22 Workstation
    From about this mac on my Graphics Card:
    Code:
    NVIDIA GeForce 8800 GT:
    
      Chipset Model:	NVIDIA GeForce 8800 GT
      Type:	GPU
      Bus:	PCIe
      Slot:	Slot-1
      PCIe Lane Width:	x16
      VRAM (Total):	512 MB
      Vendor:	NVIDIA (0x10de)
      Device ID:	0x0602
      Revision ID:	0x00a2
      ROM Revision:	3233
      Displays:
    
    DELL SE198WFP:
      Resolution:	1440 x 900 @ 75 Hz
      Pixel Depth:	32-Bit Color (ARGB8888)
      Display Serial Number:	GM77879617JU
      Main Display:	Yes
      Mirror:	Off
      Online:	Yes
      Rotation:	Supported
    Is this an unrecoverable, lack of driver support issue?

  2. #2
    Join Date
    Oct 2015
    Location
    Las Vegas, NV
    Posts
    2

    Re: Fedora on Mac Pro 3,1 (Early 2008)

    I've had the same problem with some distros on my Mac Pro, even though I happen to have an ATI card. This happened on Arch and Gentoo, and openSUSE, and Fedora wouldn't boot even with boot options set. Only Debian, Ubuntu and Mint have worked for me on this computer, which is a shame since I have been wanting either Gentoo or Fedora on there.

Similar Threads

  1. Fedora 16 installation with 2008 R2 Hyper-v
    By Ron Henn in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 13th January 2012, 09:03 AM
  2. Fedora 15 on Macbook 4.1 (2008)
    By nevius in forum Mac Chat
    Replies: 0
    Last Post: 18th August 2011, 09:14 AM
  3. Maya 2008 in Fedora 8
    By fasteddbee in forum Using Fedora
    Replies: 2
    Last Post: 8th April 2008, 04:39 AM
  4. Can Maya 2008 run in Fedora Core 8?
    By pumpkin_zch2u in forum Using Fedora
    Replies: 18
    Last Post: 25th February 2008, 08:40 AM
  5. Fedora 8 and Mandriva 2008?
    By medo1983 in forum Using Fedora
    Replies: 4
    Last Post: 21st January 2008, 08:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •