Firefox safe mode & libvdpau_nouveau.so
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2007
    Posts
    336
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Firefox safe mode & libvdpau_nouveau.so

    I'm getting this message when I run Firefox in safe mode:

    Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory

    Should I have this file?

    I'm getting severe CPU thrashing/churning on some websites even though I'm doing nothing but reading text.

    Will loading this file solve the problem?

  2. #2
    Join Date
    Jul 2008
    Posts
    1,348
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox safe mode & libvdpau_nouveau.so

    It may, it may not. Install mesa-vdpau-drivers and see if it does.

  3. #3
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,981
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox safe mode & libvdpau_nouveau.so

    Below showing results for both 32 and 64 bit F22 packages of mesa-vdpau-drivers.
    Code:
    $ sudo dnf repoquery -l mesa-vdpau-drivers | grep nouveau
    /usr/lib/vdpau/libvdpau_nouveau.so.1
    /usr/lib/vdpau/libvdpau_nouveau.so.1.0
    /usr/lib/vdpau/libvdpau_nouveau.so.1.0.0
    /usr/lib64/vdpau/libvdpau_nouveau.so.1
    /usr/lib64/vdpau/libvdpau_nouveau.so.1.0
    /usr/lib64/vdpau/libvdpau_nouveau.so.1.0.0
    /usr/lib/vdpau/libvdpau_nouveau.so.1
    /usr/lib/vdpau/libvdpau_nouveau.so.1.0
    /usr/lib/vdpau/libvdpau_nouveau.so.1.0.0
    /usr/lib64/vdpau/libvdpau_nouveau.so.1
    /usr/lib64/vdpau/libvdpau_nouveau.so.1.0
    /usr/lib64/vdpau/libvdpau_nouveau.so.1.0.0
    No libvdpau_nouveau.so. The two lower versions above (*.so.1 and *.so.1.0) are always just symlinks that point to the actual working binary which is the higher version...*.so.1.0.0.

  4. #4
    Join Date
    Jun 2007
    Posts
    336
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox safe mode & libvdpau_nouveau.so

    Thanks for the responses.

    So, this message

    Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory

    is just a notification?

  5. #5
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,981
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox safe mode & libvdpau_nouveau.so

    Yes, it's a notification that the file it's trying to access doesn't exist. In other words, since it doesn't exist (as a symlink that points to the actual working libpdvau_nouveau.so..... binary) then it can't access the working binary.

    This type of thing usually happens when an older program is trying to find a file that now doesn't exist due to updates to packages that provide that file, such as *.so.0 is dropped and is now *.so.1.

    The workaround would be to go into the directory that contains the newer libvdpau_nouveau.so.. files and create a new symlink (libvdpau_nouveau.so.0) which points to the working binary in that directory.

  6. #6
    Join Date
    Jun 2007
    Posts
    336
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox safe mode & libvdpau_nouveau.so

    This missing file is for Nvidia video acceleration. Correct? Would the notification still occur if I didn't use safe-mode? Would the notification still occur if I was using a BFGraphics card?

    I was using an Nvidia GT 620 graphics card. I just replaced it with an old Radeon HD 6850 and the churning/thrashing seems to have departed on the culprit websites. Might my problem have been caused by using an inadequate video card for a .com website overloaded with junk advertisements?

Similar Threads

  1. Firefox always starts in safe mode
    By jzc in forum Using Fedora
    Replies: 10
    Last Post: 5th September 2013, 07:21 PM
  2. firefox kills f13 even in safe mode
    By glhere in forum Using Fedora
    Replies: 12
    Last Post: 10th January 2011, 01:01 AM
  3. Replies: 2
    Last Post: 3rd January 2008, 12:29 PM
  4. safe mode
    By mjr in forum Servers & Networking
    Replies: 4
    Last Post: 29th May 2006, 08:04 PM
  5. FC3 safe mode?
    By fodder937 in forum Using Fedora
    Replies: 6
    Last Post: 7th January 2005, 06:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •