FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Aug 2015
    Location
    India
    Posts
    4

    (Solved)Legacy BIOS - Not able to dual boot

    Hello all experts,

    I am a noob to linux, and wanted to learn more about it, and so I am trying to dual boot my laptop with Windows 10, and Fedora 22.

    I have an old BIOS which doesn't support UEFI. Laptop has 500Gb HDD, and 150 Gb is un-allocated for Fedora 22 installation.

    I have the latest Fedora 22 64 bit image, and I have made a bootable USB using Fedora live usb creator. But, during installation of Fedora 22, even I am creating /boot - 500 Mb, swap - 4096Mb, and remaining all to / , I am getting the below error -

    "You have not defined a root partition(/), which is required for installation of Fedora to continue.

    No valid boot loaded target device found. See below for details.

    For a UEFI installation, you must include a EFI System Partition on a GPT-formatted disk, mounted at /boot/efi"

    It's already been one week since I am trying to dual boot Fedora 22, but no luck. Any help will be appreciated.

    Cheers!
    Last edited by homelybore; 24th August 2015 at 06:41 AM. Reason: Issue is resolved.

  2. #2
    Join Date
    Oct 2014
    Location
    milky way
    Posts
    556

    Re: Legacy BIOS - Not able to dual boot

    "You have not defined a root partition(/), which is required for installation of Fedora to continue.
    Select the check box to format the designated root partition.

  3. #3
    Join Date
    Aug 2015
    Location
    India
    Posts
    4

    Re: Legacy BIOS - Not able to dual boot

    Hello upnort,

    thanks for your quick response. The issue got resolved. If anyone else having this issue (who use legacy BIOS, but Fedora 22 installation forcing them to use UEFI), it's with the ISO to USB creator application that I was using. I used Fedora Live USB creator, Unetbootin, Rufus but no joy. Used SUSEImage Writer (a bit tricky to find point to *.iso file), but the problem got resolved.

  4. #4
    Join Date
    Oct 2014
    Location
    milky way
    Posts
    556

    Re: Legacy BIOS - Not able to dual boot

    Yes, unetbootin doesn't work with RH ISOs. I learned that the very first time I tried to create a bootable USB flash drive. I used dd.

    One thing about Linux: NIH runs rampant and everybody wants to be different.

  5. #5
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    4,490

    Re: Legacy BIOS - Not able to dual boot

    A very simple way to have solved your problem was to use Wiindows to reduce the partition size to say, 250/250.
    Leave the linux 250gs as unformatted (clear free space).

    With anaconada, you indicate that you want the system to use the clear free space, and to automatically configure space requirements. I would also choose to not use lvm, but standard partitions.
    Anaconda will apportion out the free space and the system will install properly. Grub2, the boot manager may show two Windows10 partitions and your Fedora ones.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  6. #6
    Join Date
    Aug 2015
    Location
    India
    Posts
    4

    Re: Legacy BIOS - Not able to dual boot

    Hello lsatenstein,

    As mentioned earlier, i had ~150Gb space unformatted / free space since day 1 I tried to dual boot. The problem was with the ISO to USB software I used which forced the Fedora 22 installation think that I am running UEFI partition scheme.

  7. #7
    Join Date
    Jan 2010
    Posts
    7,156

    Re: Legacy BIOS - Not able to dual boot

    Generally, if you have another Linux (or even a Mac OSX install) you can use dd. In Linux, on a single disk, the USB should show up as /dev/sdb and one can do


    dd if=<name_of_iso) of=/dev/sdb bs=1M

    (In Mac OSX you may have to use 1m, I'm not sure.)

    Generally this will create a usable USB.

  8. #8
    Join Date
    Dec 2009
    Location
    India
    Posts
    445

    Re: Legacy BIOS - Not able to dual boot

    In rufus, you have to select option of boot with mbr after selecting iso file(Go down then up). Otherwise it defaults to whatever your present windows installation is.

    It is also possible to use mbr with gpt partition scheme.

    With UEFI this all is confusing.

Similar Threads

  1. Making a multi-bootable USB stick to boot Linux ISOs in both UEFI and Legacy BIOS
    By plasmonics in forum Guides & Solutions (Not For Questions)
    Replies: 0
    Last Post: 19th August 2015, 04:09 PM
  2. Replies: 2
    Last Post: 4th March 2012, 06:31 PM
  3. [SOLVED] why grub(legacy) is so bad!! ... can't dual boot
    By fedvasu in forum Using Fedora
    Replies: 16
    Last Post: 31st July 2011, 06:06 PM
  4. Legacy Bios Rom option?
    By MagicSpark in forum Hardware & Laptops
    Replies: 1
    Last Post: 23rd March 2011, 10:52 AM
  5. [fc9] bios clock problems with dual boot
    By deathkill in forum Using Fedora
    Replies: 6
    Last Post: 13th June 2008, 04:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •