Bash will install package without asking for sudo
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2015
    Location
    Texas
    Posts
    2

    Bash will install package without asking for sudo

    So I just tried to run the 'sensors' command to get my cpu temps. I do not have the package 'lm_sensors' installed and bash found that it was the required package to run the command I wanted and then asked if I wanted to install it. It then installed it and bam, new software installed and no mention of password or sudo. Here is the output of the whole ordeal {Also note it even ran the command after installing it):

    [ashafar@fedz Downloads]$ sensors
    bash: sensors: command not found...
    Install package 'lm_sensors' to provide command 'sensors'? [N/y] y


    * Waiting in queue...
    * Waiting in queue...
    * Waiting for authentication...
    * Waiting in queue...
    * Downloading packages...
    * Requesting data...
    * Testing changes...
    * Installing packages...
    acpitz-virtual-0
    Adapter: Virtual device
    temp1: +27.8C (crit = +90.0C)
    temp2: +29.8C (crit = +90.0C)

    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0: +60.0C (high = +79.0C, crit = +85.0C)
    Core 0: +59.0C (high = +79.0C, crit = +85.0C)
    Core 1: +60.0C (high = +79.0C, crit = +85.0C)


    [ashafar@fedz Downloads]$

  2. #2
    Join Date
    Jun 2013
    Location
    USA
    Posts
    373

    Re: Bash will install package without asking for sudo

    Did you run sudo recently? It will keep the privileges for a certain number of minutes. Perhaps this is what happened?
    When professors and janitors begin working for free you can have your free education.

  3. #3
    Join Date
    Jul 2015
    Location
    Texas
    Posts
    2

    Re: Bash will install package without asking for sudo

    No I had not. I checked my history and the last time I had run sudo was about 12 hours ago in a different terminal. I'm not sure if this is a bug or a security risk. RedHat has had some 'bugs' aka security issues in the past.

  4. #4
    Join Date
    Aug 2011
    Location
    ~
    Posts
    1,948

    Re: Bash will install package without asking for sudo

    This has been discussed before.
    You either need to not run as an administrator (wheel), configure polkit to not authorize the request (at which point the action fails because the packagekit component doesn't ask for a password) or remove the packagekit component that is responsible for installing missing commands.

Similar Threads

  1. Source code of sudo, su, bash, ps etc etc
    By abhics1 in forum Using Fedora
    Replies: 5
    Last Post: 18th January 2013, 05:50 PM
  2. [SOLVED]
    [bash] sudo sub?
    By sea in forum Programming & Packaging
    Replies: 8
    Last Post: 8th August 2011, 06:56 PM
  3. Can fedora do bash completion of package names in yum?
    By MickStep in forum Using Fedora
    Replies: 4
    Last Post: 12th July 2011, 05:40 PM
  4. Cannot open /var/db/sudo after sudo package upgrade
    By Replicant10000 in forum Security and Privacy
    Replies: 1
    Last Post: 16th September 2010, 01:25 PM
  5. [SOLVED]
    How to Run (not Run in Terminal) bash script with sudo in it?
    By premudriy in forum Using Fedora
    Replies: 2
    Last Post: 6th July 2010, 06:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •