Persistently disable mutter unredirect in F21?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Apr 2015
    Location
    Tulsa, OK
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Persistently disable mutter unredirect in F21?

    Greetings, Fedora community.

    I recently picked up an Asus UX305, which is a great little Linux laptop. For the most part, everything works out of the box in F21. The only problem I'm running into is video tearing in Gnome (moving windows around tears fairly significantly) and full screen video (I've really only tested this using Firefox HTML5 video).

    After doing some digging, I came across this bug:

    https://bugzilla.redhat.com/show_bug.cgi?id=1133166#c10

    I tried what was suggested, namely disabling unredirect using this option (via Alt-F2 -> lg):

    Meta.disable_unredirect_for_screen(global.screen);

    This solves my tearing issues, which is great. However, I have to manually switch to this option every time I reboot.

    Is there a way I can make this change persistent? I found a post on the Linux Mint forum that apparently works there:

    http://forums.linuxmint.com/viewtopi...806763#p914207

    But I can't figure out how to accomplish this in F21.

    Thanks for any help.

  2. #2
    Join Date
    May 2005
    Posts
    3,868
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Persistently disable mutter unredirect in F21?

    Hi

    The bug report you linked to, talks about Anaconda. If you are seeing this in GNOME, you should file a new bug report, preferably in GNOME Bugzilla along with your hardware information.
    Rahul
    http://fedoraproject.org/wiki/RahulSundaram

  3. #3
    Join Date
    Apr 2015
    Location
    Tulsa, OK
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Persistently disable mutter unredirect in F21?

    Sorry -- should have been clearer. I'm actually seeing the tearing problem in Gnome on F21, and the workaround in that Anaconda bug (namely, disabling unredirect) resolves it for me. That probably wasn't the best bug to link to, but it's where I found the option that clears up the issue for me. I was hoping someone might know how I could script this to be persistent between boots.

    In a nuthsell, I'm looking for a way to automatically run the following between reboots:

    Alt-F2
    lg
    Meta.disable_unredirect_for_screen(global.screen);

    Again, sorry for the confusion.

  4. #4
    Join Date
    Aug 2011
    Location
    ~
    Posts
    2,060
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Persistently disable mutter unredirect in F21?

    I found this where a method for issuing these Gnome Shell commands is given.
    I tested it with the following command from a terminal:
    Code:
    gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell --method org.gnome.Shell.Eval 'Main.lookingGlass.toggle();' && sleep 5 && gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell --method org.gnome.Shell.Eval 'Main.lookingGlass.toggle();'
    Which correctly enables and then disables the looking glass from the terminal, so the following should probably work (put it in ~/.config/autostart/mutterfix.desktop).
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Version=1.0
    Type=Application
    Terminal=true
    Exec=gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell --method org.gnome.Shell.Eval 'Meta.disable_unredirect_for_screen(global.screen);'
    Name=Mutter Tear Fix
    P.s. I first tested this with Terminal=false but then it doesn't work, presumably because there is no information about the dbus session and with it it does (there is no visible window so I do not see any problems with this). Furthermore I'm not sure how to test this tearing fix problem properly so I tested with 'Main.notify("Hello world");' which worked when launching the DE session.
    Last edited by Dutchy; 3rd May 2015 at 12:10 AM. Reason: first gdbus command was missing the g at the start

  5. #5
    Join Date
    Apr 2015
    Location
    Tulsa, OK
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Persistently disable mutter unredirect in F21?

    Nice! I'll give this a try when I get home tonight.

    Thanks!

  6. #6
    Join Date
    Apr 2015
    Location
    Tulsa, OK
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up Re: Persistently disable mutter unredirect in F21?

    Worked like a champ. No more tearing!

    Thanks again.

  7. #7
    Join Date
    Dec 2014
    Location
    Warsaw
    Posts
    176
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Persistently disable mutter unredirect in F21?

    does not work for me - I get:
    (false, 'TypeError: Main.lookingGlass is null')
    (false, 'TypeError: Main.lookingGlass is null')

    Manual method works - Atl+f2 , r , Meta.disable_unredirect_for_screen(global.screen) .
    Any ideas howto make this applied during boot / what I might be doing wrong that gdbus... gives me those errors.

  8. #8
    Join Date
    Aug 2011
    Location
    ~
    Posts
    2,060
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Persistently disable mutter unredirect in F21?

    Quote Originally Posted by Przemas
    does not work for me - I get:
    (false, 'TypeError: Main.lookingGlass is null')
    (false, 'TypeError: Main.lookingGlass is null')

    Manual method works - Atl+f2 , r , Meta.disable_unredirect_for_screen(global.screen) .
    Any ideas howto make this applied during boot / what I might be doing wrong that gdbus... gives me those errors.
    That's strange.
    It seems to be working fine for me (no more tearing in fullscreen Firefox and vlc videos).
    I did seem to get those errors when I used the mentioned command to open the lg from a terminal before lg was started from ALT-F2, but for unredirect it just seems to work.

Similar Threads

  1. A silly question about mutter
    By IonIvan in forum Using Fedora
    Replies: 1
    Last Post: 14th December 2012, 07:11 PM
  2. GNOME Shell 3.1.90 & Mutter 3.1.90
    By tox in forum F16 Development
    Replies: 12
    Last Post: 2nd September 2011, 12:37 AM
  3. Mutter and Compiz both crash
    By gralco in forum Using Fedora
    Replies: 3
    Last Post: 25th July 2011, 12:45 PM
  4. GNOME Shell - Mutter crashing
    By Bloocurve in forum Using Fedora
    Replies: 0
    Last Post: 19th January 2011, 02:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •