FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2011
    Posts
    107

    boot into emergency mode and "dirty metadata"

    Upon booting computer, the first few seconds seem to boot normally. Then the display says "Welcome to emergency mode! ..." I've checked
    Code:
    journalctl -xb
    , but I don't know what most of that means. I did notice this message:
    fsck failure code 4.
    I've rebooted several times and it does the same thing every time. Once or twice it has included this message at the welcome to ... screen:
    Code:
    ext4_mb_generate_buddy:757: group 82, block bitmap and bg descriptor inconsistent: 28665 vs 28657 free clusters
    I read somewhere to try to fsck the partition. My computer is dual boot and the Win 7 partition seems to have no problems whatsoever, so I'm assuming it's a problem with /, which is sda7 on my machine. I also read that you can't run fsck on a mounted partition, so I don't know how to run fsck on / while I'm logged on.

    I started the computer with the Fedora install disk and used fdisk -l to be sure of the partition. In a terminal there, I
    Code:
    su
    fsck /dev/sda7
    and nothing seemed to happen.
    Then I read somewhere else that if I
    Code:
    su
    cd /
    touch /forcefsck
    that will fsck at start up and won't mess anything up. Then in the journalctl I saw a msg to use
    fsck.mode=force. No idea where/how to do that.

    Still an error when I reboot. I logged in as root at 'welcome to emergency' screen, changed init 1, then tried fsck -r. I don't know if did anything.

    I've tried a bunch of stuff. The dmesg has:
    Code:
    ext4_mb_generate_buddy:757: group 82, block bitmap and bg descriptor inconsistent: 28665 vs 28657 free clusters
    this still. Don't know what it means. I'm guessing something on the disk isn't playing nice. Every time I've started Firefox since this message has started, Firefox does not start with the same tabs as I closed it with, which is the option I selected for it. I check to see that option is selected each time I log on, but it still is just starting at my home page, so this may be related.

    Any help is welcome!
    Fedora 20 on a dual boot laptop, other OS = Win 7

  2. #2
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,346

    Re: boot into emergency mode and "dirty metadata"

    Fsck in this case must be run manually as it may require confirmation of what it is to do (usually happens when there are conflicting choices - and one, or both, of them could cause the loss of data).

    You can try "fsck -f /dev/sda7" (assuming sda7 is the filesystem in question).

    You should get some response from that.

  3. #3
    Join Date
    Oct 2011
    Posts
    107

    Re: boot into emergency mode and "dirty metadata"

    If /dev/sda7 is / and I'm logged on, how do I get fsck to run on / ? I just tried it and got this

    [root@localhost joe]# fsck -r
    fsck from util-linux 2.25.2
    e2fsck 1.42.11 (09-Jul-2014)
    /dev/mapper/fedora-root is mounted.
    e2fsck: Cannot continue, aborting.


    /dev/mapper/fedora-root: status 8, rss 2884, real 0.003483, user 0.000000, sys 0.003468
    Fedora 20 on a dual boot laptop, other OS = Win 7

  4. #4
    Join Date
    Oct 2004
    Posts
    107

    Re: boot into emergency mode and "dirty metadata"

    There are several options:
    1. boot from an USB stick and run fsck from there. (I assume sda7 is part of your root fs so you just can't unmount it) Fedora comes with an easy to use USB live distro creator. Probably the safest way of checking and repairing a root fs.

    2. change into emergency shell and work from there:
    http://foobaring.blogspot.dk/2014/01...y-mode-on.html

    3. mark the root fs RO and change into runlevel 1:
    http://bitsofmymind.com/2014/03/14/h...into-on-linux/

    4. add "fsck.mode=force" and "fsck.repair=preen" (for safe repairs) to the kernel at startup.
    Or "fsck.repair=yes" for saying yes to all fsck repairs (not necessarily safe).
    http://www.freedesktop.org/software/...@.service.html

  5. #5
    Join Date
    Oct 2011
    Posts
    107

    Re: boot into emergency mode and "dirty metadata"

    Peter H.S.,

    2. change into emergency shell and work from there:
    http://foobaring.blogspot.dk/2014/01...y-mode-on.html
    ... I tried the 1st option on the list there. That didn't work. I went with the 3rd option on their list. It better explained how to use an install disk to navigate to the OS on the computer's disk and everything else worked from there. Thanks!!
    Fedora 20 on a dual boot laptop, other OS = Win 7

  6. #6
    Join Date
    Oct 2011
    Posts
    107

    Re: boot into emergency mode and "dirty metadata"

    Adding this in case the link rots:

    "Solution #3 (tested):
    1. boot into your LiveCD or LiveUSB
    2. once logged in, open gnome-disks utility from the applications (I think its called Disks)
    3. unmount all the /dev/mapper/fedora_XXX--root & home & swap
    4. open a gnome-terminal (terminal)
    5. type su -
    6. enter your root password

    7. type fsck /dev/mapper/fedora_XXX--root
    8. if there are questions about fixing, ignoring, forcing, salvage, etc, always answer y (yes)
    9. repeat step 7 & 8 with --home & --swap just to be sure"
    Fedora 20 on a dual boot laptop, other OS = Win 7

Similar Threads

  1. Why did my "yum upgrade" result in "emergency mode"?
    By OS9Barry in forum Using Fedora
    Replies: 9
    Last Post: 3rd August 2014, 02:28 PM
  2. Replies: 0
    Last Post: 30th January 2014, 05:38 PM
  3. [SOLVED] F13->F15 upgrade results in "Welcome to emergency mode". Won't boot.
    By GregJo in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 14th June 2012, 09:22 AM
  4. How to debug "Emergency Mode"
    By daFritz84 in forum Using Fedora
    Replies: 0
    Last Post: 23rd January 2012, 10:58 AM
  5. Screen went black, now "Welcome to Emergency Mode"
    By KnavishClout in forum Using Fedora
    Replies: 3
    Last Post: 22nd October 2011, 02:32 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •