FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2014
    Location
    West Michigan
    Posts
    2

    [Solved] Can't switch user after installing nvidia drivers

    Hello,
    Using gdm, when I try to switch user I get the "Oh No! Something has gone wrong" message. I have to Ctrl-Alt-F1 which allows me to log back in as me.

    The only error message I can detect is (EE) FBDEV(0): FBIOBLANK: Invalid argument
    Code:
    Dec 08 07:14:01.066783 frankenputer02 gdm-Xorg-:2[17224]: (EE) FBDEV(0): FBIOBLANK: Invalid argument
    Dec 08 07:14:01.235832 frankenputer02 gnome-session[7512]: (gnome-shell:7646): St-CRITICAL **: _st_paint_shadow_with_opacity: assertion 'shadow_material != COGL_INVALID_HANDLE' failed
    Dec 08 07:14:01.236793 frankenputer02 gnome-session[7512]: (gnome-shell:7646): St-CRITICAL **: _st_paint_shadow_with_opacity: assertion 'shadow_material != COGL_INVALID_HANDLE' failed
    Dec 08 07:14:01.238263 frankenputer02 gnome-session[7512]: (gnome-shell:7646): St-CRITICAL **: _st_paint_shadow_with_opacity: assertion 'shadow_material != COGL_INVALID_HANDLE' failed
    Dec 08 07:14:04.998443 frankenputer02 acpid[1471]: client 6235[0:0] has disconnected
    Dec 08 07:14:06.446357 frankenputer02 gdm-Xorg-:0[6235]: (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1280x1024 +0+0 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DVI-D-0: nvidia-auto-select @1920x1080 +1280+0 {ViewPort
    Dec 08 07:14:06.578842 frankenputer02 acpid[1471]: client connected from 6235[0:0]
    Dec 08 07:14:06.578851 frankenputer02 acpid[1471]: 1 client rule loaded
    Dec 08 07:14:06.603419 frankenputer02 gdm-Xorg-:0[6235]: (II) NVIDIA(GPU-0): Display (Ancor Communications Inc VS248 (DFP-3)) does not
    Dec 08 07:14:06.603509 frankenputer02 gdm-Xorg-:0[6235]: (II) NVIDIA(GPU-0):     support NVIDIA 3D Vision stereo.
    Dec 08 07:14:06.611660 frankenputer02 gdm-Xorg-:0[6235]: (II) NVIDIA(GPU-0): Display (Samsung 760/V/780 TFT (CRT-0)) does not support
    Dec 08 07:14:06.611739 frankenputer02 gdm-Xorg-:0[6235]: (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
    I looked back through the log to a time before I installed the NVIDIA drivers and my current speculation is that the NOUVEAU driver has a sort of internal framebuffer mode that the VT switcher relies on.

    Has anyone seen this problem before?
    Do I have to have an /etc/X11/xorg.conf file? It seems to sort of work without it.

    Thank you.

    Code:
    [radome@frankenputer02 ~]$ rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
    abrt-addon-kerneloops-2.3.0-3.fc21.x86_64
    akmod-nvidia-343.22-4.fc21.x86_64
    kernel-3.17.1-302.fc21.x86_64
    kernel-3.17.4-300.fc21.x86_64
    kernel-3.17.4-301.fc21.x86_64
    kernel-core-3.17.1-302.fc21.x86_64
    kernel-core-3.17.4-300.fc21.x86_64
    kernel-core-3.17.4-301.fc21.x86_64
    kernel-devel-3.17.4-300.fc21.x86_64
    kernel-devel-3.17.4-301.fc21.x86_64
    kernel-headers-3.17.4-301.fc21.x86_64
    kernel-modules-3.17.1-302.fc21.x86_64
    kernel-modules-3.17.4-300.fc21.x86_64
    kernel-modules-3.17.4-301.fc21.x86_64
    kernel-modules-extra-3.17.4-301.fc21.x86_64
    kmod-nvidia-3.17.4-300.fc21.x86_64-343.22-3.fc21.x86_64
    kmod-nvidia-3.17.4-301.fc21.x86_64-343.22-4.fc21.x86_64
    libreport-plugin-kerneloops-2.3.0-4.fc21.x86_64
    xorg-x11-drv-nvidia-343.22-2.fc21.x86_64
    xorg-x11-drv-nvidia-cuda-343.22-2.fc21.x86_64
    xorg-x11-drv-nvidia-kmodsrc-343.22-2.fc21.x86_64
    xorg-x11-drv-nvidia-libs-343.22-2.fc21.x86_64
    uname -r;
    3.17.4-301.fc21.x86_64
    lsmod |grep -e nvidia -e nouveau;
    nvidia              11068215  54 
    drm                   300858  3 nvidia
    cat /etc/X11/xorg.conf
    cat: /etc/X11/xorg.conf: No such file or directory
    [radome@frankenputer02 ~]$ lspci |grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
    Last edited by radome; 9th December 2014 at 09:57 AM. Reason: Solved

  2. #2
    Join Date
    Dec 2014
    Location
    West Michigan
    Posts
    2

    Re: Can't switch user after installing nvidia drivers

    Well I activated the nvidia-xorg.conf by renaming it to xorg.conf and then using the nvidia X Server settings tool to re-write it. Now I can switch users.

Similar Threads

  1. switch user locks screen but doesn't switch user
    By amitkher in forum Using Fedora
    Replies: 11
    Last Post: 16th November 2013, 11:46 AM
  2. Help installing Installing nVidia Drivers and 32bit OpenGL
    By Jeff91 in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 25th August 2009, 12:25 AM
  3. Replies: 6
    Last Post: 19th July 2009, 05:30 PM
  4. Installing Nvidia Drivers: No Nvidia Graphics Driver Found!
    By unholy1 in forum Hardware & Laptops
    Replies: 9
    Last Post: 6th April 2005, 08:50 PM
  5. Installing nVidia drivers
    By GrayFox^ in forum Using Fedora
    Replies: 5
    Last Post: 4th April 2005, 10:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •