[SOLVED] Can't connect using openvpn
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2014
    Location
    boston
    Posts
    20

    Can't connect using openvpn

    I subscribed with private vpn access they gave me these steps to configure my vpn on ubuntu , as they said they don't support fedora. I did them but still can't connect:

    In Terminal, install openvpn packages with sudo apt-get install network-manager-openvpn.
    Restart the network manager with sudo restart network-manager
    Run sudo wget https://www.privateinternetaccess.co...pn/openvpn.zip
    Extract the files from the zip with unzip openvpn.zip.
    Move ca.crt to /etc/openvpn
    Open the Network Manager on the menu bar.
    Choose add and select the OpenVPN connection type, and click Create.
    Enter Private Internet Access SSL for the Connection Name.
    Enter us-midwest.privateinternetaccess.com[*] for the Gateway
    Select Password and enter your login credentials.
    Browse and select the CA Certificat we saved in Step 3.
    Choose Advanced and enable LZO Compression.
    Apply and exit.
    Connect using the Network Manager.


    Please help i am a new to fedora.

  2. #2
    Join Date
    May 2011
    Location
    Yorkshire, UK
    Posts
    106

    Re: Can't connect using openvpn

    Step 1 and 2 translates to:
    Code:
    $su -
    #yum install NetworkManager-openvpn NetworkManager-openvpn-gnome
    #systemctl restart NetworkManager
    You won't need 'sudo' in step 3 as you are already 'root'. The rest looks as if it should work. Give it a try. If you can't connect, temporarily disable your firewall to see if that helps.
    Computing is just a fad - it'll never catch on.

  3. #3
    Join Date
    Mar 2014
    Location
    boston
    Posts
    20

    Re: Can't connect using openvpn

    Isn't open VPN installed by default in f20? Thank you

  4. #4
    Join Date
    Mar 2014
    Location
    boston
    Posts
    20

    Re: Can't connect using openvpn

    I fixed my issue by running the following commands :

    allow this access for now by executing:
    # grep openvpn /var/log/audit/audit.log | audit2allow -M mypol
    # semodule -i mypol.pp

    this came up in SElinux i guess next time i will have to start ready my notifications, SElinux has been quite helpfull so far i am loving fedora.

Similar Threads

  1. Replies: 1
    Last Post: 29th January 2012, 07:44 PM
  2. Don't connect openvpn
    By luoluo in forum Servers & Networking
    Replies: 11
    Last Post: 18th June 2011, 02:26 PM
  3. Openvpn can connect but cannot ping other server in network issues
    By bearbasher in forum Servers & Networking
    Replies: 0
    Last Post: 29th August 2007, 04:36 AM
  4. connect.php won't connect to created db
    By bolognese in forum Using Fedora
    Replies: 4
    Last Post: 1st August 2006, 07:02 PM
  5. Connect / Dic-connect with modem lights
    By ailmarfarm in forum Using Fedora
    Replies: 1
    Last Post: 12th October 2005, 03:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •