FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23
  1. #1
    Join Date
    May 2009
    Posts
    182

    Nvidia GTX 750 ti graphics card. . . .

    I'm having issues getting this card to work. . . being a relatively new card has anyone gotten this one yet to work in Fedora 20? . My system crashed . . . and I ' m thinking the only way to get it to work is to use Nvidia's proprietary driver 334.21. Anyone got one of these and is it working?

    Rich

  2. #2
    Join Date
    Dec 2008
    Location
    ex-EU
    Posts
    1,054

    Re: Nvidia GTX 750 ti graphics card. . . .

    I don't have the card (GTX660), but I can confirm that 334.21 works just fine here with 3.13.6 kernel.
    Unfortunately it seems that RPMFusion doesn't have it even in testing as of now, so upstream Nvidia installer is needed.

  3. #3
    leigh123linux Guest

    Re: Nvidia GTX 750 ti graphics card. . . .

    Quote Originally Posted by Maryyy
    I don't have the card (GTX660), but I can confirm that 334.21 works just fine here with 3.13.6 kernel.
    Unfortunately it seems that RPMFusion doesn't have it even in testing as of now, so upstream Nvidia installer is needed.
    I rejected 334.21 for rpmfusion testing/stable, if you want the crappy 334.21 driver it's in rawhide.

    http://download1.rpmfusion.org/nonfr...rv-nvidia.html

    Use 334.21 with any accelerated DE and you get rendering issues!!

    https://devtalk.nvidia.com/default/t...geforce-9400m/

  4. #4
    Join Date
    Dec 2008
    Location
    ex-EU
    Posts
    1,054

    Re: Nvidia GTX 750 ti graphics card. . . .

    Yeah, ok. I was just saying that the driver works with current kernel, in case OP would like to try it, because it's needed for his card to work.

    As of rendering issues, no problem, I use Openbox.

  5. #5
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,026

    Re: Nvidia GTX 750 ti graphics card. . . .

    I have a 650 and have installed the nvidia drivers bearing the same number as my kernel ... then installed kmod-nvidia to keep it working through kernel updates. I don't think it 'sees' the GPU, but the card works great otherwise - though that issue could be something I did; I am no expert!

  6. #6
    Join Date
    Dec 2008
    Location
    ex-EU
    Posts
    1,054

    Re: Nvidia GTX 750 ti graphics card. . . .

    I don't know what you are talking about.

  7. #7
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,026

    Re: Nvidia GTX 750 ti graphics card. . . .

    I use yumex (yum install yumex) to look for packages. When I search for nvidia I get a list. I happened to notice one with the kernel version in it and tried it. Worked great. The next kernel came along and trashed it, so I downloaded the new (version named for the new kernel) and also installed the kmod for it. Now the new kernels don't trash it any more.

  8. #8
    Join Date
    Dec 2008
    Location
    ex-EU
    Posts
    1,054

    Re: Nvidia GTX 750 ti graphics card. . . .

    I still don't know what you're talking about.
    OP needs latest driver to support his GXT750 Ti. This driver is not available in RPMFusion, leigh explained why.
    And I only confirmed, that the only available driver - upstream Nvidia installer of 334.21 which he needs to support his card, works fine, in case he is interested.

    Installation of the RPMFusion driver is simply useless here.

  9. #9
    Join Date
    May 2009
    Posts
    182

    Re: Nvidia GTX 750 ti graphics card. . . .

    Ok. . . here's the situation. . .don't know why but the graphics driver and the latest kernel using Fedora F20 works on my SSD hard drive. The OS runs perfectly. When I get to the installation on my 3 terabyte drive I had problems initially with the install of F20 but once I got through the hurdles with the Noveau driver everything work. Then when it came to installing the latest Fedora Nvidia driver via (akmod) method the system started up and stopped and froze when it got to starting KDE program. I don't know what the heck is going on. . . But I can say my SSD drive works with everything flawlessly. . .


    Rich

  10. #10
    leigh123linux Guest

    Re: Nvidia GTX 750 ti graphics card. . . .

    Quote Originally Posted by rich52
    Ok. . . here's the situation. . .don't know why but the graphics driver and the latest kernel using Fedora F20 works on my SSD hard drive. The OS runs perfectly. When I get to the installation on my 3 terabyte drive I had problems initially with the install of F20 but once I got through the hurdles with the Noveau driver everything work. Then when it came to installing the latest Fedora Nvidia driver via (akmod) method the system started up and stopped and froze when it got to starting KDE program. I don't know what the heck is going on. . . But I can say my SSD drive works with everything flawlessly. . .


    Rich

    Your card needs 334.21 to function.

    https://devtalk.nvidia.com/default/topic/699435

    update to the rawhide driver

    Code:
    yum --enablerepo rpmfusion-nonfree-rawhide update *\nvidia\*

  11. #11
    Join Date
    May 2009
    Posts
    182

    Re: Nvidia GTX 750 ti graphics card. . . .

    Thanks leigh123. . . .I installed the rawride repo and files onto my SSD drive a couple minutes ago. . . it updated and works with no adverse reactions except for the UEFI. . . which I fixed by rebooting the computer and re-establishing the boot priorities. Works good. I'm by no means a pro at all of this and I tinker a lot on the computer. Biggest problem I have is keeping my hands off of everything and stick with just 1 distro. . . I distro hop a lot and Fedora has so far has been the best for KDE with Kubuntu as runner up. Now I just got to get the 3 terabyte drive up and running again with the video driver corrections. . . .once that is done I can rest for a while until the next slew of distro upgrades comes out. . . .


    Rich

  12. #12
    Join Date
    Apr 2011
    Posts
    17

    Re: Nvidia GTX 750 ti graphics card. . . .

    Hi, I was always (last 4+ years) able to run latest fedora with proprietary nvidia drivers and cuda support, but I failed this time
    system somehow runs now with

    vmlinuz-3.13.9-200.fc20.x86_64 nomodeset rd.driver.blacklist=nouveau rd.driver.blacklist=i915 video=vesa:off nouveau.modeset=0 drm.modeset=0 video.allow_duplicates=1

    but although cuda works partially, (latest 337beta) nvidia display driver cannot be used for X,
    please see here : https://gist.github.com/10271994
    any help appreciated

    # head /proc/cpuinfo
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 6
    model : 60
    model name : Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz
    stepping : 3
    microcode : 0x17
    cpu MHz : 3599.882
    cache size : 6144 KB
    physical id : 0

    # dmidecode --type 1
    # dmidecode 2.12
    SMBIOS 2.7 present.

    Handle 0x0001, DMI type 1, 27 bytes
    System Information
    Manufacturer: Gigabyte Technology Co., Ltd.
    Product Name: H87-HD3
    Version: To be filled by O.E.M.
    Serial Number: To be filled by O.E.M.
    UUID: 03DE0294-0480-05B3-5D06-A60700080009
    Wake-up Type: Power Switch
    SKU Number: To be filled by O.E.M.
    Family: To be filled by O.E.M.

  13. #13
    leigh123linux Guest

    Re: Nvidia GTX 750 ti graphics card. . . .

    Quote Originally Posted by rich52
    Thanks leigh123. . . .I installed the rawride repo and files onto my SSD drive a couple minutes ago. . . it updated and works with no adverse reactions except for the UEFI. . . which I fixed by rebooting the computer and re-establishing the boot priorities. Works good. I'm by no means a pro at all of this and I tinker a lot on the computer. Biggest problem I have is keeping my hands off of everything and stick with just 1 distro. . . I distro hop a lot and Fedora has so far has been the best for KDE with Kubuntu as runner up. Now I just got to get the 3 terabyte drive up and running again with the video driver corrections. . . .once that is done I can rest for a while until the next slew of distro upgrades comes out. . . .


    Rich
    I've just built 331.67 for rpmfusion stable branches which adds support for your card.


    http://www.nvidia.com/download/drive...px/75019/en-us

  14. #14
    Join Date
    Apr 2011
    Posts
    17

    Re: Nvidia GTX 750 ti graphics card. . . .

    I tried 331.67 from nvidia web, but the problem stays.
    I have found something more, any time I put vga=normal in kernel line (which somebody mentioned as a help), system freezes during booting.
    Any help is appreciated.
    it freezes somewhere after

    private kernel: [ 11.235062] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2/input12

    ===normal boot continues with

    Apr 10 06:17:37 private kernel: [ 8.276893] Adding 17329148k swap on /dev/sdb3. Priority:-1 extents:1 across:17329148k SSFS
    Apr 10 06:17:37 private kernel: [ 8.358734] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
    Apr 10 06:17:37 private kernel: [ 8.455831] type=1305 audit(1397103455.924:3): audit_pid=558 old=0 auid=4294967295 ses=4294967295 res=1
    Apr 10 06:17:37 private kernel: [ 8.651812] iTCO_vendor_support: vendor-support=0
    Apr 10 06:17:37 private kernel: [ 8.652501] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.10
    Apr 10 06:17:37 private kernel: [ 8.652523] iTCO_wdt: unable to reset NO_REBOOT flag, device disabled by hardware/BIOS
    Apr 10 06:17:37 private kernel: [ 9.963893] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
    Apr 10 06:17:37 private kernel: [ 9.970252] ip6_tables: (C) 2000-2006 Netfilter Core Team
    Apr 10 06:17:37 private kernel: [ 10.025862] Ebtables v2.0 registered
    Apr 10 06:17:37 private kernel: [ 10.054714] Bridge firewalling registered
    Apr 10 06:17:37 private kernel: [ 10.198704] it87: Found IT8728F chip at 0xa30, revision 1
    Apr 10 06:17:37 private kernel: [ 10.198719] it87: Beeping is supported
    Apr 10 06:17:37 private kernel: [ 10.361442] Guest personality initialized and is inactive
    Apr 10 06:17:37 private kernel: [ 10.361728] VMCI host device registered (name=vmci, major=10, minor=58)
    Apr 10 06:17:37 private kernel: [ 10.361728] Initialized host personality
    Apr 10 06:17:37 private kernel: [ 10.429126] NET: Registered protocol family 40
    Apr 10 06:17:37 private kernel: [ 10.457001] fuse init (API version 7.22)
    Apr 10 06:17:38 private kernel: [ 10.512027] ppdev: user-space parallel port driver
    Apr 10 06:17:38 private kernel: [ 10.800450] cfg80211: Calling CRDA to update world regulatory domain
    Apr 10 06:17:38 private kernel: [ 10.806666] cfg80211: World regulatory domain updated:
    Apr 10 06:17:38 private kernel: [ 10.806666] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    Apr 10 06:17:38 private kernel: [ 10.806667] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    Apr 10 06:17:38 private kernel: [ 10.806667] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    Apr 10 06:17:38 private kernel: [ 10.806667] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm)
    Apr 10 06:17:38 private kernel: [ 10.806668] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
    Apr 10 06:17:38 private kernel: [ 10.806668] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm)
    Apr 10 06:17:38 private kernel: [ 10.806669] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)
    Apr 10 06:16:46 private journal: Permanent journal is using 1.1G (max allowed 4.0G, trying to leave 4.0G free of 1.8G available �.. current limit 1.1G).
    Apr 10 06:16:46 private kernel: SysRq : Terminate All Tasks
    Apr 10 06:16:46 private systemd-journald[393]: Received SIGTERM
    Apr 10 06:16:46 private systemd-udevd[3395]: starting version 208
    Apr 10 06:16:46 private journal: Journal started
    Apr 10 06:16:46 private alsactl[611]: alsactl daemon stopped
    Apr 10 06:16:46 private dhclient[3007]: Received signal 15, initiating shutdown.
    Apr 10 06:16:46 private dhclient[2989]: Received signal 15, initiating shutdown.
    Apr 10 06:16:46 private smartd[627]: smartd received signal 15: Terminated
    Apr 10 06:16:46 private smartd[627]: smartd is exiting (exit status 0)
    Apr 10 06:16:46 private dhclient[3019]: Received signal 15, initiating shutdown.
    Apr 10 06:16:46 private xinetd[2932]: Exiting...
    Apr 10 06:16:46 private rpcbind: rpcbind terminating on signal. Restart with "rpcbind -w"
    Apr 10 06:16:46 private chronyd[677]: chronyd exiting
    Apr 10 06:16:46 private vmnet-dhcpd: select: Interrupted system call
    Apr 10 06:16:46 private vmnet-dhcpd: exiting.
    Apr 10 06:16:46 private bluetoothd[1021]: Terminating
    Apr 10 06:16:46 private vmnetBridge: Stopped bridge p4p1 to virtual network 0.

  15. #15
    Join Date
    Dec 2008
    Location
    ex-EU
    Posts
    1,054

    Re: Nvidia GTX 750 ti graphics card. . . .

    I don't know what you did after downloading the driver from Nvidia site, but there are some steps required prior to running the installer, otherwise it will not work, as Nouveau will still sit there.
    Even though I can confirm the driver from Nvidia site works just fine with 3.13.9 kernel, I would recommend you use the RPMfusion driver, as it takes care of those steps normally required with Nvidia installer.

    You need to get to text mode directly after boot, as graphical mode is not working in your case, so in grub2 menu, press key e on the kernel, where you installed the driver (likely the latest kernel installed), go to the end of the kernel line and add this number: 3.
    After that, don't press enter, just F10 to boot. This will get you to text mode, aka multi-user target.
    You'd first have to uninstall the driver you used from Nvidia, so run the installer again.
    Code:
    # sh NVIDIA-Linux-installed-version --uninstall
    After that, reboot.
    Now again go to the text mode as before and install the RPMfusion driver:
    Code:
    # yum --enablerepo=rpmfusion-nonfree-updates-testing install akmod-nvidia xorg-x11-drv-nvidia-libs.i686
    Mind you, kernel-devel is also needed to be installed for akmod version, so check if it is (rpm -q kernel-devel), install it if not present.

    Reboot, should now work.

    P.S. I'm typing this from work from top of my head, I may have forgotten something, hopefully not.
    If I have, leigh will likely correct that.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. [SOLVED] Upgrading nVidia Graphics card
    By sdlor in forum Hardware & Laptops
    Replies: 0
    Last Post: 9th July 2011, 05:28 PM
  2. Nvidia GT 330M Graphics Card
    By donkeyend in forum Hardware & Laptops
    Replies: 2
    Last Post: 29th November 2010, 11:39 PM
  3. Laptop Wireless Card and Desktop Nvidia Graphics Card
    By Raskula in forum Hardware & Laptops
    Replies: 4
    Last Post: 1st December 2008, 12:22 AM
  4. nVidia Graphics Card - nvClock?
    By GML3G0 in forum Hardware & Laptops
    Replies: 10
    Last Post: 7th November 2004, 01:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •