[SOLVED] A lot of duplicates in YUM
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18
  1. #1
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    A lot of duplicates in YUM

    When I run, yum check, I get a lot of duplicates. Even yum is duplicated (and protected).

    Code:
    [root@localhost yum.repos.d]# yum check
    Loaded plugins: langpacks, refresh-packagekit
    1:NetworkManager-glib-0.9.9.0-26.git20131003.fc20.x86_64 is a duplicate with 1:NetworkManager-glib-0.9.9.0-22.git20131003.fc20.x86_64
    PackageKit-glib-0.8.16-1.fc20.x86_64 is a duplicate with PackageKit-glib-0.8.15-1.fc20.x86_64
    abrt-2.1.11-1.fc20.x86_64 is a duplicate with abrt-2.1.10-1.fc20.x86_64
    abrt-addon-ccpp-2.1.11-1.fc20.x86_64 is a duplicate with abrt-addon-ccpp-2.1.10-1.fc20.x86_64
    abrt-gui-libs-2.1.11-1.fc20.x86_64 is a duplicate with abrt-gui-libs-2.1.10-1.fc20.x86_64
    abrt-libs-2.1.11-1.fc20.x86_64 is a duplicate with abrt-libs-2.1.10-1.fc20.x86_64
    abrt-python-2.1.11-1.fc20.x86_64 is a duplicate with abrt-python-2.1.10-1.fc20.x86_64
    abrt-retrace-client-2.1.11-1.fc20.x86_64 is a duplicate with abrt-retrace-client-2.1.10-1.fc20.x86_64
    accountsservice-0.6.35-4.fc20.x86_64 is a duplicate with accountsservice-0.6.35-3.fc20.x86_64
    accountsservice-libs-0.6.35-4.fc20.x86_64 is a duplicate with accountsservice-libs-0.6.35-3.fc20.x86_64
    audit-libs-2.3.3-1.fc20.x86_64 is a duplicate with audit-libs-2.3.2-1.fc20.x86_64
    32:bind-license-9.9.4-11.P2.fc20.noarch is a duplicate with 32:bind-license-9.9.4-8.fc20.noarch
    1:control-center-filesystem-3.10.2-4.fc20.x86_64 is a duplicate with 1:control-center-filesystem-3.10.2-3.fc20.x86_64
    coreutils-8.21-20.fc20.x86_64 is a duplicate with coreutils-8.21-18.fc20.x86_64
    12:dhcp-common-4.2.5-30.fc20.x86_64 is a duplicate with 12:dhcp-common-4.2.5-26.fc20.x86_64
    12:dhcp-libs-4.2.5-30.fc20.x86_64 is a duplicate with 12:dhcp-libs-4.2.5-26.fc20.x86_64
    gdb-7.6.50.20130731-19.fc20.x86_64 is a duplicate with gdb-7.6.50.20130731-16.fc20.x86_64
    gdk-pixbuf2-2.30.3-1.fc20.x86_64 is a duplicate with gdk-pixbuf2-2.30.1-1.fc20.x86_64
    glusterfs-3.4.2-1.fc20.x86_64 is a duplicate with glusterfs-3.4.1-3.fc20.x86_64
    glusterfs-libs-3.4.2-1.fc20.x86_64 is a duplicate with glusterfs-libs-3.4.1-3.fc20.x86_64
    gnome-abrt-0.3.5-1.fc20.x86_64 is a duplicate with gnome-abrt-0.3.4-1.fc20.x86_64
    ibus-libs-1.5.5-1.fc20.x86_64 is a duplicate with ibus-libs-1.5.4-2.fc20.x86_64
    initscripts-9.51-1.fc20.x86_64 is a duplicate with initscripts-9.50-1.fc20.x86_64
    kactivities-4.11.5-1.fc20.x86_64 is a duplicate with kactivities-4.11.4-1.fc20.x86_64
    kde-runtime-4.11.5-1.fc20.x86_64 is a duplicate with kde-runtime-4.11.4-1.fc20.x86_64
    kde-runtime-drkonqi-4.11.5-1.fc20.x86_64 is a duplicate with kde-runtime-drkonqi-4.11.4-1.fc20.x86_64
    kde-runtime-flags-4.11.5-1.fc20.noarch is a duplicate with kde-runtime-flags-4.11.4-1.fc20.noarch
    kde-runtime-libs-4.11.5-1.fc20.x86_64 is a duplicate with kde-runtime-libs-4.11.4-1.fc20.x86_64
    6:kdelibs-4.11.5-1.fc20.x86_64 is a duplicate with 6:kdelibs-4.11.4-1.fc20.x86_64
    6:kdelibs-common-4.11.5-1.fc20.x86_64 is a duplicate with 6:kdelibs-common-4.11.4-1.fc20.x86_64
    kdepimlibs-kxmlrpcclient-4.11.5-1.fc20.x86_64 is a duplicate with kdepimlibs-kxmlrpcclient-4.11.4-1.fc20.x86_64
    libreport-2.1.11-1.fc20.x86_64 is a duplicate with libreport-2.1.10-1.fc20.x86_64
    libreport-filesystem-2.1.11-1.fc20.x86_64 is a duplicate with libreport-filesystem-2.1.10-1.fc20.x86_64
    libreport-gtk-2.1.11-1.fc20.x86_64 is a duplicate with libreport-gtk-2.1.10-1.fc20.x86_64
    libreport-plugin-bugzilla-2.1.11-1.fc20.x86_64 is a duplicate with libreport-plugin-bugzilla-2.1.10-1.fc20.x86_64
    libreport-plugin-reportuploader-2.1.11-1.fc20.x86_64 is a duplicate with libreport-plugin-reportuploader-2.1.10-1.fc20.x86_64
    libreport-plugin-ureport-2.1.11-1.fc20.x86_64 is a duplicate with libreport-plugin-ureport-2.1.10-1.fc20.x86_64
    libreport-python-2.1.11-1.fc20.x86_64 is a duplicate with libreport-python-2.1.10-1.fc20.x86_64
    libreport-web-2.1.11-1.fc20.x86_64 is a duplicate with libreport-web-2.1.10-1.fc20.x86_64
    libudisks2-2.1.2-1.fc20.x86_64 is a duplicate with libudisks2-2.1.1-1.fc20.x86_64
    mutter-3.10.3-1.fc20.x86_64 is a duplicate with mutter-3.10.2-6.fc20.x86_64
    nepomuk-core-4.11.5-1.fc20.x86_64 is a duplicate with nepomuk-core-4.11.4-1.fc20.x86_64
    nepomuk-core-libs-4.11.5-1.fc20.x86_64 is a duplicate with nepomuk-core-libs-4.11.4-1.fc20.x86_64
    nss-3.15.4-1.fc20.x86_64 is a duplicate with nss-3.15.3.1-1.fc20.x86_64
    nss-softokn-3.15.4-1.fc20.x86_64 is a duplicate with nss-softokn-3.15.3-1.fc20.x86_64
    nss-softokn-freebl-3.15.4-1.fc20.x86_64 is a duplicate with nss-softokn-freebl-3.15.3-1.fc20.x86_64
    nss-sysinit-3.15.4-1.fc20.x86_64 is a duplicate with nss-sysinit-3.15.3.1-1.fc20.x86_64
    nss-util-3.15.4-1.fc20.x86_64 is a duplicate with nss-util-3.15.3-1.fc20.x86_64
    oxygen-icon-theme-4.11.5-1.fc20.noarch is a duplicate with oxygen-icon-theme-4.11.4-1.fc20.noarch
    p11-kit-0.20.2-1.fc20.x86_64 is a duplicate with p11-kit-0.20.1-1.fc20.x86_64
    4:perl-5.18.2-289.fc20.x86_64 is a duplicate with 4:perl-5.18.1-288.fc20.x86_64
    1:perl-Module-CoreList-3.03-289.fc20.noarch is a duplicate with 1:perl-Module-CoreList-2.96-288.fc20.noarch
    4:perl-libs-5.18.2-289.fc20.x86_64 is a duplicate with 4:perl-libs-5.18.1-288.fc20.x86_64
    4:perl-macros-5.18.2-289.fc20.x86_64 is a duplicate with 4:perl-macros-5.18.1-288.fc20.x86_64
    php-common-5.5.8-1.fc20.x86_64 is a duplicate with php-common-5.5.7-1.fc20.x86_64
    policycoreutils-2.2.5-1.fc20.x86_64 is a duplicate with policycoreutils-2.2.4-5.fc20.x86_64
    popt-1.16-2.fc20.x86_64 is a duplicate with popt-1.16-1.fc20.x86_64
    satyr-0.13-1.fc20.x86_64 is a duplicate with satyr-0.12-1.fc20.x86_64
    udisks2-2.1.2-1.fc20.x86_64 is a duplicate with udisks2-2.1.1-1.fc20.x86_64
    yum-3.4.3-132.fc20.noarch is a duplicate with yum-3.4.3-128.fc20.noarch
    Error: check all
    I have tried the following things:
    • yum -complete-transaction --cleanup-only
    • yum clean all
    • yum clean metadata
    • disable all repos except fedora-updates
    • rm -f /var/lib/rpm/__db.*
    • rpm --rebuilddb


    I also tried package-cleanup --cleandupes --skip-broken, which gave a list of updates, then two errors and then a list of duplicates.
    Code:
    Error: Trying to remove "systemd", which is protected
    Error: Trying to remove "yum", which is protected
    The output of yum update --skip-broken is (I removed the update-list on top):
    Code:
    Packages skipped because of dependency problems:
        abrt-addon-kerneloops-2.1.11-1.fc20.x86_64 from updates
        abrt-addon-pstoreoops-2.1.11-1.fc20.x86_64 from updates
        abrt-addon-python-2.1.11-1.fc20.x86_64 from updates
        abrt-addon-vmcore-2.1.11-1.fc20.x86_64 from updates
        abrt-addon-xorg-2.1.11-1.fc20.x86_64 from updates
        abrt-dbus-2.1.11-1.fc20.x86_64 from updates
        abrt-desktop-2.1.11-1.fc20.x86_64 from updates
        abrt-gui-2.1.11-1.fc20.x86_64 from updates
        abrt-plugin-bodhi-2.1.11-1.fc20.x86_64 from updates
        audit-libs-python-2.3.3-1.fc20.x86_64 from updates
        libreport-fedora-2.1.11-1.fc20.x86_64 from updates
        libreport-plugin-kerneloops-2.1.11-1.fc20.x86_64 from updates
        libreport-plugin-logger-2.1.11-1.fc20.x86_64 from updates
        policycoreutils-python-2.2.5-1.fc20.x86_64 from updates
    Error:  Multilib version problems found. This often means that the root
           cause is something else and multilib version checking is just
           pointing out that there is a problem. Eg.:
           
             1. You have an upgrade for nss-softokn-freebl which is missing some
                dependency that another package requires. Yum is trying to
                solve this by installing an older version of nss-softokn-freebl of the
                different architecture. If you exclude the bad architecture
                yum will tell you what the root cause is (which package
                requires what). You can try redoing the upgrade with
                --exclude nss-softokn-freebl.otherarch ... this should give you an error
                message showing the root cause of the problem.
           
             2. You have multiple architectures of nss-softokn-freebl installed, but
                yum can only see an upgrade for one of those architectures.
                If you don't want/need both architectures anymore then you
                can remove the one with the missing update and everything
                will work.
           
             3. You have duplicate versions of nss-softokn-freebl installed already.
                You can use "yum check" to get yum show these errors.
           
           ...you can also use --setopt=protected_multilib=false to remove
           this checking, however this is almost never the correct thing to
           do as something else is very likely to go wrong (often causing
           much more problems).
           
           Protected multilib versions: nss-softokn-freebl-3.15.4-1.fc20.i686 != nss-softokn-freebl-3.15.3-1.fc20.x86_64
    The problems began after I had run yum update. While running (or maybe it was finished), the screen went black and all I saw was the Fedora logo. I had to restart the system.

    I hope someone can help me out. Thanks!

  2. #2
    leigh123linux Guest

    Re: A lot of duplicates in YUM

    Try

    Code:
    rpm -e yum-3.4.3-128.fc20.noarch
    package-cleanup --cleandupes

  3. #3
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    Re: A lot of duplicates in YUM

    Quote Originally Posted by leigh123linux
    Try

    Code:
    rpm -e yum-3.4.3-128.fc20.noarch
    package-cleanup --cleandupes
    Thanks for your help. I think the first line removed the duplicate, since it is not in the list of yum check anymore. However, package-cleanup --cleandupes still reported the same errors.

    Code:
    Error: Trying to remove "systemd", which is protected
    Error: Trying to remove "yum", which is protected
    .

  4. #4
    leigh123linux Guest

    Re: A lot of duplicates in YUM

    Try this, post the output


    Code:
    package-cleanup --cleandupes -x systemd\*,yum

  5. #5
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    Re: A lot of duplicates in YUM

    Here you can find the output of the package-cleanup command you gave me: Pastebin.

  6. #6
    leigh123linux Guest

    Re: A lot of duplicates in YUM

    Ok try


    Code:
    package-cleanup --cleandupes -x procps-ng,systemd\*,libgudev1\*,*\yum\*

  7. #7
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    Re: A lot of duplicates in YUM

    The output is almost the same. Here is the difference between the two.

    Code:
    --- -	2014-01-27 16:59:11.751608732 +0100
    +++ /home/jvhoof/log.txt	2014-01-27 16:58:47.723559838 +0100
    @@ -3481,4 +3481,3 @@
     popt-1.16-2.fc20.x86_64 is a duplicate with popt-1.16-1.fc20.x86_64
     satyr-0.13-1.fc20.x86_64 is a duplicate with satyr-0.12-1.fc20.x86_64
     udisks2-2.1.2-1.fc20.x86_64 is a duplicate with udisks2-2.1.1-1.fc20.x86_64
    -
    Hmm, maybe it's some dependency of yum or systemd that is duplicated. It feels to me like the whole system is duplicated, actually.
    Last edited by Yatoom; 27th January 2014 at 05:20 PM.

  8. #8
    Join Date
    Aug 2009
    Posts
    9

    Re: A lot of duplicates in YUM

    Interesting - exploring Fedora, I tried this suggestion:

    When I run package-cleanup --cleanupdupes, I am proposed to remove 3 packages + 359 dependant packages (I installed + updated Fedora today) . Looks like an invitation to cause havoc - the dependencies suggested for removal mostly look essential. Looking at the 3 packages themselves with rpm -qa | grep <package-name>, I get (all items, respectively, with the same version-release):
    - 3 times freetype
    - 4 times libX11
    - 2 times qt-x11

    Looks like after a clean installation and a single update (apper) there are really some duplicates, and looks like package-cleanup would destroy not only the duplicates, but all (otherwise required) dependencies - which are installed one single time (according to rpm -qa).

    Back to the original question: how destroy the duplicates, but keep their first instance and the dependencies (i.e tidy the system, but keep it in working order)?

  9. #9
    leigh123linux Guest

    Re: A lot of duplicates in YUM

    Quote Originally Posted by Yatoom
    The output is almost the same. Here is the difference between the two.

    Code:
    --- -    2014-01-27 16:59:11.751608732 +0100
    +++ /home/jvhoof/log.txt    2014-01-27 16:58:47.723559838 +0100
    @@ -3481,4 +3481,3 @@
     popt-1.16-2.fc20.x86_64 is a duplicate with popt-1.16-1.fc20.x86_64
     satyr-0.13-1.fc20.x86_64 is a duplicate with satyr-0.12-1.fc20.x86_64
     udisks2-2.1.2-1.fc20.x86_64 is a duplicate with udisks2-2.1.1-1.fc20.x86_64
    -
    Hmm, maybe it's some dependency of yum or systemd that is duplicated. It feels to me like the whole system is duplicated, actually.
    Can you post

    Code:
    rpm -qa systemd\* *\yum\*  libgude\*

  10. #10
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    Re: A lot of duplicates in YUM

    @quichotte, I can't remember installing stuff twice either.

    @leigh123linux, here it is:

    Code:
    # rpm -qa systemd\* *\yum\*  libgude\*
    yum-3.4.3-132.fc20.noarch
    libgudev1-208-9.fc20.x86_64
    systemd-208-9.fc20.x86_64
    systemd-libs-208-9.fc20.x86_64
    yum-utils-1.1.31-19.fc20.noarch
    PackageKit-yum-plugin-0.8.15-1.fc20.x86_64
    PackageKit-yum-0.8.15-1.fc20.x86_64
    yum-metadata-parser-1.1.4-9.fc20.x86_64
    anaconda-yum-plugins-1.0-10.fc20.noarch
    yum-langpacks-0.4.3-1.fc20.noarch
    systemd-python-208-9.fc20.x86_64
    Last edited by Yatoom; 27th January 2014 at 07:12 PM.

  11. #11
    leigh123linux Guest

    Re: A lot of duplicates in YUM

    Quote Originally Posted by Yatoom
    @quichotte, I can't remember installing stuff twice either.

    @leigh123linux, here it is:

    Code:
    # rpm -qa systemd\* *\yum\*  libgude\*
    yum-3.4.3-132.fc20.noarch
    libgudev1-208-9.fc20.x86_64
    systemd-208-9.fc20.x86_64
    systemd-libs-208-9.fc20.x86_64
    yum-utils-1.1.31-19.fc20.noarch
    PackageKit-yum-plugin-0.8.15-1.fc20.x86_64
    PackageKit-yum-0.8.15-1.fc20.x86_64
    yum-metadata-parser-1.1.4-9.fc20.x86_64
    anaconda-yum-plugins-1.0-10.fc20.noarch
    yum-langpacks-0.4.3-1.fc20.noarch
    systemd-python-208-9.fc20.x86_64
    You got the dupes because yum didn't complete a transaction, maybe your system crashed during an update?


    Ok post the complete list.

    Code:
    package-cleanup --dupes
    Also post
    Code:
    package-cleanup --problems

  12. #12
    Join Date
    Aug 2011
    Location
    ~
    Posts
    1,943

    Re: A lot of duplicates in YUM

    I use to fix duplicates with something like this.
    Code:
    rpm --nodeps --noscripts -e package
    I'm not sure whether this is the actual command or the best way to clean duplicates though.

  13. #13
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    Re: A lot of duplicates in YUM

    Quote Originally Posted by leigh123linux
    You got the dupes because yum didn't complete a transaction, maybe your system crashed during an update?
    Yes, it crashed. I've more or less said that in the original post. I think it also crashed with an earlier update. Maybe I should have done yum --complete-transaction before I tried to update the system.

    Quote Originally Posted by leigh123linux
    package-cleanup --dupes
    Code:
    libudisks2-2.1.1-1.fc20.x86_64
    libudisks2-2.1.2-1.fc20.x86_64
    libreport-gtk-2.1.10-1.fc20.x86_64
    libreport-gtk-2.1.11-1.fc20.x86_64
    udisks2-2.1.2-1.fc20.x86_64
    udisks2-2.1.1-1.fc20.x86_64
    perl-libs-5.18.2-289.fc20.x86_64
    perl-libs-5.18.1-288.fc20.x86_64
    accountsservice-libs-0.6.35-3.fc20.x86_64
    accountsservice-libs-0.6.35-4.fc20.x86_64
    bind-license-9.9.4-8.fc20.noarch
    bind-license-9.9.4-11.P2.fc20.noarch
    audit-libs-2.3.3-1.fc20.x86_64
    audit-libs-2.3.2-1.fc20.x86_64
    abrt-python-2.1.11-1.fc20.x86_64
    abrt-python-2.1.10-1.fc20.x86_64
    abrt-retrace-client-2.1.11-1.fc20.x86_64
    abrt-retrace-client-2.1.10-1.fc20.x86_64
    glusterfs-3.4.2-1.fc20.x86_64
    glusterfs-3.4.1-3.fc20.x86_64
    abrt-libs-2.1.10-1.fc20.x86_64
    abrt-libs-2.1.11-1.fc20.x86_64
    dhcp-common-4.2.5-26.fc20.x86_64
    dhcp-common-4.2.5-30.fc20.x86_64
    kde-runtime-libs-4.11.4-1.fc20.x86_64
    kde-runtime-libs-4.11.5-1.fc20.x86_64
    popt-1.16-2.fc20.x86_64
    popt-1.16-1.fc20.x86_64
    gnome-abrt-0.3.5-1.fc20.x86_64
    gnome-abrt-0.3.4-1.fc20.x86_64
    nss-3.15.4-1.fc20.x86_64
    nss-3.15.3.1-1.fc20.x86_64
    kde-runtime-drkonqi-4.11.4-1.fc20.x86_64
    kde-runtime-drkonqi-4.11.5-1.fc20.x86_64
    kdepimlibs-kxmlrpcclient-4.11.4-1.fc20.x86_64
    kdepimlibs-kxmlrpcclient-4.11.5-1.fc20.x86_64
    kdelibs-common-4.11.4-1.fc20.x86_64
    kdelibs-common-4.11.5-1.fc20.x86_64
    abrt-2.1.10-1.fc20.x86_64
    abrt-2.1.11-1.fc20.x86_64
    libreport-plugin-reportuploader-2.1.10-1.fc20.x86_64
    libreport-plugin-reportuploader-2.1.11-1.fc20.x86_64
    initscripts-9.51-1.fc20.x86_64
    initscripts-9.50-1.fc20.x86_64
    perl-macros-5.18.2-289.fc20.x86_64
    perl-macros-5.18.1-288.fc20.x86_64
    perl-5.18.2-289.fc20.x86_64
    perl-5.18.1-288.fc20.x86_64
    satyr-0.12-1.fc20.x86_64
    satyr-0.13-1.fc20.x86_64
    coreutils-8.21-20.fc20.x86_64
    coreutils-8.21-18.fc20.x86_64
    kactivities-4.11.4-1.fc20.x86_64
    kactivities-4.11.5-1.fc20.x86_64
    php-common-5.5.7-1.fc20.x86_64
    php-common-5.5.8-1.fc20.x86_64
    nepomuk-core-libs-4.11.5-1.fc20.x86_64
    nepomuk-core-libs-4.11.4-1.fc20.x86_64
    policycoreutils-2.2.4-5.fc20.x86_64
    policycoreutils-2.2.5-1.fc20.x86_64
    glusterfs-libs-3.4.1-3.fc20.x86_64
    glusterfs-libs-3.4.2-1.fc20.x86_64
    NetworkManager-glib-0.9.9.0-26.git20131003.fc20.x86_64
    NetworkManager-glib-0.9.9.0-22.git20131003.fc20.x86_64
    libreport-python-2.1.11-1.fc20.x86_64
    libreport-python-2.1.10-1.fc20.x86_64
    perl-Module-CoreList-2.96-288.fc20.noarch
    perl-Module-CoreList-3.03-289.fc20.noarch
    gdk-pixbuf2-2.30.1-1.fc20.x86_64
    gdk-pixbuf2-2.30.3-1.fc20.x86_64
    mutter-3.10.3-1.fc20.x86_64
    mutter-3.10.2-6.fc20.x86_64
    libreport-filesystem-2.1.10-1.fc20.x86_64
    libreport-filesystem-2.1.11-1.fc20.x86_64
    libreport-2.1.11-1.fc20.x86_64
    libreport-2.1.10-1.fc20.x86_64
    dhcp-libs-4.2.5-26.fc20.x86_64
    dhcp-libs-4.2.5-30.fc20.x86_64
    kde-runtime-flags-4.11.5-1.fc20.noarch
    kde-runtime-flags-4.11.4-1.fc20.noarch
    abrt-gui-libs-2.1.11-1.fc20.x86_64
    abrt-gui-libs-2.1.10-1.fc20.x86_64
    abrt-addon-ccpp-2.1.11-1.fc20.x86_64
    abrt-addon-ccpp-2.1.10-1.fc20.x86_64
    oxygen-icon-theme-4.11.4-1.fc20.noarch
    oxygen-icon-theme-4.11.5-1.fc20.noarch
    kde-runtime-4.11.5-1.fc20.x86_64
    kde-runtime-4.11.4-1.fc20.x86_64
    p11-kit-0.20.2-1.fc20.x86_64
    p11-kit-0.20.1-1.fc20.x86_64
    nss-sysinit-3.15.3.1-1.fc20.x86_64
    nss-sysinit-3.15.4-1.fc20.x86_64
    kdelibs-4.11.4-1.fc20.x86_64
    kdelibs-4.11.5-1.fc20.x86_64
    libreport-web-2.1.11-1.fc20.x86_64
    libreport-web-2.1.10-1.fc20.x86_64
    gdb-7.6.50.20130731-19.fc20.x86_64
    gdb-7.6.50.20130731-16.fc20.x86_64
    PackageKit-glib-0.8.16-1.fc20.x86_64
    PackageKit-glib-0.8.15-1.fc20.x86_64
    libreport-plugin-ureport-2.1.10-1.fc20.x86_64
    libreport-plugin-ureport-2.1.11-1.fc20.x86_64
    control-center-filesystem-3.10.2-3.fc20.x86_64
    control-center-filesystem-3.10.2-4.fc20.x86_64
    nss-util-3.15.4-1.fc20.x86_64
    nss-util-3.15.3-1.fc20.x86_64
    accountsservice-0.6.35-4.fc20.x86_64
    accountsservice-0.6.35-3.fc20.x86_64
    nss-softokn-freebl-3.15.3-1.fc20.x86_64
    nss-softokn-freebl-3.15.4-1.fc20.x86_64
    nss-softokn-3.15.3-1.fc20.x86_64
    nss-softokn-3.15.4-1.fc20.x86_64
    libreport-plugin-bugzilla-2.1.10-1.fc20.x86_64
    libreport-plugin-bugzilla-2.1.11-1.fc20.x86_64
    ibus-libs-1.5.5-1.fc20.x86_64
    ibus-libs-1.5.4-2.fc20.x86_64
    nepomuk-core-4.11.5-1.fc20.x86_64
    nepomuk-core-4.11.4-1.fc20.x86_64
    Quote Originally Posted by leigh123linux
    package-cleanup --problems
    Code:
    No Problems Found
    Quote Originally Posted by Dutchy
    I use to fix duplicates with something like this.
    Code:
    rpm --nodeps --noscripts -e package
    I'm not sure whether this is the actual command or the best way to clean duplicates though.
    Thanks. I might try this later.

  14. #14
    leigh123linux Guest

    Re: A lot of duplicates in YUM

    Ok run (copy and paste it, it is all one command), first command block is a test run.


    Code:
    rpm -e --test \
    libudisks2-2.1.1-1.fc20.x86_64 \
    libreport-gtk-2.1.10-1.fc20.x86_64 \
    udisks2-2.1.1-1.fc20.x86_64 \
    perl-libs-5.18.1-288.fc20.x86_64 \
    accountsservice-libs-0.6.35-3.fc20.x86_64 \
    bind-license-9.9.4-8.fc20.noarch \
    audit-libs-2.3.2-1.fc20.x86_64 \
    abrt-python-2.1.10-1.fc20.x86_64 \
    abrt-retrace-client-2.1.10-1.fc20.x86_64 \
    glusterfs-3.4.1-3.fc20.x86_64 \
    abrt-libs-2.1.10-1.fc20.x86_64 \
    dhcp-common-4.2.5-26.fc20.x86_64 \
    kde-runtime-libs-4.11.4-1.fc20.x86_64 \
    popt-1.16-1.fc20.x86_64 \
    gnome-abrt-0.3.4-1.fc20.x86_64 \
    nss-3.15.3.1-1.fc20.x86_64 \
    kde-runtime-drkonqi-4.11.4-1.fc20.x86_64 \
    kdepimlibs-kxmlrpcclient-4.11.4-1.fc20.x86_64 \
    kdelibs-common-4.11.4-1.fc20.x86_64 \
    abrt-2.1.10-1.fc20.x86_64 \
    libreport-plugin-reportuploader-2.1.10-1.fc20.x86_64 \
    initscripts-9.50-1.fc20.x86_64 \
    perl-macros-5.18.1-288.fc20.x86_64 \
    perl-5.18.1-288.fc20.x86_64 \
    satyr-0.12-1.fc20.x86_64 \
    coreutils-8.21-18.fc20.x86_64 \
    kactivities-4.11.4-1.fc20.x86_64 \
    php-common-5.5.7-1.fc20.x86_64 \
    nepomuk-core-libs-4.11.4-1.fc20.x86_64 \
    policycoreutils-2.2.4-5.fc20.x86_64 \
    glusterfs-libs-3.4.1-3.fc20.x86_64 \
    NetworkManager-glib-0.9.9.0-22.git20131003.fc20.x86_64 \
    libreport-python-2.1.10-1.fc20.x86_64 \
    perl-Module-CoreList-2.96-288.fc20.noarch \
    gdk-pixbuf2-2.30.1-1.fc20.x86_64 \
    mutter-3.10.2-6.fc20.x86_64 \
    libreport-filesystem-2.1.10-1.fc20.x86_64 \
    libreport-2.1.10-1.fc20.x86_64 \
    dhcp-libs-4.2.5-26.fc20.x86_64 \
    kde-runtime-flags-4.11.4-1.fc20.noarch \
    abrt-gui-libs-2.1.10-1.fc20.x86_64 \
    abrt-addon-ccpp-2.1.10-1.fc20.x86_64 \
    oxygen-icon-theme-4.11.4-1.fc20.noarch \
    kde-runtime-4.11.4-1.fc20.x86_64 \
    p11-kit-0.20.1-1.fc20.x86_64 \
    nss-sysinit-3.15.3.1-1.fc20.x86_64 \
    kdelibs-4.11.4-1.fc20.x86_64 \
    libreport-web-2.1.10-1.fc20.x86_64 \
    gdb-7.6.50.20130731-16.fc20.x86_64 \
    PackageKit-glib-0.8.15-1.fc20.x86_64 \
    libreport-plugin-ureport-2.1.10-1.fc20.x86_64 \
    control-center-filesystem-3.10.2-3.fc20.x86_64 \
    nss-util-3.15.3-1.fc20.x86_64 \
    accountsservice-0.6.35-3.fc20.x86_64 \
    nss-softokn-freebl-3.15.3-1.fc20.x86_64 \
    nss-softokn-3.15.3-1.fc20.x86_64 \
    libreport-plugin-bugzilla-2.1.10-1.fc20.x86_64 \
    ibus-libs-1.5.4-2.fc20.x86_64 \
    nepomuk-core-4.11.4-1.fc20.x86_64
    If it produces no errors run


    Code:
    rpm -e \
    libudisks2-2.1.1-1.fc20.x86_64 \
    libreport-gtk-2.1.10-1.fc20.x86_64 \
    udisks2-2.1.1-1.fc20.x86_64 \
    perl-libs-5.18.1-288.fc20.x86_64 \
    accountsservice-libs-0.6.35-3.fc20.x86_64 \
    bind-license-9.9.4-8.fc20.noarch \
    audit-libs-2.3.2-1.fc20.x86_64 \
    abrt-python-2.1.10-1.fc20.x86_64 \
    abrt-retrace-client-2.1.10-1.fc20.x86_64 \
    glusterfs-3.4.1-3.fc20.x86_64 \
    abrt-libs-2.1.10-1.fc20.x86_64 \
    dhcp-common-4.2.5-26.fc20.x86_64 \
    kde-runtime-libs-4.11.4-1.fc20.x86_64 \
    popt-1.16-1.fc20.x86_64 \
    gnome-abrt-0.3.4-1.fc20.x86_64 \
    nss-3.15.3.1-1.fc20.x86_64 \
    kde-runtime-drkonqi-4.11.4-1.fc20.x86_64 \
    kdepimlibs-kxmlrpcclient-4.11.4-1.fc20.x86_64 \
    kdelibs-common-4.11.4-1.fc20.x86_64 \
    abrt-2.1.10-1.fc20.x86_64 \
    libreport-plugin-reportuploader-2.1.10-1.fc20.x86_64 \
    initscripts-9.50-1.fc20.x86_64 \
    perl-macros-5.18.1-288.fc20.x86_64 \
    perl-5.18.1-288.fc20.x86_64 \
    satyr-0.12-1.fc20.x86_64 \
    coreutils-8.21-18.fc20.x86_64 \
    kactivities-4.11.4-1.fc20.x86_64 \
    php-common-5.5.7-1.fc20.x86_64 \
    nepomuk-core-libs-4.11.4-1.fc20.x86_64 \
    policycoreutils-2.2.4-5.fc20.x86_64 \
    glusterfs-libs-3.4.1-3.fc20.x86_64 \
    NetworkManager-glib-0.9.9.0-22.git20131003.fc20.x86_64 \
    libreport-python-2.1.10-1.fc20.x86_64 \
    perl-Module-CoreList-2.96-288.fc20.noarch \
    gdk-pixbuf2-2.30.1-1.fc20.x86_64 \
    mutter-3.10.2-6.fc20.x86_64 \
    libreport-filesystem-2.1.10-1.fc20.x86_64 \
    libreport-2.1.10-1.fc20.x86_64 \
    dhcp-libs-4.2.5-26.fc20.x86_64 \
    kde-runtime-flags-4.11.4-1.fc20.noarch \
    abrt-gui-libs-2.1.10-1.fc20.x86_64 \
    abrt-addon-ccpp-2.1.10-1.fc20.x86_64 \
    oxygen-icon-theme-4.11.4-1.fc20.noarch \
    kde-runtime-4.11.4-1.fc20.x86_64 \
    p11-kit-0.20.1-1.fc20.x86_64 \
    nss-sysinit-3.15.3.1-1.fc20.x86_64 \
    kdelibs-4.11.4-1.fc20.x86_64 \
    libreport-web-2.1.10-1.fc20.x86_64 \
    gdb-7.6.50.20130731-16.fc20.x86_64 \
    PackageKit-glib-0.8.15-1.fc20.x86_64 \
    libreport-plugin-ureport-2.1.10-1.fc20.x86_64 \
    control-center-filesystem-3.10.2-3.fc20.x86_64 \
    nss-util-3.15.3-1.fc20.x86_64 \
    accountsservice-0.6.35-3.fc20.x86_64 \
    nss-softokn-freebl-3.15.3-1.fc20.x86_64 \
    nss-softokn-3.15.3-1.fc20.x86_64 \
    libreport-plugin-bugzilla-2.1.10-1.fc20.x86_64 \
    ibus-libs-1.5.4-2.fc20.x86_64 \
    nepomuk-core-4.11.4-1.fc20.x86_64

  15. #15
    Join Date
    Apr 2012
    Location
    The Netherlands
    Posts
    7

    Re: A lot of duplicates in YUM

    Thanks for making the list But I did this instead.
    Code:
    rpm --nodeps --noscripts -e libreport-gtk-2.1.10-1.fc20.x86_64 udisks2-2.1.2-1.fc20.x86_64 perl-libs-5.18.2-289.fc20.x86_64 accountsservice-libs-0.6.35-3.fc20.x86_64 bind-license-9.9.4-8.fc20.noarch audit-libs-2.3.3-1.fc20.x86_64 abrt-python-2.1.11-1.fc20.x86_64 abrt-retrace-client-2.1.11-1.fc20.x86_64 glusterfs-3.4.2-1.fc20.x86_64 abrt-libs-2.1.10-1.fc20.x86_64 dhcp-common-4.2.5-26.fc20.x86_64 kde-runtime-libs-4.11.4-1.fc20.x86_64 popt-1.16-2.fc20.x86_64 gnome-abrt-0.3.5-1.fc20.x86_64 nss-3.15.4-1.fc20.x86_64 kde-runtime-drkonqi-4.11.4-1.fc20.x86_64 kdepimlibs-kxmlrpcclient-4.11.4-1.fc20.x86_64 kdelibs-common-4.11.4-1.fc20.x86_64 abrt-2.1.10-1.fc20.x86_64 libreport-plugin-reportuploader-2.1.10-1.fc20.x86_64 initscripts-9.51-1.fc20.x86_64 perl-macros-5.18.2-289.fc20.x86_64 perl-5.18.2-289.fc20.x86_64 satyr-0.12-1.fc20.x86_64 coreutils-8.21-20.fc20.x86_64 kactivities-4.11.4-1.fc20.x86_64 php-common-5.5.7-1.fc20.x86_64 nepomuk-core-libs-4.11.5-1.fc20.x86_64 policycoreutils-2.2.4-5.fc20.x86_64 glusterfs-libs-3.4.1-3.fc20.x86_64 NetworkManager-glib-0.9.9.0-26.git20131003.fc20.x86_64 libreport-python-2.1.11-1.fc20.x86_64 perl-Module-CoreList-2.96-288.fc20.noarch gdk-pixbuf2-2.30.1-1.fc20.x86_64 mutter-3.10.3-1.fc20.x86_64 libreport-filesystem-2.1.10-1.fc20.x86_64 libreport-2.1.11-1.fc20.x86_64 dhcp-libs-4.2.5-26.fc20.x86_64 kde-runtime-flags-4.11.5-1.fc20.noarch abrt-gui-libs-2.1.11-1.fc20.x86_64 abrt-addon-ccpp-2.1.11-1.fc20.x86_64 oxygen-icon-theme-4.11.4-1.fc20.noarch kde-runtime-4.11.5-1.fc20.x86_64 p11-kit-0.20.2-1.fc20.x86_64 nss-sysinit-3.15.3.1-1.fc20.x86_64 kdelibs-4.11.4-1.fc20.x86_64 libreport-web-2.1.11-1.fc20.x86_64 gdb-7.6.50.20130731-19.fc20.x86_64 PackageKit-glib-0.8.16-1.fc20.x86_64 libreport-plugin-ureport-2.1.10-1.fc20.x86_64 control-center-filesystem-3.10.2-3.fc20.x86_64 nss-util-3.15.4-1.fc20.x86_64 accountsservice-0.6.35-4.fc20.x86_64 nss-softokn-freebl-3.15.3-1.fc20.x86_64 nss-softokn-3.15.3-1.fc20.x86_64 libreport-plugin-bugzilla-2.1.10-1.fc20.x86_64 ibus-libs-1.5.5-1.fc20.x86_64 nepomuk-core-4.11.5-1.fc20.x86_64
    After that, I am able to yum update without errors.

    Thank you!
    Here is a funny text, because you helped me: link.

    Quick summary of solution:
    Store duplicate-list in a file.
    # package-cleanup --dupes > duplicates.txt

    Remove odd lines.
    # awk 'NR%2==0' duplicates.txt > single-duplicates.txt

    Replace new lines with spaces.
    # awk '{ printf "%s ", $0 }' single-duplicates.txt > duplicates.txt

    Copy-paste content of duplicates after command.
    # rpm --nodeps --noscripts -e [paste here]

Page 1 of 2 1 2 LastLast

Similar Threads

  1. [SOLVED]
    yum update reports duplicates and missing dependencies
    By Kristoffer in forum Using Fedora
    Replies: 11
    Last Post: 29th January 2013, 05:26 AM
  2. remove duplicates.
    By atar1 in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 26th May 2012, 08:37 PM
  3. lot of disk access after yum updates
    By Imiro in forum Using Fedora
    Replies: 2
    Last Post: 1st March 2009, 09:39 PM
  4. checking for duplicates
    By lesliek in forum Using Fedora
    Replies: 8
    Last Post: 11th May 2005, 08:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •