[SOLVED] fedora 20 enable vsync with intel graphics
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Oct 2011
    Location
    Amsterdam
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    fedora 20 enable vsync with intel graphics

    Hello! I'm on fedora 20 with Intel® Haswell Mobile graphics (HD 4600, I suppose). When I play video the screen is chopped. How to enable vertical synchronization with Intel graphics?

  2. #2
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,069
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    First off, you should determine if vblanking is turned off or not. A good way to do that is to run the "glxgears" command from a terminal. When the glxgears box comes up with the spinnibg gears, put your mouse curser inside the window, and watch the output in the terminal.

    If you're getting something like this:
    Code:
    34864 frames in 5.0 seconds = 6972.768 FPS
    37210 frames in 5.0 seconds = 7441.921 FPS
    37505 frames in 5.0 seconds = 7500.925 FPS
    ..then vblanking is turned off. If FPS rate is reported at something very close to 60fps, or whatever your monitor vertical refresh rate actually is, then vblanking is already on. Some programs may actually override the current vblank setting.

    On my laptop with Intel(R) Core(TM) i5-3210M CPU (IvyBridge), vlanking was on by default so I turned it off with an entry in my ~/.bash_profile file.
    Code:
    # User specific environment and startup programs
    
    export vblank_mode=0
    If you find vblank if on by default and you want it off, then you can add the same line, but use =1 instead of =0 to turn it on. You can also issue the command at the command line just ahead of launching a program to test things. I think something like this:
    Code:
    vlblank_mode=1 vlc
    You could try this. In a terminal:
    Code:
    export vblank_mode=1

  3. #3
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,069
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    Well, now I'm a bit puzzled as I reset my vblank_mode to 1 (on) to test and glxgears is still reporting the higher frame rates instead of something at the laptops lcd screen refresh rate. Maybe that needed a reboot or re-login.

  4. #4
    Join Date
    Oct 2011
    Location
    Amsterdam
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    Thank you for detailed answer. It seems for me that vblank is on (have 60 fps). But why videos are chopped in vlc and totem? Will try running vlc from terminal with vblank_mode=1 later and report the result.

  5. #5
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,069
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    Will try running vlc from terminal with vblank_mode=1
    Well, since vblank_mode on your system is already ON, turning it ON again using the environment variable shouldn't make any change. Try turning it OFF (=0) and see if anything changes.

    And I discovered this morning why I couldn't get my vblank_mode to actually use the ON mode by resetting the vblank_mode variable. I had a file named drirc sitting in the top directory of my $HOME (since moved elsewhere).
    Code:
    $ cat Documents/Files/Fixes/drirc
    <driconf>
       <device screen="0" driver="i915">
          <application name="all">
             <!-- Always synchronize with vertical refresh to avoid tearing -->
             <option name="vblank_mode" value="0"/>
          </application>
       </device>
    </driconf>
    It was overriding the environment variable setting, which now explains the warning message glxgears was giving me.

  6. #6
    Join Date
    Oct 2011
    Location
    Amsterdam
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    chopped video in both cases with vblank on and off strange

  7. #7
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,069
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Then I would have to say that vblank, on or off, isn't the cause of the choppy video.


    Sent from my Nexus 7

  8. #8
    dobbi Guest

    Re: fedora 20 enable vsync with intel graphics

    Video playback is not controlled by the VAAPI thing?

    https://01.org/linuxgraphics/community
    http://freedesktop.org/wiki/Software/vaapi/
    http://www.phoronix.com/scan.php?pag...00_linux&num=1

    Model and driver would be useful to lookup stuff.

    lspci -k | grep -iA 3 vga

  9. #9
    Join Date
    Oct 2011
    Location
    Amsterdam
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    Thanks dobbi. Never heard about VAAPI before (used nvidia graphics before). Here is command output:
    00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
    Subsystem: Toshiba America Info Systems Device fa47
    Kernel driver in use: i915

  10. #10
    Join Date
    Oct 2011
    Location
    Amsterdam
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    Thanks dobby one more time! I fixed it in vlc by adding to /etc/environment:
    CLUTTER_PAINT=disable-clipped-redraws:disable-culling
    CLUTTER_VBLANK=True

  11. #11
    Join Date
    Jan 2013
    Location
    Poland
    Posts
    100
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: fedora 20 enable vsync with intel graphics

    Are you sure about the line?
    Code:
    CLUTTER_VBLANK
    I haven't found any up-to-date info on the parameter. Also arch wiki on gnome recommends just the first line.

    Some general info:
    For older generation of Intel graphics this bollocks started around January 2013. The clutter_paint workaround didn't restore the previosuly excellent, smooth animations. It was supposed to be fixed with the advent of Mesa 10 and DRI3 (Xorg 1.15) but this didn't happen (tested on more fresh distros). So don't hold your breath.

    We're most probably stuck with it until Wayland-enabled Gnome gets released (~3.14) because apparently Intel and Gnome guys have little regard for end user experience.

Similar Threads

  1. How enable ati/intel flgrx drivers on fedora 19?
    By gomesc in forum F19 Development
    Replies: 6
    Last Post: 26th June 2013, 10:38 AM
  2. Fedora 16: how to disable vsync for Intel Graphics card?
    By Sagari in forum Hardware & Laptops
    Replies: 0
    Last Post: 15th December 2011, 03:56 PM
  3. Replies: 4
    Last Post: 18th July 2010, 03:52 AM
  4. Fedora 13 on old P4 with intel graphics
    By BobNutfield in forum Fedora 13 Development Branch
    Replies: 15
    Last Post: 25th April 2010, 06:16 AM
  5. How to enable Desktop Effects with Intel on board Graphics Card on Fedora 10?
    By apocalyptic in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 17th January 2009, 10:05 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •