[SOLVED] Anybody got XDMCP working with lightdm?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2012
    Location
    USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Anybody got XDMCP working with lightdm?

    Greetings,

    I'm trying to get lightdm to act like a display manager and provide a remote xsession to Xming running on Windows. Its more of an exercise just to see if I could do it, since I can use PuTTY and X11 forward all the clients I like. It would just be nice to have the whole desktop session though.

    Here's the changes I've made to lightdm.conf (/etc/lightdm/lightdm.conf) I've tried various combinations of these parameters. What I'm sure IS my issue is that I cannot figure out how to get the system to start X without the -nolisten tcp option.

    root 5942 5938 0 00:40 tty1 00:00:48 /usr/bin/X -background none :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch

    netstat shows port 177 listening on 0.0.0.0. When I comment out the port params in lightdm.conf and restart, I see the listener go away.

    #
    # Begin the XDMCP experiment
    # Trying to get a X login up on Win7 through Xming
    #
    # type = Seat type (xlocal, xremote)
    # xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
    # xdmcp-port = XDMCP UDP/IP port to communicate on
    # xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
    #

    [Seat:1]
    type=xremote
    xserver-allow-tcp=true
    [XDMCPServer]
    # enabled=true
    # port=177
    xdmcp-manager=10.23.62.26
    xdmcp-port=177

  2. #2
    Join Date
    Feb 2012
    Location
    USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up Re: Anybody got XDMCP working with lightdm?

    This is working - somewhat.

    The pulseaudio daemon isn't producing any sound when watching videos or playing music and the dbus-helper throws an error when trying to start the bluetooth manager.

    Port 177 UDP must be allowed using ipchains.
    Port 6000-6012 TCP must be allowed using ipchains

    # netstat -anl | egrep ':177|:6000'
    tcp 0 0 10.23.62.26:38268 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38302 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38284 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38294 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38236 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38274 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38253 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38262 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38277 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38254 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38266 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38241 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38283 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38295 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38306 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38713 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38251 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38267 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38233 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38272 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38301 10.23.62.27:6000 ESTABLISHED
    tcp 0 68 10.23.62.26:38269 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38258 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38280 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38273 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38261 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38235 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38282 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38242 10.23.62.27:6000 ESTABLISHED
    tcp 33 0 10.23.62.26:37531 10.23.62.27:6000 CLOSE_WAIT
    tcp 0 0 10.23.62.26:38248 10.23.62.27:6000 ESTABLISHED
    tcp 0 0 10.23.62.26:38252 10.23.62.27:6000 ESTABLISHED
    udp 0 0 0.0.0.0:177 0.0.0.0:*
    udp6 0 0 :::177 :::*

    The Xming configuration (Using Xlaunch) I used is:

    One Window
    Display 0
    Open session via XDMCP
    Connect to Host. Place the IP address or hostname of my Fedora machine in the box provided.
    Leave the 'Integrated Clipboard Manager' option checked.
    Save Configuration.

    After some more experimentation, the following lightdm.conf entries produced a login window through Xming:
    The key is a string of characters that must also appear (*I think*) in the keys.conf file in /etc/lightdm .

    /etc/lightdm/lightdm.conf

    [Seat:1]
    type=xremote
    greeter-session=lightdm-greeter
    greeter-show-remote-login=true
    remote-sessions-directory=/usr/share/lightdm/remote-sessions
    [XDMCPServer]
    enabled=true
    port=177
    key=*******

    /etc/lightdm/keys.conf
    [keyring]
    a=0x0123456789ABCD
    b=*******

    After making those edits to lightdm configuration files as the root user, issue a restart of lightdm:

    # systemctl restart lightdm.service

    Start Xming and the xfce4 session appears in the Root Window.

  3. #3
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Anybody got XDMCP working with lightdm?

    You likely won't get the audio working, or bluetooth... That isn't a X protocol.

  4. #4
    Join Date
    Feb 2012
    Location
    USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Anybody got XDMCP working with lightdm?

    jpollard,

    Indeed I did, although I have no idea how. I found the following parameter in /etc/pulse/system.pa and added the remote parameter. I then restarted lightdm and killed the currently running pulseaudio process. When I started rhythmbox I got music. Then I backed out the changes, restarted lightdm and killed pulseaudio and STILL got music from rhythmbox.

    .ifexists module-dbus-protocol.so
    ### If you want to allow TCP connections, set access to "remote" or "local,remote".
    load-module module-dbus-protocol access=local
    .endif

    What still doesn't work are any of the installed video players. If I login locally, it all works. Through Xming and remote session, it crashes immediately after launch.

    As for the Bluetooth, I agree with you, I'll never get it to work.. No matter, I just wanted to see if I could get the remote session working and I did.

    Thanks for your comment though, was starting to think no one cared ...

    Rusty

  5. #5
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Anybody got XDMCP working with lightdm?

    The usual problem caused by audio is that it is an unauthenticated connection.

    The problem with XDMCP is that is passes your login credentials unencrypted, and passes back the X authentication unencrypted. I have seen both used to capture and break into a system.

Similar Threads

  1. autologin in lightdm? or any other dm?
    By amitkher in forum Using Fedora
    Replies: 2
    Last Post: 14th November 2013, 12:37 PM
  2. LightDM language issue
    By arielnmz in forum Using Fedora
    Replies: 6
    Last Post: 14th January 2013, 08:09 AM
  3. Ubuntu to Drop GDM for LightDM
    By tox in forum Linux Chat
    Replies: 6
    Last Post: 11th December 2010, 08:19 AM
  4. F10: xdmcp not working
    By ydesgagne in forum Using Fedora
    Replies: 20
    Last Post: 28th July 2009, 05:15 AM
  5. XDMCP not working
    By Dragonmantank in forum Servers & Networking
    Replies: 5
    Last Post: 19th April 2005, 12:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •