FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Jan 2011
    Location
    NYC,NY
    Posts
    1,306

    rpmfusion in transition

    Right now I am running on rawhide in on one of my systems and I have some errors with liabv libraries while installing vlc. Looks like they want to change the build system and so that users may experience a snag while updating the their system in next few weeks.

    Code:
    yum update
    --> Finished Dependency Resolution
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libavformat.so.54()(64bit)
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libavcodec.so.54(LIBAVCODEC_54)(64bit)
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libavcodec.so.54()(64bit)
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libavformat.so.54(LIBAVFORMAT_54)(64bit)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    [root@localhost yum.repos.d]# yum update --skip-broken
    
    
    
    when I try to install vlc
    --> Finished Dependency Resolution
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-core.so.1.0()(64bit)
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-kbd.so.1.0()(64bit)
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-channels.so.1.0()(64bit)
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-codec.so.1.0()(64bit)
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-gdi.so.1.0()(64bit)
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-utils.so.1.0()(64bit)
    Error: Package: vlc-core-2.1.0-0.6.pre2.fc20.x86_64 (rpmfusion-free-rawhide)
               Requires: libfreerdp-rail.so.1.0()(64bit)
     You could try using --skip-broken to work around the problem
    LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

  2. #2
    leigh123linux Guest

    Re: rpmfusion in transition

    The buildsystem is proper f^^^ed

    https://bugzilla.rpmfusion.org/show_bug.cgi?id=2959

  3. #3
    Join Date
    Jan 2011
    Location
    NYC,NY
    Posts
    1,306

    Re: rpmfusion in transition

    If the situation is that bad users are going to suffer for a while. I was hoping to get things fixed sooner. Is there any alternate repo ?

    On the other hand I don't mind to build it myself but I need at least the src.rpm.
    LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

  4. #4
    Join Date
    May 2012
    Location
    Chongqing, China
    Posts
    8

    Re: rpmfusion in transition

    Same here, this is what I get when I try to install gstreamer1-libav:

    --> Finished Dependency Resolution
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free)
    Requires: libavcodec.so.54(LIBAVCODEC_54)(64bit)
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free)
    Requires: libavformat.so.54()(64bit)
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free)
    Requires: libavcodec.so.54()(64bit)
    Error: Package: gstreamer1-libav-1.1.3-1.fc20.x86_64 (rpmfusion-free)
    Requires: libavformat.so.54(LIBAVFORMAT_54)(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    When is this gonna be fixed?

    ---------- Post added at 05:43 PM ---------- Previous post was at 05:42 PM ----------

    And why rpmfusion bugzilla has SSL Error?

  5. #5
    Join Date
    Jan 2011
    Location
    NYC,NY
    Posts
    1,306

    Re: rpmfusion in transition

    It appears to be fixed for the last 24 hours. I see the commits in the ml. So the broken packages shall be fixed in the next updates which may take 1-2 days to reach your mirror.
    LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

  6. #6
    leigh123linux Guest

    Re: rpmfusion in transition

    Quote Originally Posted by yanglifu90
    Same here, this is what I get when I try to install gstreamer1-libav:



    When is this gonna be fixed?

    ---------- Post added at 05:43 PM ---------- Previous post was at 05:42 PM ----------

    And why rpmfusion bugzilla has SSL Error?
    http://www.forums.fedoraforum.org/sh...5&postcount=13

  7. #7
    Join Date
    Jan 2011
    Location
    NYC,NY
    Posts
    1,306

    Re: rpmfusion in transition

    Does that mean its not fixed yet?

    Thank you so much Leigh. I was waiting for these RPMs.
    LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

  8. #8
    leigh123linux Guest

    Re: rpmfusion in transition

    Quote Originally Posted by hadrons123
    Does that mean its not fixed yet?

    Thank you so much Leigh. I was waiting for these RPMs.
    The buildsystem is fixed but there is a long queue of rpm's that need rebuilding (due to the buildsystem randomly losing stuff).

  9. #9
    Join Date
    Jan 2011
    Location
    NYC,NY
    Posts
    1,306

    Re: rpmfusion in transition

    Vlc has a dependency for freerdp 1.0.2-6.fc20 which is fixed to the version not in rawhide and its a beta version of freerdp 1.1.0-0.6.beta.2013071101.fc21 in rawhide and so it ultimately breaks VLC and I filed a bug report against it which I doubt its going to be fixed anytime soon. For anyone trying to install VLC you will have to manually downgrade freerdp to freerdp 1.0.2-6.fc20 to get it working.
    LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

  10. #10
    Join Date
    Nov 2013
    Location
    marathon
    Posts
    1

    Re: rpmfusion in transition

    forums.fedoraforum.org/showthread.php?t=292668

  11. #11
    Join Date
    Jan 2011
    Location
    NYC,NY
    Posts
    1,306

    Re: rpmfusion in transition

    I certainly don't under stand why u have linked here
    LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

Similar Threads

  1. How to enable RPMFusion (free and nonfree) and sign the RPMFusion download
    By Cylinder57 in forum Guides & Solutions (Not For Questions)
    Replies: 2
    Last Post: 19th July 2013, 01:09 PM
  2. Beta to F18 transition !
    By whiteelephant in forum Using Fedora
    Replies: 4
    Last Post: 16th January 2013, 08:29 PM
  3. Domain transition problem
    By mlyczko in forum Security and Privacy
    Replies: 24
    Last Post: 13th March 2011, 05:27 PM
  4. rpmfusion transition
    By GoinEasy9 in forum Fedora 12 Alpha, Beta & Release Candidates
    Replies: 3
    Last Post: 15th November 2009, 07:44 PM
  5. Windows to Linux transition
    By Cazz in forum Using Fedora
    Replies: 5
    Last Post: 14th November 2005, 05:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •