rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernels
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 4 1 2 3 ... LastLast
Results 1 to 15 of 55
  1. #1
    leigh123linux Guest

    Arrow rpmfusion buildsystem issue - affects nvidia akmod and kmod for F19 with 3.11 kernels

    We can't currently build nvidia for the new 3.11 kernel due to missing buildsystem deps .


    Patched akmod-nvidia rpm

    i686


    http://www.linux-ati-drivers.homecal....fc19.i686.rpm



    x86_64

    http://www.linux-ati-drivers.homecal...c19.x86_64.rpm



    Patched akmod-nvidia-304xx rpm


    i686


    http://www.linux-ati-drivers.homecal....fc19.i686.rpm

    x86_64


    http://www.linux-ati-drivers.homecal...c19.x86_64.rpm





    Patched akmod-nvidia-173xx rpm



    i686


    http://www.linux-ati-drivers.homecal....fc19.i686.rpm



    x86_64



    http://www.linux-ati-drivers.homecal...c19.x86_64.rpm











    .
    Last edited by leigh123linux; 19th September 2013 at 04:48 PM.

  2. #2
    Join Date
    Aug 2009
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Thanks Leigh. Does this also affect catalyst? Also, do you have the srpms handy?

    Is this due to old buildsys-build-rpmfusion-kerneldevpkgs-current package?

    Cheers,
    -c

  3. #3
    leigh123linux Guest

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Quote Originally Posted by csmart
    Thanks Leigh. Does this also affect catalyst? Also, do you have the srpms handy?

    Is this due to old buildsys-build-rpmfusion-kerneldevpkgs-current package?

    Cheers,
    -c
    Catalyst didn't need patching for 3.11 so the akmod will still work, we're unable to build a new kmod-catalyst package due to old buildsys-build-rpmfusion-kerneldevpkgs-current.

  4. #4
    Join Date
    Aug 2009
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Quote Originally Posted by leigh123linux
    Catalyst didn't need patching for 3.11 so the akmod will still work, we're unable to build a new kmod-catalyst package due to old buildsys-build-rpmfusion-kerneldevpkgs-current.
    OK, thanks.

  5. #5
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,259
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    I was wondering why these were not present yet since both of you are usually very very quick!

    Thanks Leigh!

  6. #6
    Join Date
    Sep 2013
    Location
    upstate NY
    Posts
    195
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Forgive a Fedora newb (even though I used it several years ago). I have been using Ubuntu for a while and got use to apt-get instead.

    I'm currently using akmod for 304xx.

    This is saying I should update the akmod for 304xx to the above posted RPM in order to use a 3.11 kernel, correct?

  7. #7
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,259
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Quote Originally Posted by kingsombra
    This is saying I should update the akmod for 304xx to the above posted RPM in order to use a 3.11 kernel, correct?
    Yes!

  8. #8
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    76
    Posts
    24,485
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Leigh, thanks once again for an awesome fix. Tried without it and bork, upgraded the akmod and perfect!
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  9. #9
    Join Date
    Feb 2007
    Location
    China
    Posts
    161
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Thanks. This fix works for me!
    Home: Pentium III. 768M. GeForce GT 730. 120G(3 HDDs)
    Office: Lenovo Xiaoxin 700-15ISK
    Fedora 28

  10. #10
    Join Date
    Jun 2004
    Posts
    87
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Seems to be working as advertised.

    Thanks!

    - Gilboa
    Devel: Intel S2600C0, 2xE5-2658V2, 32GB, 6x2TB, 1x256GB-SSD, GTX1080, F33, Dell UP3216Q 4K.
    oVirt: Intel S2400GP2, 2xE5-2448L, 96GB, 10x2TB, GTX550, CentOS8.3.
    Win10: Gigabyte B85M-HD3, E3-1245V3, 32GB, 5x1TB, GTX980, Win10Pro.
    Devel-2: Asus H110M-K, i5-6500, 16GB, 3x1TB + 128GB-SSD, F33, Dell U2711.
    Laptop: ASUS Strix GL502V, i7-6700HQ, 32GB, 1TB+256GB, 1070M, F33.

  11. #11
    Join Date
    Aug 2005
    Posts
    46
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    How to install the akmod package? Got this error
    ================================================== ==========================
    [root@ Downloads]# rpm -ivh akmod-nvidia-319.32-3.fc19.i686.rpm
    Preparing... ################################# [100%]
    file /usr/src/akmods/nvidia-kmod.latest from install of akmod-nvidia-1:319.32-3.fc19.i686 conflicts with file from package akmod-nvidia-1:319.32-2.fc19.i686

  12. #12
    leigh123linux Guest

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Quote Originally Posted by jakerock
    How to install the akmod package? Got this error
    ================================================== ==========================
    [root@ Downloads]# rpm -ivh akmod-nvidia-319.32-3.fc19.i686.rpm
    Preparing... ################################# [100%]
    file /usr/src/akmods/nvidia-kmod.latest from install of akmod-nvidia-1:319.32-3.fc19.i686 conflicts with file from package akmod-nvidia-1:319.32-2.fc19.i686
    Update (-U) instead of install (-i)

    Code:
    rpm -Uvh akmod-nvidia-319.32-3.fc19.i686.rpm

  13. #13
    Join Date
    Sep 2013
    Location
    Germany
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    I'd been struggling for hours with this. Thank you very much indeed, it's very much appreciated.

    It would be good if systemd reported this video driver error as such: it took me quite a while to realise it was nothing to do with Plymouth but was the nvidia driver failing.

  14. #14
    Join Date
    May 2006
    Location
    Oklahoma
    Posts
    443
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    I still have problems.
    First the following information:
    I got the http://www.linux-ati-drivers.homecal...c19.x86_64.rpm and installed via:
    Code:
    yum localinstall akmod-nvidia-304xx-304.88-3.fc19.x86_64.rpm
    Now I have:
    Code:
    rpm -qa|grep nvidia
    kmod-nvidia-304xx-3.10.11-200.fc19.x86_64-304.88-2.fc19.6.x86_64
    xorg-x11-drv-nvidia-304xx-libs-304.88-12.fc19.x86_64
    nvidia-settings-319.32-1.fc19.x86_64
    akmod-nvidia-304xx-304.88-3.fc19.x86_64
    xorg-x11-drv-nvidia-304xx-304.88-12.fc19.x86_64
    nvidia-xconfig-319.32-1.fc19.x86_64
    kmod-nvidia-304xx-3.10.7-200.fc19.x86_64-304.88-2.fc19.4.x86_64
    and:
    Code:
    rpm -qa|grep kernel
    kernel-tools-3.11.1-200.fc19.x86_64
    abrt-addon-kerneloops-2.1.7-1.fc19.x86_64
    libreport-plugin-kerneloops-2.1.7-1.fc19.x86_64
    kernel-tools-libs-3.11.1-200.fc19.x86_64
    kernel-3.10.7-200.fc19.x86_64
    kernel-devel-3.11.1-200.fc19.x86_64
    kernel-devel-3.10.11-200.fc19.x86_64
    kernel-devel-3.10.7-200.fc19.x86_64
    kernel-3.11.1-200.fc19.x86_64
    kernel-headers-3.11.1-200.fc19.x86_64
    kernel-3.10.11-200.fc19.x86_64
    but when I "startx" in kernel version 3.11.1-200 it fails to start x saying no nvidia driver is found, and from the above it is obvious.

    I am posting this booted into kernel kernel-3.10.11-200.fc19.x86_64.

    Can any one help?

    Masoud
    I use F26 and Gnome Xfce, with all updates applied, on a X86_64 kernel with 4gb of DRAM and Evga Geforce 7600 GS PCI-E 256mb DDR2 video card.

  15. #15
    leigh123linux Guest

    Re: rpmfusion buildsystem issue - affects all akmod and kmod for F19 with 3.11 kernel

    Quote Originally Posted by mpajoh
    I still have problems.
    First the following information:
    I got the http://www.linux-ati-drivers.homecal...c19.x86_64.rpm and installed via:
    Code:
    yum localinstall akmod-nvidia-304xx-304.88-3.fc19.x86_64.rpm
    Now I have:
    Code:
    rpm -qa|grep nvidia
    kmod-nvidia-304xx-3.10.11-200.fc19.x86_64-304.88-2.fc19.6.x86_64
    xorg-x11-drv-nvidia-304xx-libs-304.88-12.fc19.x86_64
    nvidia-settings-319.32-1.fc19.x86_64
    akmod-nvidia-304xx-304.88-3.fc19.x86_64
    xorg-x11-drv-nvidia-304xx-304.88-12.fc19.x86_64
    nvidia-xconfig-319.32-1.fc19.x86_64
    kmod-nvidia-304xx-3.10.7-200.fc19.x86_64-304.88-2.fc19.4.x86_64
    and:
    Code:
    rpm -qa|grep kernel
    kernel-tools-3.11.1-200.fc19.x86_64
    abrt-addon-kerneloops-2.1.7-1.fc19.x86_64
    libreport-plugin-kerneloops-2.1.7-1.fc19.x86_64
    kernel-tools-libs-3.11.1-200.fc19.x86_64
    kernel-3.10.7-200.fc19.x86_64
    kernel-devel-3.11.1-200.fc19.x86_64
    kernel-devel-3.10.11-200.fc19.x86_64
    kernel-devel-3.10.7-200.fc19.x86_64
    kernel-3.11.1-200.fc19.x86_64
    kernel-headers-3.11.1-200.fc19.x86_64
    kernel-3.10.11-200.fc19.x86_64
    but when I "startx" in kernel version 3.11.1-200 it fails to start x saying no nvidia driver is found, and from the above it is obvious.

    I am posting this booted into kernel kernel-3.10.11-200.fc19.x86_64.

    Can any one help?

    Masoud
    run

    Code:
    su
    akmods --kernels 3.11.1-200.fc19.x86_64


    ---------- Post added at 04:55 PM ---------- Previous post was at 04:53 PM ----------

    Quote Originally Posted by csmart
    Thanks Leigh. Does this also affect catalyst? Also, do you have the srpms handy?

    Is this due to old buildsys-build-rpmfusion-kerneldevpkgs-current package?

    Cheers,
    -c
    This issue is bigger than I thought

    https://bugzilla.rpmfusion.org/show_bug.cgi?id=2959

Page 1 of 4 1 2 3 ... LastLast

Similar Threads

  1. kmod vs akmod
    By mathan in forum Hardware
    Replies: 13
    Last Post: 27th January 2014, 04:01 PM
  2. What is the difference between an 'akmod' and a 'kmod'?
    By Dead1nside in forum Using Fedora
    Replies: 21
    Last Post: 20th October 2013, 05:11 PM
  3. kmod, akmod, dkms ??
    By KirkD in forum Linux Chat
    Replies: 10
    Last Post: 16th October 2011, 02:59 AM
  4. [SOLVED]
    No OpenGL after installink akmod catalyst from rpmfusion
    By Krusadr in forum Using Fedora
    Replies: 3
    Last Post: 5th November 2010, 04:25 PM
  5. kmod to akmod -question
    By GoinEasy9 in forum Using Fedora
    Replies: 6
    Last Post: 26th June 2009, 11:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •