Improper video playback on Firefox/YouTube
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2013
    Location
    Ames Iowa
    Posts
    34

    Improper video playback on Firefox/YouTube

    Online videos don't play properly for me. Videos play like a badly skipping DVD.

    I'm using Fedora 19 and Firefox 21.

    I've got lightspark, gnash, and gstreamer. I have about every gstreamer plugin I could find, as well as the lightspark mozilla plugin. I read that lightspark will fall back to gnash if it encounters an usupported format and for this to work I shouldn't install the gnash web plugin, otherwise there will be conflicts.

    Here's a list of everything (pertinent that I can think of) that I have:
    Code:
    gstreamer.x86_64                                      0.10.36-3.fc19           @koji-override-0/$releasever
    gstreamer-ffmpeg.x86_64                               0.10.13-9.fc19           @rpmfusion-free-updates     
    gstreamer-plugins-bad.x86_64                          0.10.23-3.fc19           @rpmfusion-free             
    gstreamer-plugins-bad-free.x86_64                     0.10.23-17.fc19          @koji-override-0/$releasever
    gstreamer-plugins-bad-free-extras.x86_64              0.10.23-17.fc19          @fedora                     
    gstreamer-plugins-bad-nonfree.x86_64                  0.10.23-2.fc19           @rpmfusion-nonfree          
    gstreamer-plugins-base.x86_64                         0.10.36-4.fc19           @koji-override-0/$releasever
    gstreamer-plugins-espeak.x86_64                       0.4.0-2.fc19             @koji-override-0/$releasever
    gstreamer-plugins-good.x86_64                         0.10.31-9.fc19           @koji-override-0/$releasever
    gstreamer-plugins-good-extras.x86_64                  0.10.31-9.fc19           @fedora                     
    gstreamer-plugins-ugly.x86_64                         0.10.19-11.fc19          @rpmfusion-free             
    gstreamer-tools.x86_64                                0.10.36-3.fc19           @koji-override-0/$releasever
    gstreamer1.x86_64                                     1.0.10-1.fc19            @updates                    
    gstreamer1-libav.x86_64                               1.0.9-1.fc19             @rpmfusion-free-updates     
    gstreamer1-plugins-bad-free.x86_64                    1.0.10-1.fc19            @updates                    
    gstreamer1-plugins-bad-free-extras.x86_64             1.0.10-1.fc19            @updates                    
    gstreamer1-plugins-bad-freeworld.x86_64               1.0.9-1.fc19             @rpmfusion-free-updates     
    gstreamer1-plugins-base.x86_64                        1.0.10-1.fc19            @updates                    
    gstreamer1-plugins-good.x86_64                        1.0.10-1.fc19            @updates                    
    gstreamer1-plugins-good-extras.x86_64                 1.0.10-1.fc19            @updates                    
    gstreamer1-plugins-ugly.x86_64                        1.0.9-1.fc19             @rpmfusion-free-updates     
    
    gnash.x86_64                                    1:0.8.10-8.fc19                                     @fedora
    
    lightspark.x86_64                                      0.7.2-2.fc19.1                       @rpmfusion-free
    lightspark-mozilla-plugin.x86_64                       0.7.2-2.fc19.1                       @rpmfusion-free
    Am I missing something? I coudn't find a "bad-nonfree" plugnin for gstreamer1. Should there be one?

    Or are there conflicts? There are like 4 different "bad" plugins for gstreamer.

    I used this page to test out my flash functionality:
    http://www.chemgapedia.de/vsengine/h...ash/index.html
    The flash animation on top worked, but the flash video below just gave me a black box with the following message:
    We're sorry, Lightspark encountered a yet unsupported Flash file
    SWF file: http://www.chemgapedia.de/vsengine/n...yer/player.swf
    Cause: Type mismatch in EventDispatcher::removeEventListener
    This is different from what I get in YouTube, so I must be having different problems with different formats.

    Any ideas?

  2. #2
    Join Date
    May 2012
    Location
    Texas
    Posts
    17

    Re: Improper video playback on Firefox/YouTube

    What desktop are you running, gnome or kde? If gnome you'll need to install the gstreamer1-libav gstreamer1-plugins-ugly plugins to get totem to play videos on and of the net. I install gecko-media player in kde. Everything works that way. Btw, why don't you just install the flash player for Youtube?

Similar Threads

  1. Youtube video playback problems
    By snubriot in forum Using Fedora
    Replies: 0
    Last Post: 21st May 2013, 11:01 PM
  2. Replies: 3
    Last Post: 31st May 2011, 03:16 AM
  3. Replies: 13
    Last Post: 20th March 2011, 09:16 PM
  4. can't see youtube video with Firefox + xine
    By ispanico in forum Using Fedora
    Replies: 1
    Last Post: 20th December 2008, 12:06 PM
  5. no text console, improper video mode?
    By Beomoss in forum Using Fedora
    Replies: 3
    Last Post: 27th May 2006, 09:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •