[SOLVED] Slow boot after upgrade to F19
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2007
    Location
    Freedonia
    Age
    72
    Posts
    3,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Slow boot after upgrade to F19

    Yesterday evening, I upgraded my laptop from F17 to F19. There were a few, minor hiccups, but on the whole it went well. However, booting is odd: the first part, with the Fedora logo goes very nicely. Then, the screen goes blank and there's a long wait before lightdm comes up. (I use Xfce, not Gnome.) Once I log in, there's another delay before the desktop comes up properly. Systemd-analyze shows that my machine boots in just under 27 seconds, but I have a panel widget that (among other things) shows uptime, and from the time it starts until I have a working desktop is about two minutes, and this wasn't true before the upgrade. Everything in /var/log/boot.log seems OK, but I find this in /var/log/messages:

    Jul 14 13:02:23 barrayar dbus-daemon[320]: dbus[320]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Unit dbus-org.freedesktop.nm-dispatcher.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.nm-dispatcher.service' for details.

    This is repeated several times. Checking, there is no dbus-org.freedesktop.nm-dispatcher.service, which explains why it "fails." Does anybody here know how to track down what's causing this and correct it? As far as I can tell, once everything's up and running it works well, but I'd like to clear this up. It's kind of hard to use your laptop as a Linux showpiece it it's that laggy at boot!
    Registered Linux user #470359 and permanently recovered BOFH.

    Any advice in this post is worth exactly what you paid for it.

  2. #2
    raveit65 Guest

    Re: Slow boot after upgrade to F19

    I'm pretty shure you run in this issue with selinux, as you described the issue.
    https://bugzilla.redhat.com/show_bug.cgi?id=972881 comment 49
    Try as root:
    restorecon -R -v /usr/sbin

    If this works, report your experience to the report, to wake up selinux maintainer.

  3. #3
    Join Date
    Aug 2009
    Posts
    9,444
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)

    Re: Slow boot after upgrade to F19

    That was a bug in NetworkManager that hit upgrades.

    Try running:

    Code:
    su -
    (root password)
    
    systemctl enable NetworkManager-dispatcher.service
    Reboot or start the service manually after enabling it.

  4. #4
    Join Date
    Oct 2007
    Location
    Freedonia
    Age
    72
    Posts
    3,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Slow boot after upgrade to F19

    I tried your suggestion first Dan, because it seemed simpler. After enabling the service, I rebooted. No change, except that for some odd reason, my Xfce desktop had no icons. Also, it occurred to me to watch the disk activity: during the blank time before lightdm came up and after I logged in but before things started to work, the disk light was off at all times. Then I tried the restorecon suggestion and rebooted again. No blank period, no hanging, proper disk activity, and when I had my desktop up, my uptime was just under one minute. (Yes, I have icons; I'm sure that wasn't related, especially as I didn't undo Dan's suggestion.)

    Thanx to both of you, and I'm now off to Bugzilla to add my tuppence to the discussion.
    Registered Linux user #470359 and permanently recovered BOFH.

    Any advice in this post is worth exactly what you paid for it.

  5. #5
    Join Date
    Aug 2009
    Posts
    9,444
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)

    Re: Slow boot after upgrade to F19

    I usually set SELinux to permissive when I do an upgrade. I set to permissive, upgrade, do a complete relabel, then set back to enforcing.

    I guess that's why I didn't see the problem you had during my upgrade to F19.

  6. #6
    Join Date
    Jun 2013
    Location
    Argentina
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Slow boot after upgrade to F19

    WOW I had been having very long wait times on F19 before and after session login for weeks and these fixes cut down both! Now the system boots to desktop in only seconds rather than minutes, thank you!

Similar Threads

  1. [SOLVED]
    Upgrade to F19 - powertop starts spewing errors
    By pjhacnau in forum Hardware
    Replies: 1
    Last Post: 10th July 2013, 11:10 PM
  2. Upgrade F18 > F19 error
    By STANKAR in forum Installation, Upgrades and Live Media
    Replies: 13
    Last Post: 5th July 2013, 10:29 PM
  3. Fedup to upgrade F18 to F19 with Live iso
    By grishi111 in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 4th July 2013, 06:39 PM
  4. [SOLVED]
    F19 rawhide slow with kernel-3.9.0-0.rc0.git5.1.fc19
    By chepioq in forum Rawhide
    Replies: 4
    Last Post: 10th April 2013, 10:11 PM
  5. Slow boot after fc7 upgrade
    By tmoore25 in forum Using Fedora
    Replies: 2
    Last Post: 26th September 2007, 07:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •