Here are some steps for FC3 users that would like to get their APC UPS devices to interact correctly with FC3. I have been using the apcupsd agent in FC2, but after updating to FC3, it no longer worked. I upgaded to the latest binaries , but it still did not work.

Here are some steps that will help:

1. Download and install the device. (RPMs for FC3 are provided in the link above)

2. Using the documentation at , correctly configure the etc/apcupsd/apcupsd.conf file. In my case, I am using a usb cable.

3. Due to the changes to where devices are located in FC3, apcupsd cannot detect the UPS because it looks for the usb path in /dev/usb. In my case, these were no longer there. As such, I had to do the following:

(a) run the script /etc/apcupsd/make-hiddev as Root.
This creates files for the usb devices in the /dev/usb/ directory.

(b) run the following as root: cp -rp /dev/usb /etc/udev/devices
This creates the missing usb files in the udev directory.

4. Reboot the system. You should be able to see the agent diagnostics in the System Settings - Server Settings - Serivices panel., or in the /var/log/ log file.

Hope this helps.