I can only run Fedora in nomodeset
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Join Date
    Feb 2013
    Location
    Europe
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I can only run Fedora in nomodeset

    Hello

    First ive installed Fedora. After choosing fedora in GRUB and hitting enter, just a blank screen appeared and nothing happened.
    so i run fedora now always with the temporary nomodeset in GRUB.
    like that: http://img26.imageshack.us/img26/350...raclevmvir.png

    then i did
    yum update
    , thoguht that might help
    with yum update and NOT running in nomodeset, fedora boots and starts but the screen is fluctuating very strognly (strobo like).

    i did not install any drivers (nor graphic drivers), because some said there will be issues.
    I can only run fedora in nomodeset so far.

    help ?

    with regards
    Last edited by carborane; 13th February 2013 at 03:24 PM.

  2. #2
    Join Date
    Jan 2010
    Posts
    7,486
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    What sort of graphics card do you have? You can find out by typing

    lspci |grep VGA

    in a terminal

  3. #3
    Join Date
    Feb 2013
    Location
    Europe
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    lspci |grep VGA gives me

    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Barts XT [Radeon HD 6800 Series]

  4. #4
    Join Date
    Oct 2011
    Location
    UK
    Posts
    469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    Instead of using nomodeset try editing grub when it comes up and change set gfxppayload=keep to set gfxppayload=text and hit F10 to boot and see if it comes up. I have had to change this permanently for both F17 and F18 to boot with my ATI Gfx card.

    Stuart

  5. #5
    Join Date
    Feb 2013
    Location
    Europe
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    Quote Originally Posted by broadstairs
    Instead of using nomodeset try editing grub when it comes up and change set gfxppayload=keep to set gfxppayload=text and hit F10 to boot and see if it comes up. I have had to change this permanently for both F17 and F18 to boot with my ATI Gfx card.

    Stuart
    hu.
    yes that works when setting:
    gfxppayload=text
    But there is a "but".
    Before with "nomodeset" (that low graphic mode) teh Computer runned on +/- 64Watt. Now it runs on 124Watt with fxppayload=text.


    In Windows it runs always around 73 Watt. Now the question is, is there a possibility to get similar PowerUsage Values in Fedora, as in Windows?

    with regards

  6. #6
    Join Date
    Feb 2013
    Location
    Europe
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    so i tried to install ati proprietary drivers, but yeah cant do that either:
    installation stops and says i should check /usr/share/ati/fglrx-install.log


    so fglrx-install.log tells me:
    Supported adapter detected.
    Check if system has the tools required for installation.
    fglrx installation requires that the system have kernel headers. /lib/modules/3.7.6-201.fc18.x86_64/build/include/linux/version.h cannot be found on this system.
    fglrx installation requires that the system has gcc tool. gcc cannot be found on this system.
    One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
    Optionally, run the installer with --force option to install without the tools.
    Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
    and in googly i cant find nowhere how to install the missing stuff...

    with regards

  7. #7
    Join Date
    Jan 2010
    Posts
    7,486
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    yum install make automake gcc gcc-c++ linux-devel

    should help some of that. Fedora moved version.h around for whatever reason, which is causing trouble for some third party programs, so for that, you can do
    cp /usr/include/linux/version.h /lib/modules/<kernelversion>/build/include/linux/

    Also, once yo install kernel-devel be sure that it's the same version as your running kernel. Often, people install kernel-devel, which will be the latest version but it won't match the kernel version. For example if you have kernel 3.71 and you've run yum update, and 3.7.2 has been downloaded, it won't run until you reboot. Then, when you install kernel-devel, it's for 3.7.2 but your current kernel is 3.7.1 So, run the command

    uname -r

    and make sure it matches whatever version of kernel-devel you have.

  8. #8
    Join Date
    Feb 2013
    Location
    Europe
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    with yum update my new kernel is 3.7.6-201.fc18.x86_64. i choose that at boot.

    so i should copy that file in to that kernel directory "3.7.6-201.fc18.x86_64"
    i installed devel, while i was on "3.7.6-201.fc18.x86_64"

    since a file "build" was in the "3.7.6-201.fc18.x86_64" directory, i just renamed it. and made the /build/include/linux direcrtory


    then i tried to install driver againg, and the message ist the following now:



    ---------- Post added at 10:45 PM ---------- Previous post was at 10:26 PM ----------

    Supported adapter detected.
    Check if system has the tools required for installation.
    Uninstalling any previously installed drivers.
    Unloading radeon module...
    Unloading drm module...
    rmmod: ERROR: Module drm is in use by: ttm drm_kms_helper
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    AMD kernel module generator version 2.1
    Error:
    kernel includes at /lib/modules/3.7.6-201.fc18.x86_64/build/include do not match current kernel.
    they are versioned as ""
    instead of "3.7.6-201.fc18.x86_64".
    you might need to adjust your symlinks:
    - /usr/include
    - /usr/src/linux
    [Error] Kernel Module : Failed to compile kernel module - please consult readme.
    [Reboot] Kernel Module : dracut
    Last edited by carborane; 14th February 2013 at 10:59 PM.

  9. #9
    Join Date
    Jan 2010
    Posts
    7,486
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    with yum update my new kernel is 3.7.6-201.fc18.x86_64. i choose that at boot.
    Ok, so you need kernel-devel to match that--in other words, rpm -q kernel-devel should show that exact number.

    Then, copy the version.h to /lib/modules/376-201.fc18.x86_64/build/include/linux/

  10. #10
    Join Date
    Feb 2013
    Location
    Europe
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I can only run Fedora in nomodeset

    rpm -q kernel-devel first didnt work
    then i did "yum install kernel-devel"
    then i made again: "rpm -q kernel-devel"
    and got the response:
    "kernel-devel-3.7.6-201.fc18.x86_64"


    then i tried installiation, it worked over a long time (i think some stuff might be installed) but anyway Error message appears:

    fglrx-install.log tells:

    Supported adapter detected.
    Detected a previous installation, /usr/share/ati/amd-uninstall.sh
    Dryrun uninstall succeeded continuing with installation.
    Check if system has the tools required for installation.
    Uninstalling any previously installed drivers.
    Forcing uninstall of AMD Catalyst(TM) Proprietary Driver.
    No integrity verification is done.
    restore of system environment completed
    Uninstall fglrx driver complete.
    For detailed log of uninstall, please see /etc/ati/fglrx-uninstall.log
    System must be rebooted to avoid system instability and potential data loss.
    /usr/share/ati/amd-uninstall.sh completed with 0
    Unloading radeon module...
    Unloading drm module...
    rmmod: ERROR: Module drm is in use by: ttm drm_kms_helper
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    AMD kernel module generator version 2.1
    Error:
    kernel includes at /lib/modules/3.7.6-201.fc18.x86_64/build/include do not match current kernel.
    they are versioned as ""
    instead of "3.7.6-201.fc18.x86_64".
    you might need to adjust your symlinks:
    - /usr/include
    - /usr/src/linux
    [Error] Kernel Module : Failed to compile kernel module - please consult readme.
    [Reboot] Kernel Module : dracut
    and i still can only start Fedora with nomodeset.
    but what i have noticed is: since the "not complete installation" of the drivers, the computer runs in nomodeset, and with high resolution on +/- 66W.
    thats one positive point, so far
    Last edited by carborane; 15th February 2013 at 09:55 AM.

Similar Threads

  1. Fedora 15 Black Screen on Startup without nomodeset
    By srinivasasha in forum Hardware & Laptops
    Replies: 6
    Last Post: 26th December 2011, 04:50 PM
  2. nomodeset and vesa drivers
    By muhammad ammar in forum Using Fedora
    Replies: 11
    Last Post: 6th July 2011, 02:32 PM
  3. F14 Macbook Pro (5,5) Nomodeset doesn't work
    By Kivamaki in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 2nd February 2011, 06:05 AM
  4. Replies: 0
    Last Post: 13th June 2010, 12:31 AM
  5. nomodeset improve performance
    By axet in forum Hardware & Laptops
    Replies: 1
    Last Post: 18th August 2009, 10:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •