[SOLVED] qemu kvm fedora guest problems
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    May 2007
    Posts
    99
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    qemu kvm fedora guest problems

    Hi,

    host: Fedora 17 x64 minimal

    I've installed qemu, kvm, libvirt, virt-manager, python-virtinst

    using virt-install
    Trying to install fedora17 x64 or fedora 18 x64 from local mounted Fedora-DVD-ISO but getting strange errors just before anaconda starts up:

    Code:
    vda: unknown partition table
    and then it stalls with:
    Code:
    unable to process initqueue
    /dev/root does not exist
    strangely this does work if I run location pointed to an internet mirror


    I've been trying to get this setup working for several days now without success. Used Xen before without any problems using same virt-install.

    I did only install qemu and NOT qemu-kvm, thinking that qemu alone would suffice. all systems are x64 fedora.

    Would someone please point me in right direction here.

    I dont really know what you guys need as information, but just ask and I'll provide.

    Regards,
    Dan

  2. #2
    Join Date
    Apr 2005
    Location
    earth
    Posts
    1,361
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: qemu kvm fedora guest problems

    dunno,
    starting from the command line? What's the line look like? Might help someone else spot a problem.
    x--x--x
    http://www.gnu.org/philosophy/free-sw.html
    Freedom is never Free.
    Pat Jr.

  3. #3
    Join Date
    May 2007
    Posts
    99
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: qemu kvm fedora guest problems

    Hi and thanks for trying,

    just installed another system q6600 with 4 gb memory. clean minimal install, created a bridge and bridged to the eth0, everything works fine.

    disabled selinux

    Code:
    yum install @virtualization
    reboot

    mounted iso of F17-dvd

    virt-install -n f17 -r 1024 --vcpus=1 --disk path=/f17.img,size=10 --location=/f17-dvd --noautoconsole --os-type linux --os-variant fedora17 --accelerate --network=bridge:vbr0 --vnc

    connecting from another client via virt-manager.
    yet again same error comes up.

    I must be doing something! wrong. is it at all possible to install from mouted dvd?!

    Will try to download f16-netinstall iso and try with that too. Already tried F17-netinstall, F18-live/DVD

    anyone else?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot from 2013-01-25 22:33:34.png 
Views:	127 
Size:	13.8 KB 
ID:	24420  

  4. #4
    Join Date
    Feb 2008
    Location
    Sydney Australia
    Age
    65
    Posts
    2,662
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: qemu kvm fedora guest problems

    You shouldn't need to mount the iso. I'm not at the computer with it installed now but there is an option for local file and there you just select the iso.

  5. #5
    Join Date
    May 2007
    Posts
    99
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: qemu kvm fedora guest problems

    Hi,

    some kind of progress here, F16-netinstall iso mounted on a dir does works fine !

    here's screenshot from F18-netinstall


    They must've changed somehing from Fedora 16, maybe when I last tried this it was on Fedora 16

    But anyway, there must be some kind of explanation!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot from 2013-01-25 23:17:30.png 
Views:	153 
Size:	21.7 KB 
ID:	24422  

  6. #6
    Join Date
    May 2007
    Posts
    99
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: qemu kvm fedora guest problems

    Quote Originally Posted by ozjd
    You shouldn't need to mount the iso. I'm not at the computer with it installed now but there is an option for local file and there you just select the iso.
    Hi,

    thanks, Yes I'm aware of that. But is there an option to run extra argument when specifying iso?

    isn't iso specified with " -c " and extra-args needs "location"-option??

    -dan

    ---------- Post added at 11:37 PM ---------- Previous post was at 11:23 PM ----------

    It works!

    Specifying ISO-image with "--location=" option does work! I was certain that I had read somewhere it only could be specified by -cdrom option... My apologies for all the fuss

Similar Threads

  1. Cannot resolve DNS behind a qemu/KVM guest on fedora 15
    By wlpl in forum Servers & Networking
    Replies: 0
    Last Post: 1st August 2011, 06:15 PM
  2. qemu-kvm F15 host and guest - guest screen problem
    By gmangum in forum Using Fedora
    Replies: 0
    Last Post: 25th June 2011, 05:39 PM
  3. F14 Qemu+KVM Host= Guest with sound?
    By kyryder in forum F14 Development
    Replies: 5
    Last Post: 18th October 2010, 11:06 PM
  4. Virtualization - am I creating a kvm guest or qemu
    By bshack in forum Using Fedora
    Replies: 7
    Last Post: 23rd September 2009, 01:56 AM
  5. QEMU 0.8.2: FC6 Host: Fedora 7 Guest - Driver Problem
    By greno in forum EOL (End Of Life) Versions
    Replies: 1
    Last Post: 4th June 2007, 05:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •