FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    May 2012
    Location
    ctz
    Age
    23
    Posts
    43

    LightDM language issue

    Well, I've installed lightdm earlier today, and I found out I am able to configure it (via lightd-gtk-greeter.config) but I'm only able to change the "appereance" of the UI... nothing more than the fonts and some display settings, the thing is that I need it to be in Spanish.

    When looking into the "/etc/X11/prefdm" script, I found that it actually "loads" the locale configuration (from /etc/locale.conf or /etc/sysconfig/i18n) for the display manager but it seems that lightdm ignores it.

    What can I do to change it to Spanish? My locales are confgured correctly as "es_MX.utf-8"

  2. #2
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,150

    Re: LightDM language issue

    Try this

    PHP Code:

    su 
    -
    [
    root password]

    vim /etc/lightdm/lightdm-gtk-greeter.conf

    [add/uncomment this line]
    show-language-selectortrue 
    I think this should enable the language selection option.

  3. #3
    Join Date
    May 2012
    Location
    ctz
    Age
    23
    Posts
    43

    Re: LightDM language issue

    Yes, that's what I find on all forums, but I don't want to change my session's language, I want to change the language of lightdm itself...

  4. #4
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,150

    Re: LightDM language issue

    Well, I guess I misunderstood your question! Sorry!!

  5. #5
    Join Date
    May 2012
    Location
    ctz
    Age
    23
    Posts
    43

    Re: LightDM language issue

    No problem, by the way, any ideas?

  6. #6
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,150

    Re: LightDM language issue

    Not yet. I haven't been able to do much searching today ... if I find something, I will definitely post it...

  7. #7
    Join Date
    May 2012
    Location
    ctz
    Age
    23
    Posts
    43

    Re: LightDM language issue

    Thanks! I'd appreciate that!

Similar Threads

  1. enable lightdm at system boot? F17 minimal install
    By Neruson in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 16th July 2012, 12:25 AM
  2. Ubuntu to Drop GDM for LightDM
    By tox in forum Linux Chat
    Replies: 6
    Last Post: 11th December 2010, 08:19 AM
  3. Language issue
    By konmitsu in forum Using Fedora
    Replies: 1
    Last Post: 10th February 2008, 03:42 PM
  4. Language Support Issue
    By AutoC in forum Using Fedora
    Replies: 2
    Last Post: 31st January 2008, 06:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •