I've been writing CGI scripts that use /tmp for years and now I've upgraded to F17 and they can't read the /tmp directory (/var/tmp, either). Why? Apache is running as a specific user that has no trouble reading these directories from the command line. What must I change to get this functionality back?

---------- Post added 11th August 2012 at 10:04 AM ---------- Previous post was 10th August 2012 at 11:31 PM ----------

Found it! Turns out that F16 intruduced the concept of a private /tmp and /var/tmp directory (which were the two directories I looked at) for services that keeps their temp files from being visible to other processes. Makes sense for security, but makes it difficult for services to share files with users and breaks my scripts. It can be disabled, though, which is fine for my home media/web/file server.

Explained under 2.3.3. Services Private
http://docs.fedoraproject.org/en-US/..._Sysadmin.html

and http://fedoraproject.org/wiki/Featur...icesPrivateTmp