FedoraForum.org - Fedora Support Forums and Community
Page 3 of 3 FirstFirst 1 2 3
Results 31 to 35 of 35
  1. #31
    Join Date
    Jun 2012
    Location
    USA
    Posts
    14

    Re: Bootloader Failing to Install

    so here is how I got it to generate the grub.cfg file -- on the file located at /usr/share/grub/grub-mkconfig_lib on line 26 change grub-probe to grub_probe, then ran grub2-mkconfig -o /boot/grub2/grub.cfg and it worked.

    it did give me a few errors when I run the script but it generated it completely, i saw on a bug report for a mac that said that it was looking for the grub-probe script but because it's for the legacy grub it stops while running the script. I still get the following errors:
    [root@hiddencloud grub]# grub2-mkconfig -o /boot/grub2/grub.cfg
    Generating grub.cfg ...
    /usr/share/grub/grub-mkconfig_lib: line 282: /usr/sbin/grub2_probe: No such file or directory
    Found linux image: /boot/vmlinuz-3.5.0-2.fc17.x86_64
    Found initrd image: /boot/initramfs-3.5.0-2.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    Found linux image: /boot/vmlinuz-3.4.6-2.fc17.x86_64
    Found initrd image: /boot/initramfs-3.4.6-2.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    Found linux image: /boot/vmlinuz-3.4.4-5.fc17.x86_64
    Found initrd image: /boot/initramfs-3.4.4-5.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/grub2_probe: No such file or directory
    /usr/share/grub/grub-mkconfig_lib: line 282: /usr/sbin/grub2_probe: No such file or directory
    done

    is this something I should be concerned about? the system boots fine and it creates the config file with no issues.

    thanks

  2. #32
    Join Date
    Aug 2009
    Posts
    8,464

    Re: Bootloader Failing to Install

    may I ask why you changed that line to grub2_probe? There isn't a grub2_probe.

    If anything, it should have been changed to grub2-probe, not grub2_probe.

  3. #33
    Join Date
    Jun 2012
    Location
    USA
    Posts
    14

    Re: Bootloader Failing to Install

    while looking on the web I found this: https://bugzilla.redhat.com/show_bug.cgi?id=737203

    it says that's calling the old grub-probe script from /etc/grub.d/30_os-prober -- I looked at that script and didn't see any entries so I loaded a live cd to see if I could get grub reinstalled but when I tried the script spit out an error saying that there was grub error on a line of /usr/share/grub/grub-mkconfig_lib

    when I looked in there i saw that all the entries had grub_probe and there was only one for grub-probe (no entries for grub2_probe or grub2-probe) I noticed that if I changed it to grub2_probe or grub2-probe I still get the same outcome as if I changed it to grub_probe.

    I don't know about scripting but someone on the bugzilla report said: I believe the fix grub2-probe should be ${grub_probe} instead rather than hard coding it as grub2-probe, as there is code early in grub2-mkconfig that allows for the proper substitution.

    so that's why I only changed it to grub-probe because either way it works but I still get the errors when running the script, I know what I'm doing here is not quite a clean fix but I don't want to give up as I want to run fedora on this system so at first i got around it by copying grub.cfg from another machine and now it's generating the config file but because of my limited knowledge i don't know if the error messages will affect something else.

    now I know this is a different script than the one on the bug report but it seems to help because it generates it's own complete config file, I just tried it and changed it to ${grub_probe} and it works but I get a different error:

    [root@hiddencloud grub]# grub2-mkconfig -o /boot/grub2/grub.cfg
    Generating grub.cfg ...
    /usr/share/grub/grub-mkconfig_lib: line 282: /usr/sbin/: Is a directory
    Found linux image: /boot/vmlinuz-3.5.0-2.fc17.x86_64
    Found initrd image: /boot/initramfs-3.5.0-2.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    Found linux image: /boot/vmlinuz-3.4.6-2.fc17.x86_64
    Found initrd image: /boot/initramfs-3.4.6-2.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    Found linux image: /boot/vmlinuz-3.4.4-5.fc17.x86_64
    Found initrd image: /boot/initramfs-3.4.4-5.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 282: /usr/sbin/: Is a directory
    done
    [root@hiddencloud grub]# ls

  4. #34
    Join Date
    Aug 2009
    Posts
    8,464

    Re: Bootloader Failing to Install

    Quote Originally Posted by d3spinoz4
    while looking on the web I found this: https://bugzilla.redhat.com/show_bug.cgi?id=737203

    it says that's calling the old grub-probe script from /etc/grub.d/30_os-prober -- I looked at that script and didn't see any entries so I loaded a live cd to see if I could get grub reinstalled but when I tried the script spit out an error saying that there was grub error on a line of /usr/share/grub/grub-mkconfig_lib

    when I looked in there i saw that all the entries had grub_probe and there was only one for grub-probe (no entries for grub2_probe or grub2-probe) I noticed that if I changed it to grub2_probe or grub2-probe I still get the same outcome as if I changed it to grub_probe.

    I don't know about scripting but someone on the bugzilla report said: I believe the fix grub2-probe should be ${grub_probe} instead rather than hard coding it as grub2-probe, as there is code early in grub2-mkconfig that allows for the proper substitution.

    so that's why I only changed it to grub-probe because either way it works but I still get the errors when running the script, I know what I'm doing here is not quite a clean fix but I don't want to give up as I want to run fedora on this system so at first i got around it by copying grub.cfg from another machine and now it's generating the config file but because of my limited knowledge i don't know if the error messages will affect something else.

    now I know this is a different script than the one on the bug report but it seems to help because it generates it's own complete config file, I just tried it and changed it to ${grub_probe} and it works but I get a different error:

    [root@hiddencloud grub]# grub2-mkconfig -o /boot/grub2/grub.cfg
    Generating grub.cfg ...
    /usr/share/grub/grub-mkconfig_lib: line 282: /usr/sbin/: Is a directory
    Found linux image: /boot/vmlinuz-3.5.0-2.fc17.x86_64
    Found initrd image: /boot/initramfs-3.5.0-2.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    Found linux image: /boot/vmlinuz-3.4.6-2.fc17.x86_64
    Found initrd image: /boot/initramfs-3.4.6-2.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    Found linux image: /boot/vmlinuz-3.4.4-5.fc17.x86_64
    Found initrd image: /boot/initramfs-3.4.4-5.fc17.x86_64.img
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 122: /usr/sbin/: Is a directory
    /usr/share/grub/grub-mkconfig_lib: line 282: /usr/sbin/: Is a directory
    done
    [root@hiddencloud grub]# ls
    If you would have looked, that was an OLD bug that was fixed over 7 months ago. It is no longer an issue. It was a F16 bug and was fixed in F16 and F17.

    The scripts in F17 work fine.

  5. #35
    Join Date
    Jun 2012
    Location
    USA
    Posts
    14

    Re: Bootloader Failing to Install

    dude please don't get me wrong, I know my postings haven't been clean and i've had a lot of typos but I've looked everywhere and tried a million searches with different wording and could not find anything, to tell you that in order to post that bug link here I had to search it for another 30 mins because I ran into it for the firs time last thursday so I don't know maybe the info wasn't released out of the bug report or something is missing on their end because if YUM can fix dependencies and errors while updating how come it didn't fix it when I updated it and upgraded the kernel from 3.4.4 to 3.4.5 and then to 3.4.6? I even removed grub2 using yum remove grub2 and then yum reinstall grub2 so does that mean that the repository didn't have the fixed files?

    I also installed fedora 16 like a million times on many different machines and VM's and didn't run into this issue before until i installed 17 for the first time.

    now that all i've done is cause trouble maybe I should stay out of this forum because I'm just gonna look like a jerk.

Page 3 of 3 FirstFirst 1 2 3

Similar Threads

  1. bootloader won't install
    By farmkid in forum Installation, Upgrades and Live Media
    Replies: 7
    Last Post: 10th March 2012, 09:46 PM
  2. Where do I install the bootloader?
    By SplitInfinity in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 12th October 2010, 08:54 PM
  3. Install / Bootloader help
    By mordex in forum Installation, Upgrades and Live Media
    Replies: 9
    Last Post: 2nd November 2006, 05:10 PM
  4. Apt install failing
    By Thoreau in forum Using Fedora
    Replies: 2
    Last Post: 18th August 2004, 03:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •