[SOLVED] Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2012
    Location
    Lancaster, MA
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [SOLVED] Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    Hi all-

    I have a soekris net6501 with 4 x e1000e interfaces and a card with two r8169 interfaces.

    Fedora 17 installed fine, but the network device renaming sometimes just fails on bootup -- I usually get this which makes sense with the new consistent network naming stuff:

    p1p1 - e1000e 1st port
    p1p2 - e1000e 2nd port
    p2p1 - e1000e 3rd port
    p2p2 - e1000e 4th port
    p3p1 - r8169 1st port
    p3p2 - r8169 2nd port

    The above would be great if I got that every time I reboot, however one or two times just rebooting I didn't get the same as above -- but rather this:

    p1p1 - e1000e 1st port
    eth1 - r8169 2nd port
    eth3 - e1000e 2nd port
    eth4 - e1000e 3rd port
    eth5 - e1000e 4th port
    p3p1 - r8169 1st port

    During bootup udevd only announced it renamed eth2 to p1p1 and eth0 to p3p1 Any idea why it would just skip other valid interfaces? eth1,3,4,5 are all there not renamed!

    Fedora 17 docs still say the user should be able to use 70persistent-net.rules in /etc/udev/rules.d to control network device name to MAC as desired, however this directory is EMPTY on my installation.
    Plus -- if udevd only renames some interfaces and not others I will never be able to count on this thing booting with the right interfaces every time. Should I have a 70persistent-net.rules on F17? If not, docs need to be updated! Is there some new thing that replaces 70persistent-net.rules for F17?

    I wanted to include dmesg info from a failed boot and successful with ifconfig after, but I can only post 10000 chars, so I've got the very condensed output from failed and then successful here:

    Here's the failed boot:

    Loading Linux 3.4.4-3.fc17.i686.PAE ...Loading Linux 3.4.4-3.fc17.i686.PAE ...


    [ OK ] Started D-Bus System Message Bus.
    [ 15.418340] udevd[338]: renamed network interface eth2 to p1p1
    [ 16.012944] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [ 16.037407] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
    [ 16.756937] ADDRCONF(NETDEV_UP): p1p1: link is not ready
    [ 16.927211] ADDRCONF(NETDEV_UP): eth3: link is not ready
    [ 17.306701] ADDRCONF(NETDEV_UP): eth4: link is not ready
    [ 17.457044] ADDRCONF(NETDEV_UP): eth5: link is not ready
    [ 17.466573] udevd[339]: renamed network interface eth0 to p3p1
    [ 17.529445] r8169 0000:10:00.0: eth1: link down
    [ 17.544058] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 17.692018] r8169 0000:0f:00.0: p3p1: link down
    [ 17.694760] ADDRCONF(NETDEV_UP): p3p1: link is not ready
    [ 18.438435] e1000e: p1p1 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
    [ 18.439227] e1000e 0000:05:00.0: p1p1: 10/100 speed: disabling TSO
    [ 18.442027] ADDRCONF(NETDEV_CHANGE): p1p1: link becomes ready

    Fedora release 17 (Beefy Miracle)
    Kernel 3.4.4-3.fc17.i686.PAE on an i686 (ttyS0)

    mmi-fw1 login: root
    Password:
    Last login: Sat Jul 7 13:26:55 on ttyS0
    [root@mmi-fw1 ~]# ifconfig
    eth1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:e0:4c:68:d6:e7 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    eth3: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0d txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16 memory 0xa2000000-a2020000

    eth4: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0e txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16 memory 0xa3000000-a3020000

    eth5: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0f txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 17 memory 0xa4000000-a4020000

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 0 (Local Loopback)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    p1p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 10.1.1.197 netmask 255.255.255.0 broadcast 10.1.1.255
    inet6 fe80::200:24ff:fece:e10c prefixlen 64 scopeid 0x20<link>
    ether 00:00:24:ce:e1:0c txqueuelen 1000 (Ethernet)
    RX packets 42 bytes 5133 (5.0 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 15 bytes 1440 (1.4 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 19 memory 0xa1000000-a1020000

    p3p1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:e0:4c:68:d7:12 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0



    Here is a boot that works:


    [ 15.642348] udevd[343]: renamed network interface eth0 to p3p1
    [ 16.049302] udevd[344]: renamed network interface eth1 to p3p2
    [ 16.505212] udevd[347]: renamed network interface eth2 to p1p1
    [ 16.680209] udevd[334]: renamed network interface eth3 to p1p2
    [ 17.293431] udevd[335]: renamed network interface eth5 to p2p2
    [ 17.424065] udevd[337]: renamed network interface eth4 to p2p1
    [ OK ] Started udev Wait for Complete Device Initialization.
    Starting Wait for storage scan...
    [ OK ] Started Wait for storage scan.

    [ 18.793329] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [ 18.874636] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
    [ 19.480082] ADDRCONF(NETDEV_UP): p1p1: link is not ready
    [ 19.846630] ADDRCONF(NETDEV_UP): p1p2: link is not ready
    [ 19.988556] ADDRCONF(NETDEV_UP): p2p1: link is not ready
    [ 20.099978] ADDRCONF(NETDEV_UP): p2p2: link is not ready
    [ 20.139633] r8169 0000:0f:00.0: p3p1: link down
    [ 20.145991] ADDRCONF(NETDEV_UP): p3p1: link is not ready
    [ 20.184707] r8169 0000:10:00.0: p3p2: link down
    [ 20.192513] ADDRCONF(NETDEV_UP): p3p2: link is not ready
    [ 21.102957] e1000e: p1p1 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
    [ 21.103811] e1000e 0000:05:00.0: p1p1: 10/100 speed: disabling TSO
    [ 21.107324] ADDRCONF(NETDEV_CHANGE): p1p1: link becomes ready

    Fedora release 17 (Beefy Miracle)
    Kernel 3.4.4-3.fc17.i686.PAE on an i686 (ttyS0)

    mmi-fw1 login: root
    Password:
    Last login: Sat Jul 7 13:29:48 on ttyS0
    [root@mmi-fw1 ~]# ifconfig
    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 0 (Local Loopback)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    p1p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 10.1.1.197 netmask 255.255.255.0 broadcast 10.1.1.255
    inet6 fe80::200:24ff:fece:e10c prefixlen 64 scopeid 0x20<link>
    ether 00:00:24:ce:e1:0c txqueuelen 1000 (Ethernet)
    RX packets 22 bytes 2801 (2.7 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 13 bytes 1272 (1.2 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 19 memory 0xa1000000-a1020000

    p1p2: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0d txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16 memory 0xa2000000-a2020000

    p2p1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0e txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16 memory 0xa3000000-a3020000

    p2p2: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0f txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 17 memory 0xa4000000-a4020000

    p3p1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:e0:4c:68:d7:12 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    p3p2: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:e0:4c:68:d6:e7 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    [root@mmi-fw1 ~]#
    Last edited by malk315; 8th July 2012 at 03:09 AM. Reason: Solved

  2. #2
    Join Date
    Jul 2012
    Location
    Lancaster, MA
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    By the way:

    I found this very useful post:

    http://forums.fedoraforum.org/showthread.php?t=277223

    But the above only works through Fedora 16 since it creates 70persistent-net.rules
    I'd like to know how to do the equivalent on F17.

    I tried turning off biosdevname=0 in grub config so I would always just have ethX names, but then I end up with built in interfaces being eth2-5 and PCI-X card being eth0-1 whereas I'd like the builtins to be eth0-3. So I started searching for a way to force r8169 module load to happen after e1000e, but didn't find anything that was simple to force the ordering of module loading -- seems quite parallel.

    If I can't make progress on this, I may just stick with biosdevname=0 and live with the fact that by builtin devices are eth2-5

    Any ideas appreciated.

    ---------- Post added at 01:41 PM ---------- Previous post was at 01:21 PM ----------

    I just took a look at /lib/udev/rules.d/71-biosdevname.rules which is the thing that implements the biosdevname=0|1 kernel cmdline param and found this key comment:

    # using NAME= instead of setting INTERFACE_NAME, so that persistent
    # names aren't generated for these devices, they are "named" on each boot.

    According to the above, persistent names won't be generated -- hence the reason for no 70persistent-net.rules

    Since this doesn't reliably re-name the devices the same everytime -- I just got yet another permutation I'll paste in -- I'm going to try turning of biosdevname and do several reboots and see if I at least get consistent names when they are all just ethX. If that doesn't work I'm going to try and blacklist r8169 and add something to load after I know e1000e is loaded and keep biosdevname=0 and hopefully finally have consistent all ethX interfaces... This shouldn't be this annoying..

    Here's where the biosdevname stuff just decided to only "name" or "rename" one out of the 6 interfaces.
    Just to note -- ** most ** of the time it correctly names all 6 interfaces to pXpY but not all the time... no good for a firewall box I'm building up!

    [root@mmi-fw1 rules.d]# ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 10.1.1.197 netmask 255.255.255.0 broadcast 10.1.1.255
    inet6 fe80::200:24ff:fece:e10c prefixlen 64 scopeid 0x20<link>
    ether 00:00:24:ce:e1:0c txqueuelen 1000 (Ethernet)
    RX packets 755 bytes 88704 (86.6 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 25 bytes 2239 (2.1 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 19 memory 0xa1000000-a1020000

    eth1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:e0:4c:68:d7:12 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    eth2: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:e0:4c:68:d6:e7 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    eth4: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0e txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16 memory 0xa3000000-a3020000

    eth5: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0f txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 17 memory 0xa4000000-a4020000

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 16436
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 0 (Local Loopback)
    RX packets 54 bytes 6114 (5.9 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 54 bytes 6114 (5.9 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    p1p2: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:00:24:ce:e1:0d txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16 memory 0xa2000000-a2020000

  3. #3
    Join Date
    Jul 2012
    Location
    Lancaster, MA
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    After messing around with this some more, here's what I did to solve this:

    I added biosdevname=0 to my kernel cmdline in grub. To do this I edited /etc/default/grub and added the parameter to GRUB_CMDLINE_LINUX. This simply makes the devices ethX instead of pXpY in Fedora 17. In the post I mentioned above was a reply that mentions simply removing the biosdevname package also makes it use ethX devices. I didn't try that solution but it's probably slightly more efficient! I'm fine with the ethX devices and I don't trust udev's renaming of them.

    Next, I needed my e1000e built-in 4 x eth devices to be eth0,1,2,3 and my r8169 based add-on card to be eth4,5 to keep my sanity. Just letting the normal auto module load works but seemed like a race condition waiting to happen since the e1000e and 8169 modules are loading in parallel (evident from kernel dmesg showing printk's from both drivers interleaved when looking at the timestamps). I found that with systemd based stuff you can control the module load order for these by adding a file to /etc/modules-load.d with the desired order. I created /etc/modules-load.d/ethernet_drivers.conf and the content of it is:

    Code:
    # Load e1000e followed by r8169
    e1000e
    r8169
    By looking at the handy kernel timestamps for e1000e and r8169 it's easy to see these are loaded serially instead of parallel -- and they are loaded earlier than the auto module loading since without the ethernet_drivers.conf file I would see timestamps from these drivers about 13 seconds in instead of 11.5 seconds through 12.249 like they are here:

    Code:
    [root@mmi-fw1 ~]# dmesg | grep e1000e
    [   11.512771] e1000e: Intel(R) PRO/1000 Network Driver - 1.9.5-k
    [   11.513273] e1000e: Copyright(c) 1999 - 2012 Intel Corporation.
    [   11.514419] e1000e 0000:05:00.0: Disabling ASPM L0s L1
    [   11.516273] e1000e 0000:05:00.0: PCI->APIC IRQ transform: INT C -> IRQ 19
    [   11.518163] e1000e 0000:05:00.0: (unregistered net_device): Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
    [   11.518515] e1000e 0000:05:00.0: irq 41 for MSI/MSI-X
    [   11.518574] e1000e 0000:05:00.0: irq 42 for MSI/MSI-X
    [   11.518629] e1000e 0000:05:00.0: irq 43 for MSI/MSI-X
    [   11.625944] e1000e 0000:05:00.0: eth0: (PCI Express:2.5GT/s:Width x1) 00:00:24:ce:e1:0c
    [   11.626393] e1000e 0000:05:00.0: eth0: Intel(R) PRO/1000 Network Connection
    [   11.628444] e1000e 0000:05:00.0: eth0: MAC: 3, PHY: 8, PBA No: FFFFFF-0FF
    [   11.629770] e1000e 0000:06:00.0: Disabling ASPM L0s L1
    [   11.631259] e1000e 0000:06:00.0: PCI->APIC IRQ transform: INT D -> IRQ 16
    [   11.632645] e1000e 0000:06:00.0: (unregistered net_device): Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
    [   11.633804] e1000e 0000:06:00.0: irq 44 for MSI/MSI-X
    [   11.633865] e1000e 0000:06:00.0: irq 45 for MSI/MSI-X
    [   11.634020] e1000e 0000:06:00.0: irq 46 for MSI/MSI-X
    [   11.745931] e1000e 0000:06:00.0: eth1: (PCI Express:2.5GT/s:Width x1) 00:00:24:ce:e1:0d
    [   11.753260] e1000e 0000:06:00.0: eth1: Intel(R) PRO/1000 Network Connection
    [   11.760343] e1000e 0000:06:00.0: eth1: MAC: 3, PHY: 8, PBA No: FFFFFF-0FF
    [   11.770372] e1000e 0000:0a:00.0: Disabling ASPM L0s L1
    [   11.782250] e1000e 0000:0a:00.0: PCI->APIC IRQ transform: INT C -> IRQ 16
    [   11.794547] e1000e 0000:0a:00.0: (unregistered net_device): Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
    [   11.806606] e1000e 0000:0a:00.0: irq 47 for MSI/MSI-X
    [   11.806691] e1000e 0000:0a:00.0: irq 48 for MSI/MSI-X
    [   11.806769] e1000e 0000:0a:00.0: irq 49 for MSI/MSI-X
    [   11.933857] e1000e 0000:0a:00.0: eth2: (PCI Express:2.5GT/s:Width x1) 00:00:24:ce:e1:0e
    [   11.934516] e1000e 0000:0a:00.0: eth2: Intel(R) PRO/1000 Network Connection
    [   11.935541] e1000e 0000:0a:00.0: eth2: MAC: 3, PHY: 8, PBA No: FFFFFF-0FF
    [   11.936311] e1000e 0000:0b:00.0: Disabling ASPM L0s L1
    [   11.939286] e1000e 0000:0b:00.0: PCI->APIC IRQ transform: INT D -> IRQ 17
    [   11.941921] e1000e 0000:0b:00.0: (unregistered net_device): Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
    [   11.943231] e1000e 0000:0b:00.0: irq 50 for MSI/MSI-X
    [   11.943308] e1000e 0000:0b:00.0: irq 51 for MSI/MSI-X
    [   11.943380] e1000e 0000:0b:00.0: irq 52 for MSI/MSI-X
    [   12.056010] e1000e 0000:0b:00.0: eth3: (PCI Express:2.5GT/s:Width x1) 00:00:24:ce:e1:0f
    [   12.063210] e1000e 0000:0b:00.0: eth3: Intel(R) PRO/1000 Network Connection
    [   12.071242] e1000e 0000:0b:00.0: eth3: MAC: 3, PHY: 8, PBA No: FFFFFF-0FF
    [   17.712476] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
    [   17.713329] e1000e 0000:05:00.0: eth0: 10/100 speed: disabling TSO
    
    [root@mmi-fw1 ~]# dmesg | grep r8169
    [   12.177190] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
    [   12.190191] r8169 0000:0f:00.0: PCI->APIC IRQ transform: INT A -> IRQ 19
    [   12.197539] r8169 0000:0f:00.0: irq 53 for MSI/MSI-X
    [   12.199343] r8169 0000:0f:00.0: eth4: RTL8168c/8111c at 0xf7e36000, 00:e0:4c:68:d7:12, XID 1c4000c0 IRQ 53
    [   12.208214] r8169 0000:0f:00.0: eth4: jumbo features [frames: 6128 bytes, tx checksumming: ko]
    [   12.217300] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
    [   12.231178] r8169 0000:10:00.0: PCI->APIC IRQ transform: INT B -> IRQ 16
    [   12.238335] r8169 0000:10:00.0: irq 54 for MSI/MSI-X
    [   12.239817] r8169 0000:10:00.0: eth5: RTL8168c/8111c at 0xf7e42000, 00:e0:4c:68:d6:e7, XID 1c4000c0 IRQ 54
    [   12.249186] r8169 0000:10:00.0: eth5: jumbo features [frames: 6128 bytes, tx checksumming: ko]
    [   16.612836] r8169 0000:0f:00.0: eth4: link down
    [   16.657749] r8169 0000:10:00.0: eth5: link down
    The resulting network interfaces are exactly as I want them every time the box boots:

    Code:
    [root@mmi-fw1 ~]# ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 10.1.1.197  netmask 255.255.255.0  broadcast 10.1.1.255
            inet6 fe80::200:24ff:fece:e10c  prefixlen 64  scopeid 0x20<link>
            ether 00:00:24:ce:e1:0c  txqueuelen 1000  (Ethernet)
            RX packets 2238  bytes 250972 (245.0 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 320  bytes 45544 (44.4 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 19  memory 0xa1000000-a1020000  
    
    eth1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 00:00:24:ce:e1:0d  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 16  memory 0xa2000000-a2020000  
    
    eth2: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 00:00:24:ce:e1:0e  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 16  memory 0xa3000000-a3020000  
    
    eth3: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 00:00:24:ce:e1:0f  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 17  memory 0xa4000000-a4020000  
    
    eth4: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 00:e0:4c:68:d7:12  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    eth5: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 00:e0:4c:68:d6:e7  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 0  (Local Loopback)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    To finish this off I'll be assigning statics to each interface by using /etc/syconfig/network-scripts/ifcfg-ethX which I'll use the previous /etc/sysconfig/network-scripts/ifcfg-p1p1 as templates.

  4. #4
    Join Date
    Nov 2012
    Location
    canada
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    Thank you sooo much for documenting your problem getting the order of your nics right! I joined the forum just to thank you really. I was trying to rebuild a cluster and it had been driving me nuts for hours until I found this thread. I would never have thought of forcing the driver order. You're a prince for doggedly documenting here when there was no help forthcoming at all.

    BTW, I did go the other way with removing the biosdevname package as I'd already done that, so it works fine doing that as well.

    Ironically, this change was supposed to help those of us with multiple interfaces...

  5. #5
    Join Date
    Dec 2012
    Location
    Seattle WA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    Thanks so much for posting this as I have been having the exact same problem. Your explanation and documentation were excellent.

  6. #6
    Join Date
    Jan 2013
    Location
    India
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    First: Thanks!
    Second: Thanks!

    Problem:
    Fedora 17, two nics
    static IP address causes no access to DNS (resulting in no internet access)

    Able to ping the DNS and any other machine on the internal network;
    Not able to ping the machine or ssh into the machine from outside.

    Adding the biosdevname=0 to my kernel cmdline in grub worked!
    To do this I edited /etc/default/grub and added the parameter to GRUB_CMDLINE_LINUX.

    it took several reboots ( a linux newbie does that best !! ) but eventually it worked.

    Thank you!

  7. #7
    Join Date
    Nov 2010
    Location
    Canada
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 17 no 70persistent-net.rules / biosdevname skips some ethX devices

    Thank you for posting your solution. Oddly I never ran into as persistent a problem until upgrading from 17 to 19.

    It seems that /etc/udev/rules.d/70-persistent-net.rules (carried over from FC16 I suppose) doesn't get read correctly, or at all, every second or third reboot. I initially ended up with eth2 instead of eth0 after upgrading to FC19 and it reverts back to eth2 in a seemingly random fashion every so often after rebooting due to kernel upgrades.

    Change for the sake of change. Fedora's new motto apparently.

Similar Threads

  1. How vital is biosdevname for your system?
    By DokterW in forum F15 Development
    Replies: 13
    Last Post: 13th May 2011, 06:07 PM
  2. Test Day:2011-01-27 Network Device Naming With Biosdevname
    By diamond_ramsey in forum F16 Development
    Replies: 3
    Last Post: 27th January 2011, 01:54 PM
  3. Replies: 3
    Last Post: 5th March 2008, 04:47 AM
  4. fedora 7, xmms skips and stalls
    By slidgey in forum Using Fedora
    Replies: 2
    Last Post: 11th October 2007, 08:17 PM
  5. Fedora 6 64bit Pause's/skips, Sata Dma help questions
    By Lizard_king825 in forum Using Fedora
    Replies: 8
    Last Post: 26th November 2006, 02:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •