[SOLVED] F17: how do you get a network printer working?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Oct 2005
    Location
    U.S.A.
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    F17: how do you get a network printer working?

    I have a network printer.

    I installed the drivers for it. Same ones that worked in F16.

    I try adding a printer through the System Settings. Result: Hopeless keeps getting FirewallD errors.

    So I Alt-F2 and use system-config-printer.

    At least I can add a printer.

    I am using socket://192.168.2.180:9100
    UPDATE: I also tried lpd://192.168.2.180/binary_p1. It fails as well. These work on F16.

    I can ping the printer just fine.

    Now comes the good part. NOTHING PRINTS.

    CUPS says all print jobs complete. But nothing ever prints on the printer.

    So I tried.
    systemctl disable cups.service
    systemctl stop cups.service
    systemctl enable cups.service
    systemctl start cups.service
    systemctl status cups.service

    Nope. Still no good.

    Jun 6 15:41:40 renog13-lin01 python: io/hpmud/jd.c 89: unable to read device-id
    Jun 6 15:41:40 renog13-lin01 python: io/hpmud/jd.c 847: invalid ip 192.168.2.180
    Jun 6 15:41:40 renog13-lin01 hp-makeuri: hp-makeuri[20326]: error: Device not found
    Jun 6 15:41:43 renog13-lin01 dbus-daemon[921]: ** Message: No devices in use, exit
    Jun 6 15:41:53 renog13-lin01 chronyd[909]: Selected source 69.164.222.108
    Jun 6 15:41:56 renog13-lin01 dbus-daemon[921]: dbus[921]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
    Jun 6 15:41:56 renog13-lin01 dbus[921]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
    Jun 6 15:41:56 renog13-lin01 dbus-daemon[921]: Launching FprintObject
    Jun 6 15:41:56 renog13-lin01 dbus-daemon[921]: dbus[921]: [system] Successfully activated service 'net.reactivated.Fprint'
    Jun 6 15:41:56 renog13-lin01 dbus-daemon[921]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
    Jun 6 15:41:56 renog13-lin01 dbus-daemon[921]: ** Message: entering main loop
    Jun 6 15:41:56 renog13-lin01 dbus[921]: [system] Successfully activated service 'net.reactivated.Fprint'
    Jun 6 15:42:26 renog13-lin01 dbus-daemon[921]: ** Message: No devices in use, exit

    Maybe someone can see something in this log.

    The ip address: 192.168.2.180 is the printer and it pings just fine.

    I just walked over to its console to check its IP and it is correct.

    How do you get a network printer working in F17?

    .

    ---------- Post added at 05:51 PM ---------- Previous post was at 04:16 PM ----------

    I gave up on the first printer and tried installing a second network printer (HP).

    This time I was able to get it working as LPD.

    So I went back to the first printer (a Brother MFC) and I see this in the error_log:


    Code:
    W [06/Jun/2012:15:47:47 -0400] failed to find device: cups-mfc665cw
    W [06/Jun/2012:15:47:47 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'mfc665cw-Gray..' already exists
    W [06/Jun/2012:15:47:47 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'mfc665cw-RGB..' already exists
    W [06/Jun/2012:15:47:47 -0400] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-mfc665cw' already exists
    E [06/Jun/2012:15:47:47 -0400] Unable to bind socket for address [v1.::1]:631 - Address already in use.
    W [06/Jun/2012:16:02:15 -0400] failed to find device: cups-mfc665cw
    W [06/Jun/2012:16:02:15 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'mfc665cw-Gray..' already exists
    W [06/Jun/2012:16:02:15 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'mfc665cw-RGB..' already exists
    W [06/Jun/2012:16:02:15 -0400] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-mfc665cw' already exists
    E [06/Jun/2012:16:02:15 -0400] Unable to bind socket for address [v1.::1]:631 - Address already in use.
    W [06/Jun/2012:17:05:45 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'mfc665cw-Gray..' already exists
    W [06/Jun/2012:17:05:45 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'mfc665cw-RGB..' already exists
    W [06/Jun/2012:17:05:45 -0400] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-mfc665cw' already exists
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
    W [06/Jun/2012:17:10:57 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
    W [06/Jun/2012:17:16:02 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HP-LaserJet-4-Plus-Gray..' already exists
    W [06/Jun/2012:17:16:02 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HP-LaserJet-4-Plus-RGB..' already exists
    W [06/Jun/2012:17:16:02 -0400] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-HP-LaserJet-4-Plus' already exists
    W [06/Jun/2012:17:16:03 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HP-LaserJet-4-Plus-Gray..' already exists
    W [06/Jun/2012:17:16:03 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HP-LaserJet-4-Plus-RGB..' already exists
    W [06/Jun/2012:17:16:03 -0400] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-HP-LaserJet-4-Plus' already exists
    W [06/Jun/2012:17:16:03 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HP-LaserJet-4-Plus-Gray..' already exists
    W [06/Jun/2012:17:16:03 -0400] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HP-LaserJet-4-Plus-RGB..' already exists
    W [06/Jun/2012:17:16:03 -0400] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-HP-LaserJet-4-Plus' already exists
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
    W [06/Jun/2012:17:40:16 -0400] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
    I installed the Brother printer drivers from their website just as I had before with F16.

    So I'm wondering if maybe these Brother drivers are not compatible with F17 for some reason.

    .
    Last edited by greno; 6th June 2012 at 10:08 PM.

  2. #2
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,236
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Why don't use try using the web browser to install printers. It usually works without too many problems. System settings printer has acted up in the past for me ...

    Open a broswer and go to localhost:631. From the Administration tab, you can add printers without problems. I am using one on socket right now!

    Try this!

  3. #3
    Join Date
    Oct 2005
    Location
    U.S.A.
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Ok, I think I found the problem.

    Brother packages its drivers as i386 RPM packages for Fedora and other rpm distros.

    I had installed F17 on a x86_64 machine and when I checked RPM I see this:

    Code:
    Warning: RPMDB altered outside of yum.
    ** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
    mfc665cwcupswrapper-1.0.1-1.i386 has missing requires of libc.so.6
    mfc665cwcupswrapper-1.0.1-1.i386 has missing requires of libc.so.6(GLIBC_2.0)
    mfc665cwcupswrapper-1.0.1-1.i386 has missing requires of libc.so.6(GLIBC_2.1)
    mfc665cwlpr-1.0.1-1.i386 has missing requires of libc.so.6
    mfc665cwlpr-1.0.1-1.i386 has missing requires of libc.so.6(GLIBC_2.0)
    mfc665cwlpr-1.0.1-1.i386 has missing requires of libc.so.6(GLIBC_2.1)
    mfc665cwlpr-1.0.1-1.i386 has missing requires of libc.so.6(GLIBC_2.3)
    So it appears that it wants 32-bit libraries.

    So what needs to be installed?

    .

  4. #4
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,236
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Do you have glibc.i686 installed?

    one helpful command in these cases is yum provides

    Code:
    yum provides libc.so.6
    Loaded plugins: langpacks, presto, refresh-packagekit
    
    glibc-2.15-37.fc17.i686 : The GNU libc libraries
    Repo        : fedora
    Matched from:
    Provides    : libc.so.6
    
    glibc-2.15-37.fc17.i686 : The GNU libc libraries
    Repo        : @fedora
    Matched from:
    Provides    : libc.so.6

  5. #5
    Join Date
    Oct 2005
    Location
    U.S.A.
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Installing glibc.i686 fixed the problem.

    .

  6. #6
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,236
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Glad it worked! would you please mark the thread as 'solved' then! Cheers

  7. #7
    stevea Guest

    Re: F17: how do you get a network printer working?

    I try adding a printer through the System Settings. Result: Hopeless keeps getting FirewallD errors.
    Firewalld was removed from the release F17 defaults since the gui tool for setting permanent tables didn't work.

  8. #8
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,236
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Quote Originally Posted by stevea
    Firewalld was removed from the release F17 defaults since the gui tool for setting permanent tables didn't work.
    Yeah! But setting up printer using that GNOME printer settings GUI still shows that FirewallD message.

  9. #9
    Join Date
    Jun 2012
    Location
    Los Angeles
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Hi, I'm new to Linux and Fedora. I was able to get my canon printer working with Fedora 16, but I am having trouble with Fedora 17. I get the same libc.so.6 files missing message, but I have glibc.i686 installed. I think the rpm packages are getting installed in /lib and not /lib64. Could that be the problem? Can anyone give me detailed instructions on how to install the rpm printer files to the correct directory?

    This is the message I have been getting:


    libc.so.6 is needed by cndrvcups-common-2.30-1.x86_64
    libc.so.6(GLIBC_2.0) is needed by cndrvcups-common-2.30-1.x86_64
    libc.so.6(GLIBC_2.1) is needed by cndrvcups-common-2.30-1.x86_64
    libc.so.6(GLIBC_2.1.3) is needed by cndrvcups-common-2.30-1.x86_64
    libc.so.6(GLIBC_2.3) is needed by cndrvcups-common-2.30-1.x86_64
    libdl.so.2 is needed by cndrvcups-common-2.30-1.x86_64
    libdl.so.2(GLIBC_2.0) is needed by cndrvcups-common-2.30-1.x86_64
    libdl.so.2(GLIBC_2.1) is needed by cndrvcups-common-2.30-1.x86_64
    libm.so.6 is needed by cndrvcups-common-2.30-1.x86_64
    libm.so.6(GLIBC_2.0) is needed by cndrvcups-common-2.30-1.x86_64
    libpthread.so.0 is needed by cndrvcups-common-2.30-1.x86_64
    libpthread.so.0(GLIBC_2.0) is needed by cndrvcups-common-2.30-1.x86_64
    libpthread.so.0(GLIBC_2.1) is needed by cndrvcups-common-2.30-1.x86_64
    libpthread.so.0(GLIBC_2.3.2) is needed by cndrvcups-common-2.30-1.x86_64
    librt.so.1 is needed by cndrvcups-common-2.30-1.x86_64

  10. #10
    Join Date
    Jun 2011
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    THANK YOU so much.

    Installing glibc.i686 fixed the problem. i used the command below:

    yum install glibc.i686

  11. #11
    Join Date
    Nov 2013
    Location
    Phoenix, AZ
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F17: how do you get a network printer working?

    Quote Originally Posted by nonamedotc
    Why don't use try using the web browser to install printers. It usually works without too many problems. System settings printer has acted up in the past for me ...

    Open a broswer and go to localhost:631. From the Administration tab, you can add printers without problems. I am using one on socket right now!

    Try this!

    You are awesome! Thank you! This step worked perfectly on my Fedora 19 machine. Thank you for helping the OP and also for solving my issue as well.

Similar Threads

  1. Printer not Working
    By DustinCox in forum Hardware & Laptops
    Replies: 2
    Last Post: 25th April 2012, 12:50 PM
  2. Panasonic DP-8020p Printer Copier Network Printer
    By Cyborg_sa in forum Hardware & Laptops
    Replies: 5
    Last Post: 6th March 2010, 05:17 PM
  3. Package updater fails, no network, but network is working fine
    By MonsterMaxx in forum Servers & Networking
    Replies: 3
    Last Post: 2nd February 2008, 12:05 AM
  4. Replies: 11
    Last Post: 5th October 2007, 09:23 AM
  5. Need help getting my printer working..
    By mrnatch in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 26th March 2006, 05:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •