FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2010
    Posts
    2

    Cannot solve - ERROR with transaction check vs depsolve:

    I've searched and tried a number of solutions but I just cannot solve this problem when trying to install updates.


    Code:
    Running Transaction Check
    ERROR with transaction check vs depsolve:
    kernel-uname-r = 2.6.35.14-103.fc14.x86_64 is needed by (installed) kmod-wl-2.6.35.14-103.fc14.x86_64-5.100.82.38-1.fc14.10.x86_64
    kernel-uname-r = 2.6.35.14-97.fc14.x86_64 is needed by (installed) kmod-wl-2.6.35.14-97.fc14.x86_64-5.100.82.38-1.fc14.8.x86_64
    kernel-uname-r = 2.6.35.14-106.fc14.x86_64 is needed by (installed) kmod-wl-2.6.35.14-106.fc14.x86_64-5.100.82.38-1.fc14.12.x86_64
    Please report this error in http://yum.baseurl.org/report
    ** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
    intellij-idea-9.0.1.94.399-12.fc15.x86_64 has missing requires of commons-collections
    kmod-wl-2.6.35.14-103.fc14.x86_64-5.100.82.38-1.fc14.10.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '103.fc14.x86_64')
    kmod-wl-2.6.35.14-106.fc14.x86_64-5.100.82.38-1.fc14.12.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '106.fc14.x86_64')
    kmod-wl-2.6.35.14-97.fc14.x86_64-5.100.82.38-1.fc14.8.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '97.fc14.x86_64')
    Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2012-03-28-22-48F9tqEO.yumtx
    [root@localhost ~]# yum update kernel-uname-r
    Loaded plugins: langpacks, presto, refresh-packagekit
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package kernel.x86_64 0:3.3.0-4.fc16 will be installed
    --> Processing Dependency: linux-firmware >= 20120206-0.1.git06c8f81 for package: kernel-3.3.0-4.fc16.x86_64
    --> Running transaction check
    ---> Package linux-firmware.noarch 0:20110731-2.fc16 will be updated
    ---> Package linux-firmware.noarch 0:20120206-0.1.git06c8f81.fc16 will be an update
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package kernel.x86_64 0:3.1.4-1.fc16 will be erased
    --> Processing Dependency: kernel-uname-r = 3.1.4-1.fc16.x86_64 for package: kmod-wl-3.1.4-1.fc16.x86_64-5.100.82.112-1.fc16.4.x86_64
    --> Running transaction check
    ---> Package kmod-wl-3.1.4-1.fc16.x86_64.x86_64 0:5.100.82.112-1.fc16.4 will be erased
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ================================================================================
     Package                  Arch   Version                      Repository   Size
    ================================================================================
    Installing:
     kernel                   x86_64 3.3.0-4.fc16                 updates      26 M
    Removing:
     kernel                   x86_64 3.1.4-1.fc16                 @anaconda-0 112 M
    Updating for dependencies:
     linux-firmware           noarch 20120206-0.1.git06c8f81.fc16 updates      10 M
    Removing for dependencies:
     kmod-wl-3.1.4-1.fc16.x86_64
                              x86_64 5.100.82.112-1.fc16.4        @anaconda-0 3.0 M
    
    Transaction Summary
    ================================================================================
    Install       1 Package
    Upgrade       1 Package
    Remove        2 Packages
    
    Total size: 37 M
    Is this ok [y/N]: y
    Downloading Packages:
    Running Transaction Check
    ERROR with transaction check vs depsolve:
    kernel-uname-r = 2.6.35.14-103.fc14.x86_64 is needed by (installed) kmod-wl-2.6.35.14-103.fc14.x86_64-5.100.82.38-1.fc14.10.x86_64
    kernel-uname-r = 2.6.35.14-97.fc14.x86_64 is needed by (installed) kmod-wl-2.6.35.14-97.fc14.x86_64-5.100.82.38-1.fc14.8.x86_64
    kernel-uname-r = 2.6.35.14-106.fc14.x86_64 is needed by (installed) kmod-wl-2.6.35.14-106.fc14.x86_64-5.100.82.38-1.fc14.12.x86_64
    Please report this error in 
    ** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
    intellij-idea-9.0.1.94.399-12.fc15.x86_64 has missing requires of commons-collections
    kmod-wl-2.6.35.14-103.fc14.x86_64-5.100.82.38-1.fc14.10.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '103.fc14.x86_64')
    kmod-wl-2.6.35.14-106.fc14.x86_64-5.100.82.38-1.fc14.12.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '106.fc14.x86_64')
    kmod-wl-2.6.35.14-97.fc14.x86_64-5.100.82.38-1.fc14.8.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '97.fc14.x86_64')
    Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2012-03-28-23-37ZZ_h4H.yumtx
    I would be greatful for any help.

  2. #2
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,572

    Re: Cannot solve - ERROR with transaction check vs depsolve:

    I would start with this to resolve the issue:
    Code:
    yum erase kmod-wl-2.6.35.14-103.fc14.x86_64-5.100.82.38-1.fc14.10.x86_64 kmod-wl-2.6.35.14-97.fc14.x86_64-5.100.82.38-1.fc14.8.x86_64 kmod-wl-2.6.35.14-106.fc14.x86_64-5.100.82.38-1.fc14.12.x86_64
    Just for the heck of it, in F16, I did a "sudo yum install intellij-idea". After a rather lengthy list of dependencies that would have been pulled in with it, it ended with...
    Code:
    ........
    --> Finished Dependency Resolution
    Error: Package: intellij-idea-9.0.1.94.399-12.fc15.x86_64 (fedora)
               Requires: commons-collections
     You could try using --skip-broken to work around the problem
    Code:
    BASH:~/-> yum list commons-collections
    Loaded plugins: langpacks, presto
    Error: No matching Packages to list
    The package maintainer of intellij-idea pushed the package into the F16 repo without checking that all the dependency packages were there to support it, or just made a slip up in the spec file.
    Code:
    BASH:~/-> yum list *commons-collections*
    Loaded plugins: langpacks, presto
    Available Packages
    apache-commons-collections.noarch                                                            3.2.1-11.fc16                                      fedora
    apache-commons-collections-javadoc.noarch                                                    3.2.1-11.fc16                                      fedora
    apache-commons-collections-testframework.noarch                                              3.2.1-11.fc16                                      fedora
    apache-commons-collections-testframework-javadoc.noarch                                      3.2.1-11.fc16                                      fedora
    Last edited by PabloTwo; 29th March 2012 at 12:40 AM.

  3. #3
    Join Date
    Dec 2010
    Posts
    2

    Re: Cannot solve - ERROR with transaction check vs depsolve:

    OMG. Thanks a bunch!

    It worked.

Similar Threads

  1. Transaction check error
    By guyenfedora000 in forum Using Fedora
    Replies: 1
    Last Post: 5th June 2007, 08:52 AM
  2. yum, transaction check error
    By hugbees in forum Using Fedora
    Replies: 0
    Last Post: 12th December 2006, 03:48 PM
  3. Transaction Check Error:
    By tgrier in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 25th November 2006, 04:50 AM
  4. Transaction Check Error
    By hedgert in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 23rd October 2005, 10:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •