<---- template headericclude ----->
[SOLVED] blacklisting radeon module for catalyst
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2011
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    blacklisting radeon module for catalyst

    Hi,

    I'm trying out the catalyst driver 12.1 and I'm clearly missing something when trying to blacklist the radeon driver. When booting catalyst it tries to load the radeon module and and when I get as far as gdm I get either a blank screen or a screen of coloured lines then the system reboots. I tried adding the following to /etc/modprobe.d/blacklist.conf

    Code:
    blacklist radeon
    blacklist radeonhd
    But it still loads the radeon module. I'm clearly missing out a step, because if I edit by grub boot string to include rdblacklist=radeon it boots ok.

    Could someone tell me what I've missed?

  2. #2
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    901
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: blacklisting radeon module for catalyst

    on my Fedora 15 system I have radeon.modeset=0 (probably exactly the same as rdblacklist=radeon) in the grub boot string. That's probably the easiest way to solve it.

  3. #3
    Join Date
    Oct 2011
    Posts
    141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: blacklisting radeon module for catalyst

    Fenrin, thanks. That was what I opted for (well rdblacklist=radeon) as I realised that I used nearly the same flag for my old NVidia card: rdblacklist=nouveau

    That being said, I found the tearing in Gnome 3 was driving me batty. Meantime I've switched back to the radeon driver despite 3D being decidedly poor, and or broken.

  4. #4
    Join Date
    Dec 2006
    Location
    Pennsylvania
    Posts
    385
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: blacklisting radeon module for catalyst

    Gnome 3 and catalyst still don't play well together. If you want to use Gnome 3 without any tearing, you have to use fallback mode.

    On the bright side, KDE 4.7 has gotten quite a bit better. I installed the KDE spin after I got tried of Gnome's very limited fallback mode. With all of the updates applied, it runs quite well (for the moment).

Similar Threads

  1. Fedora 14 ATI Catalyst and Radeon HD 6550m
    By evilbastard in forum Hardware
    Replies: 4
    Last Post: 1st August 2011, 12:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
[[template footer(Guest)]]