FedoraForum.org - Fedora Support Forums and Community
Results 1 to 9 of 9
  1. #1
    Join Date
    Jan 2012
    Location
    Dehradun, India
    Posts
    14

    Exclamation Recover deleted files

    Hello Fedorians !

    Yesterday, when I opened my system it gave me an error message saying

    "Could not create ICE listening socket. Cannot establish any listening port."

    and after that message all of my visuals tuned to very basic level. I mean earlier when I installed fedora 16
    the graphics and animation were quite interesting, but then after that error everything dissapeared, and fedora 16 looked like a very old fedora.

    I am new to linux OS and fedora 16 is my first attempt towards linux.

    After few googles I thought that the error was due to few leftover temporary files in /tmp directory.
    I also read somehwere that using "tmpwatch" command can help me with that error, so I used this command but nothing happened. Then I tried many combinations of this command with different differrent attributes.

    Here is the list of commands I used

    tmpwatch /tmp
    tmpwatch 1m /tmp
    sudo tmpwatch 1m /tmp
    sudo tmpwatch 1m --all


    and at last the most importantly this one
    sudo tmpwatch 1m /

    after which I discovered that all of my personal files and folders are gone.I dont know which command specifically did that. FYI only the files and folders in my home folders are gone(as much as i know till now), but there has been no harm to the applications I installed, I mean they are still installed and are working fine.

    Can anybody please tell me If I can get all my files back, if Yes Then please post how..??
    Please Please PLease its very very urgent for me to get my files back.

    Thanks a Ton in advance !!!

  2. #2
    Join Date
    Dec 2011
    Posts
    68

    Re: Recover deleted files

    tmpwatch deletes any files that are older than the time given (1m or 1 minute) in the directory specified (/ or the top of your file system) and all its subdirectories. Basically you have wiped out everything to which you had access that is older than one minute. Prefixing this with sudo means that you have done this as root (who has access to everything). I guess that bits and pieces are still there as the files were still open or had recently been accessed, but I guess you have basically wiped your harddisk. A re-install may be the quickest way forward.

  3. #3
    Join Date
    Aug 2009
    Posts
    8,482

    Re: Recover deleted files

    I don't believe that those tmpwatch commands have anything to do with files being gone from your home folder. Tmpwatch works on files in /tmp and does not cross filesystem boundaries (even if symlinks are present that do) Plus, you can go in and delete every file in /tmp and not cause any really bad problems (you may have to restart, but that's about the worst you would need to do).

    I believe the "missing" files in your home folder is what caused the original issue. (The files may not be missing due to the nature of the original issue)

    One thing to try is to delete all of the file in /tmp/.ICE-unlx and restart.

    Gnome tries to create an ICE socket when it starts, and stores the ICE sockets in /tmp/.ICE-unix and they are named by PID. If there was one named with the same PID as what Gnome was trying to create, it can cause issues.

    try running rm -f /tmp/.ICE-unix/* and then restart your system.

  4. #4
    Join Date
    Jan 2012
    Location
    Dehradun, India
    Posts
    14

    Re: Recover deleted files

    After my files were gone I restarted my pc but still all my files were gone... but 1 thing changed that is .. now again my fedora is looking great with graphics as newly installed fedora 16

  5. #5
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    901

    Re: Recover deleted files

    a free data recovery tool is Autopsy Forensic.

    this tool has several purposes. I just installed it and it seems to be a bit complicated to use.
    Last edited by Fenrin; 5th February 2012 at 07:42 PM.

  6. #6
    Join Date
    Jan 2012
    Location
    Dehradun, India
    Posts
    14

    Re: Recover deleted files

    it happened with one more friend of mine....
    He also tried "sudo tmpwatch 1m /" command and he also landed in troubling situations.. infact he had to reinstall Fedora.... So as of now I suggest everybody to strictly avoid this command....!
    Last edited by vaibhavatul47; 11th February 2012 at 02:06 PM. Reason: missed some data

  7. #7
    Join Date
    Mar 2009
    Location
    Lancaster, UK
    Posts
    930

    Re: Recover deleted files

    If you have indeed deleted your files have a look at this thread on how to recover them (perhaps) http://forums.fedoraforum.org/showthread.php?t=267788

  8. #8
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,284

    Re: Recover deleted files

    Quote Originally Posted by DBelton
    I don't believe that those tmpwatch commands have anything to do with files being gone from your home folder. Tmpwatch works on files in /tmp and does not cross filesystem boundaries (even if symlinks are present that do)
    I'm also not sure the OP problem was due to the "tmpwatch 1m /" but in general the
    tmpwatch's man page says that tmpwatch is not specific to /tmp, there's a final "dirs" argument which can point to a directory other than /tmp quoting from the man page:

    tmpwatch [-u|-m|-c] [-MUXadfqstvx] [--verbose] [--force] [--all]
    [--nodirs] [--nosymlinks] [--test] [--fuser] [--quiet]
    [--atime|--mtime|--ctime] [--dirmtime] [--exclude path]
    [--exclude-user user] [--exclude-pattern pattern]
    time dirs
    "Normally, it's used to clean up directories which are used for temporary holding space such as /tmp."
    It's not absolutely clear but "Normally" implies that "dirs" can be something other than something underneath /tmp. So to test that I copied my ~/.shotwell directory over to the saved side copy and used tmpwatch on it:
    cd
    cp -a .shotwell .shotwell.sav
    tmpwatch 1m ~/.shotwell

    diff -r .shotwell .shotwell.sav/
    Only in .shotwell.sav/: data
    Only in .shotwell.sav/: mimics
    Only in .shotwell.sav/: thumbs
    I found all the stuff in .shotwell was removed by tmpwatch
    Last edited by marko; 11th February 2012 at 07:03 PM.

  9. #9
    Join Date
    Jun 2011
    Location
    Italy
    Posts
    395

    Re: Recover deleted files

    I had the same problem when I upgraded to kernel 3.2.5-3.
    Running rm -f /tmp/.ICE-unix/* completely solved the problem.
    Thanks DBelton...

Similar Threads

  1. How To Recover The Deleted Files ???
    By BProgrammer in forum Using Fedora
    Replies: 5
    Last Post: 2nd February 2011, 09:24 PM
  2. recover deleted or disapeared files?
    By betz in forum Using Fedora
    Replies: 4
    Last Post: 18th May 2008, 03:54 AM
  3. How to recover deleted files?
    By ims.analyst in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 20th February 2008, 11:42 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •