FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2012
    Location
    baltimore, md
    Posts
    5

    F16 Wake on lan not working

    I'm beating my head against a small rack of computers that need to be started remotely (won't have front panel access generally) so WOL is the obvious solution. Originally the whole rack was set to be RHEL 6 (really should just have used Centos) but the workstations needed more current stuff, so Fedora was the right choice for them, servers are still RH. When all were RHEL 6.2 the entire rack could boot using WOL.

    After loading F16 on the workstations they booted using WOL just fine (the first time...) but now WOL only works on them from a "suspended" state. Fully shutdown they don't respond.

    The systems are Dell Precsions with Broadcom 10G ethernet cards (tg3). The driver is the same (3.119) between RH and F16 (3.1 kernel) so seems that its in the surrounding code. Problem

    When up, ethtool reports Wake On Lan = g, as expected, so everything looks good. I've tried putting 'ETHTOOL_OPTS="wol g" ' in the ifcfg-em1 and wedged 'ethtool-set' into all the places in ifdown-eth where the interfaces are cleared. Even commented out the line in ifdown-eth where the device is set "down" ('ip link set dev ${DEVICE} down'). No joy all around.

    The new systemd setup does a very good job of hiding the whole halt process. there's no "/etc/init.d/halt" to play around with.

    Any ideas? Any one?

    TIA,

    carl.

  2. #2
    Join Date
    Jan 2012
    Location
    baltimore, md
    Posts
    5

    Re: F16 Wake on lan not working

    more on my situation.

    looking directly into the /sys/class/net/em1/device/power/wakeup it is "enabled" setting ethtool -s wol d does set it to "disabled." So the system, when up, seems to be properly configured, but WOL does not work.

    Looking at the device the link light is on on the card, so power is being applied, it just won't respond to the WOL. (And again WOL works for a system in "suspend" but not in "poweroff").

    pointers?

    carl.

    ---------- Post added at 10:40 PM ---------- Previous post was at 04:38 PM ----------

    Curiouser and curiouser.

    If I reboot and then when I get to grub, issue a halt from the grub command line, then WOL works. So there's something in the Fedora shutdown routines that is leaning heavily on the ethernet card.

    Does anyone have a good approach for tracing what the heck is happening during the shutdown? I can't get any log information.

    I've tried the recommendation from DBelton here for a script in /lib/systemd/system-shutdown, but it doesn't seem to run for me (I don't get any information in /dmesg.shutdown.

  3. #3
    Join Date
    Jan 2012
    Location
    baltimore, md
    Posts
    5

    Re: F16 Wake on lan not working

    for those watching, a bit more info.

    If I issue shutdown -H (instead of shutdown -h) telling the system to "HALT" not "POWEROFF" the system will not actually shutdown. Fedora gets to the end (apparently, the log file shows rsyslogd closing, which is usually last) but then just sits, in a powered state. If at that point I push the power button it shuts down, and then can be woken with WOL.

  4. #4
    Join Date
    Aug 2011
    Location
    ~
    Posts
    1,936

    Re: F16 Wake on lan not working

    Most likely a driver problem even though the version hasn't changed.
    What Broadcom model do you have?

  5. #5
    Join Date
    Jan 2012
    Location
    baltimore, md
    Posts
    5

    Re: F16 Wake on lan not working

    I've got a Broadcom NetXtreme BCM5761. Its built-in to the Dell boxes I'm working with.

    ACPITOOL reports that the cards are "disabled" for waking the PCI, I can't seem to get "enabled" to stick, so yes, it may be the card. I saw a couple of month old conversation about this but the mentioned patches are already in the driver. (I've pulled the source for it as well as systemd).

    So right now my work-around is to reboot the box, intercept it in grub and halt from there. Very inelegant, but gets me what I need....

  6. #6
    Join Date
    Oct 2012
    Location
    UK
    Posts
    1

    Re: F16 Wake on lan not working

    I had the same problem as you and a simmilar level of frustration. I found the solution here: http://www.techanswerguy.com/2010/02...lan-redux.html

    I can't get to grips with the way halt works with systmctl and so I added the following script with chkconfig:

    Code:
    #!/bin/sh
    # chkconfig: 123456 55 95
    
    case "$1" in
    start)
            ;;
    stop)
            rmmod tg3
            ;;
    status)
            echo "fix for wol on shutdown"
            ;;
    *)
            echo $"Usage: $0 {start|stop|status}"
            exit 1
    esac
    
    exit 0

Similar Threads

  1. Replies: 1
    Last Post: 2nd July 2009, 10:35 AM
  2. Can't wake up
    By TheCigarman in forum Using Fedora
    Replies: 0
    Last Post: 13th August 2008, 05:18 PM
  3. wake-on-lan
    By kicon_kijin in forum Hardware & Laptops
    Replies: 2
    Last Post: 19th February 2008, 04:47 PM
  4. Wake On LAN
    By bajo in forum Servers & Networking
    Replies: 9
    Last Post: 25th July 2006, 12:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •