Configuring mouse side buttons in FC3
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
  1. #1
    s_reynisson Guest

    Configuring mouse side buttons in FC3

    Keywords: Mouse, Fedora Core 3, Side, Button, USB, Wheel, Forward, Back, Configure
    Files used: /etc/X11/xorg.conf, /etc/X11/xinit/xinitrc.d/mouse.sh

    This is a summary from the many posts here on this topic, credits to the original posters. This works fine on my system, FC3 Kernel 2.6.9-1.678_FC3smp with a USB Logitech MX500 mouse. This is all you need to do, you do not have to install any programs.

    As root, add this to your InputDevice section in xorg.conf in folder /etc/X11/, I back up using comments, you can also copy the file first with something like cp xorg.conf xorg.conf.org:
    Code:
    # new part
    Section "InputDevice"
    #       Identifier  "USB Mouse"
            Identifier  "Mouse0"
            Driver      "mouse"
            Option      "Protocol"     "ExplorerPS/2"
            Option      "Device"       "/dev/input/mice"
            Option      "Buttons"      "7"
            Option      "ZAxisMapping" "6 7"
    EndSection
    # old part
    #Section "InputDevice"
    #       Identifier  "Mouse0"
    #       Driver      "mouse"
    #       Option      "Protocol" "IMPS/2"
    #       Option      "Device" "/dev/input/mice"
    #       Option      "ZAxisMapping" "4 5"
    #       Option      "Emulate3Buttons" "yes"
    Note here that I have commented out Identifier "USB Mouse" and replaced it with my original Identifier "Mouse0". You must do the same. Next create the file mouse.sh in folder /etc/X11/xinit/xinitrc.d/ and paste the following in it:
    Code:
    #!/bin/sh
    # /etc/X11/xinit/xinitrc.d/mouse.sh
    # Required for the configuration of a 5-button mouse
    xmodmap -e "pointer = 1 2 3 6 7 4 5"
    Finally make it executable with chmod +x mouse.sh. Restart X, I rebooted Good luck!
    Last edited by s_reynisson; 20th November 2004 at 05:36 AM.

  2. #2
    imdeemvp Guest
    Very how info....it will help others.

  3. #3
    SilverZero Guest
    Very how indeed.

    Glad to see a reference to the ".sh" extension requirement for scripts in the xinitrc.d directory. That hummer was eluding me for hours!
    Last edited by SilverZero; 20th November 2004 at 06:10 AM.

  4. #4
    adam Guest
    awesome! thank you

  5. #5
    Join Date
    Nov 2004
    Posts
    1,105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This worked great for me. Thank you for the how-to. I do have one question. Is it possible to play with some of the parameters in these two files and program the side buttons for functions other than "back" and "forward"?
    IMHO GNOME FTW! BTW KDE WAD? FWIW. HTH. AFAIK YMMV. OMG WTF BBQ! :rolleyes:

    Do you like surfing forums but wish people would stop using obscure abbreviations and acronyms?
    Then my Firefox/Chrome extension ABBREX is for you!
    It automatically adds hover tooltips to abbreviations displaying their meanings on any web page you visit!

    Check it out at: http://abbrex.com

  6. #6
    benv84 Guest
    thanks alot for the how to, not being able to use my side buttons has really been bugging me after switching to linux

  7. #7
    benv84 Guest
    does anyone know how to edit the files for a microsoft intellimouse explorer 3.0? because the back and forward buttons still don't work.

  8. #8
    Forlorn Guest
    Quote Originally Posted by benv84
    does anyone know how to edit the files for a microsoft intellimouse explorer 3.0? because the back and forward buttons still don't work.
    same for me

  9. #9
    vladthedog Guest
    oh man thanks. i've been trying to get this mx510 to work for a while. i've read other "walkthroughs" but either i've been doing something wrong, or whatever cause i could never get the dang thing to work... now it works like a charm! i'm a very recent convert from winxp, and that was one of my big complaints

  10. #10
    saFFyre Guest
    Ok ive just attempted this, and all works well when im logged in as root. However when im using my normal user account the mouse wheel and the side buttons have swapped function. The mouse wheel being back and forward and the side buttons scroll up and down. Im using fedora core 3 on a fresh install. I followed the instructions right as far as i can tell.

    Cheers
    Tom

  11. #11
    Aksen Guest
    I'm totally new to linux, I've been trying to tackle this problem for two days now. Thank you, this worked on the first try.

  12. #12
    Aksen Guest
    saFFyre :

    I just reinstalled FC3, first time was a test run i guess. Well anyway, now I'm having the same problem as you... but i think i figured it out. log in as root, then go to the "mouse.sh" file, right click and hit properties. Make sure all users have permissions to execute the file!

  13. #13
    firstknt Guest
    thanks for the how...

    my previously limited intellimouse is currently at it's best... now if i can get the "snap-to" to work and have the hot keys on my desktop elite function, i would be a zealot of linux till eternity

  14. #14
    micha Guest

  15. #15
    niloppa Guest
    there's answer in this link ===> www.s_what_mouse_configuration.op.com

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 32
    Last Post: 19th August 2009, 05:34 PM
  2. Can't use mouse side buttons in FC6
    By Mystinar in forum Using Fedora
    Replies: 3
    Last Post: 5th November 2006, 05:39 AM
  3. FC5 - FireFox Side Buttons
    By BoSoxNC in forum Using Fedora
    Replies: 3
    Last Post: 6th April 2006, 04:39 AM
  4. Not detecting side mouse buttons
    By TheSkunkMan in forum Hardware
    Replies: 1
    Last Post: 15th August 2005, 07:00 PM
  5. configuring mouse buttons
    By zulaica in forum Hardware
    Replies: 7
    Last Post: 28th October 2004, 10:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •