vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 15 of 15
  1. #1
    Join Date
    Jan 2007
    Posts
    16

    vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    I have been running the VMWare workstation in F15. The published patch set allowed it to build and run with the 2.6.40 kernel, but the new kernel that was just pushed breaks vmware and it will not compile. anyone seen a fix?

  2. #2
    Join Date
    Nov 2006
    Posts
    46

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    The same is here. Will be very thankful for the help!

  3. #3
    Join Date
    Apr 2005
    Posts
    344

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    The same issue here.

    Looks as though VirtualBox is broken too, however an easy fix is available here:
    http://linuxfollies.blogspot.com/201...15-kernel.html
    Last edited by psyklops; 21st November 2011 at 12:15 PM.

  4. #4
    Join Date
    Oct 2006
    Posts
    26

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    I have the same problem with VMWare 8. Here are the compile errors in the vmnet module:

    In file included from /tmp/vmware-root/modules/vmnet-only/netif.c:43:0:
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:186:0: warning: "alloc_netdev" redefined [enabled by default]
    include/linux/netdevice.h:2438:0: note: this is the location of the previous definition
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:187:0: warning: "alloc_etherdev" redefined [enabled by default]
    include/linux/etherdevice.h:53:0: note: this is the location of the previous definition
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:208:1: error: conflicting types for 'netif_start_queue'
    include/linux/netdevice.h:1804:20: note: previous definition of 'netif_start_queue' was here
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h: In function 'netif_start_queue':
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:210:21: error: 'struct device' has no member named 'tbusy'
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h: At top level:
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:214:1: error: conflicting types for 'netif_stop_queue'
    include/linux/netdevice.h:1869:20: note: previous definition of 'netif_stop_queue' was here
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h: In function 'netif_stop_queue':
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:216:19: error: 'struct device' has no member named 'tbusy'
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h: At top level:
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:220:1: error: conflicting types for 'netif_queue_stopped'
    include/linux/netdevice.h:1895:19: note: previous definition of 'netif_queue_stopped' was here
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h: In function 'netif_queue_stopped':
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:222:11: error: 'struct device' has no member named 'tbusy'
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:222:11: error: 'struct device' has no member named 'tbusy'
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h: At top level:
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:226:1: error: conflicting types for 'netif_wake_queue'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIfSetup':
    /tmp/vmware-root/modules/vmnet-only/netif.c:149:7: error: 'struct net_device' has no member named 'init'
    /tmp/vmware-root/modules/vmnet-only/netif.c:150:7: error: 'struct net_device' has no member named 'open'
    /tmp/vmware-root/modules/vmnet-only/netif.c:151:7: error: 'struct net_device' has no member named 'hard_start_xmit'
    /tmp/vmware-root/modules/vmnet-only/netif.c:152:7: error: 'struct net_device' has no member named 'stop'
    /tmp/vmware-root/modules/vmnet-only/netif.c:153:7: error: 'struct net_device' has no member named 'get_stats'
    /tmp/vmware-root/modules/vmnet-only/netif.c:154:7: error: 'struct net_device' has no member named 'set_mac_address'
    /tmp/vmware-root/modules/vmnet-only/netif.c:155:7: error: 'struct net_device' has no member named 'set_multicast_list'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIfNetDeviceToNetIf':
    /tmp/vmware-root/modules/vmnet-only/netif.c:196:14: error: 'struct net_device' has no member named 'priv'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIf_Create':
    /tmp/vmware-root/modules/vmnet-only/netif.c:311:4: error: implicit declaration of function 'compat_alloc_netdev' [-Werror=implicit-function-declaration]
    /tmp/vmware-root/modules/vmnet-only/netif.c:311:8: warning: assignment makes pointer from integer without a cast [enabled by default]
    /tmp/vmware-root/modules/vmnet-only/netif.c:316:7: error: 'struct net_device' has no member named 'priv'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetIfReceive':
    /tmp/vmware-root/modules/vmnet-only/netif.c:397:4: warning: passing argument 1 of 'netif_running' from incompatible pointer type [enabled by default]
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:233:1: note: expected 'struct device *' but argument is of type 'struct net_device *'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetifOpen':
    /tmp/vmware-root/modules/vmnet-only/netif.c:477:4: warning: passing argument 1 of 'netif_start_queue' from incompatible pointer type [enabled by default]
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:208:1: note: expected 'struct device *' but argument is of type 'struct net_device *'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'VNetNetifClose':
    /tmp/vmware-root/modules/vmnet-only/netif.c:525:4: warning: passing argument 1 of 'netif_stop_queue' from incompatible pointer type [enabled by default]
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:214:1: note: expected 'struct device *' but argument is of type 'struct net_device *'
    /tmp/vmware-root/modules/vmnet-only/netif.c: In function 'netif_running':
    /tmp/vmware-root/modules/vmnet-only/compat_netdevice.h:236:1: warning: control reaches end of non-void function [-Wreturn-type]


    make[2]: *** [/tmp/vmware-root/modules/vmnet-only/bridge.o] Error 1
    make[1]: *** [_module_/tmp/vmware-root/modules/vmnet-only] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.41.1-1.fc15.x86_64'
    make: *** [vmnet.ko] Error 2
    make: Leaving directory `/tmp/vmware-root/modules/vmnet-only'
    Unable to install vmnet

  5. #5
    leigh123linux Guest

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    Quote Originally Posted by psyklops
    The same issue here.

    Looks as though VirtualBox is broken too, however an easy fix is available here:
    http://linuxfollies.blogspot.com/201...15-kernel.html

    That is a crap fix for vbox.

    a better fix

    http://forums.fedoraforum.org/showthread.php?t=272465

  6. #6
    Join Date
    Jun 2011
    Posts
    5

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    I had the same problem with vmplayer 4.0.1. Thanks kernel devs for changing APIs so often! I really LOVE having to wrestle with recompiling stuff after minor kernel updates. And people wonder why no one uses Linux on the desktop. Anyhow, enough ranting. Everything was compiling for me except the vmnet module. http://weltall.heliohost.org/wordpre...for-linux-3-2/ had some patches, but they didn't seem to work. So, I manually patched the vmnet sources with the changes that seemed to make sense from those patch files and everything compiled and seems to function...so far. I'm attaching my vmnet.tar file if anyone wants to try it. Just backup your existing /usr/lib/vmware/modules/source/vmnet.tar and put this one in it's place and run the compile. Try it at your own risk though. It works so far for me, but I make no claims that it won't screw anything up
    Attached Files Attached Files

  7. #7
    Join Date
    Oct 2011
    Posts
    40

    Audacious

    I wonder if there no way to grab the latest version of Audacious in Fedora? I'm way behind of archlinux

  8. #8
    Join Date
    Jan 2007
    Posts
    16

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    Thanks. The vmnet.tar worked for me to reconfigure vmware workstation 7.1.5 build-491717.

  9. #9
    Join Date
    Oct 2010
    Posts
    4

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    @jmtw000

    your fixed worked for me as well, Workstation 8.0.1 on 2.6.41.1-1.fc15.i686.PAE. much obliged, sir.

  10. #10
    Join Date
    Apr 2005
    Posts
    344

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    Quote Originally Posted by leigh123linux
    That is a crap fix for vbox.

    a better fix

    http://forums.fedoraforum.org/showthread.php?t=272465
    Thanks Leigh... So true

  11. #11
    Join Date
    Jul 2009
    Location
    Ireland
    Posts
    34

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    Quote Originally Posted by jmtw000
    I had the same problem with vmplayer 4.0.1. Thanks kernel devs for changing APIs so often! I really LOVE having to wrestle with recompiling stuff after minor kernel updates. And people wonder why no one uses Linux on the desktop. Anyhow, enough ranting. Everything was compiling for me except the vmnet module. http://weltall.heliohost.org/wordpre...for-linux-3-2/ had some patches, but they didn't seem to work. So, I manually patched the vmnet sources with the changes that seemed to make sense from those patch files and everything compiled and seems to function...so far. I'm attaching my vmnet.tar file if anyone wants to try it. Just backup your existing /usr/lib/vmware/modules/source/vmnet.tar and put this one in it's place and run the compile. Try it at your own risk though. It works so far for me, but I make no claims that it won't screw anything up
    Thanks a lot for that, worked ok for me as well using VMPlayer 4.0.1 on F15 with kernel 2.6.41.1-1.fc15.x86_64.

  12. #12
    Join Date
    Jan 2007
    Posts
    34

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    Quote Originally Posted by jmtw000
    I had the same problem with vmplayer 4.0.1. Thanks kernel devs for changing APIs so often! I really LOVE having to wrestle with recompiling stuff after minor kernel updates. And people wonder why no one uses Linux on the desktop.
    Agreed, makes me frikking furious.

    Quote Originally Posted by jmtw000
    Everything was compiling for me except the vmnet module.
    What patch did you use, precisely? An official one from vmware? I've found them quite hard to track down and some trial and error is involved in finding the right one. I've been reinstalling and repatching workstation 7.1.4 today after accidentally switching to the 2.6.41 kernel and deciding to see if vmware would work on it. Last attempt was to use vmware2.6.39fixedv3.patch from here http://linux-knowledgebase.com/cms/c...article_id=186 .. it patched ok, but vmnet failed to build. Took your vmnet.tar and swapped it in, the compile finished but I got errors starting services.

    BUT on running vmware, it seems to start up and work just fine, network and all. Pretty mysterious. Trying to start the vmware service manually gives me an error:
    Code:
    [root@myhost neek]# service vmware start
    Starting vmware (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                               [FAILED]
    and systemctl claims the vmware service isn't valid:
    Code:
    [root@uberneek neek]# systemctl status vmware
    Failed to issue method call: Unit name vmware is not valid.
    Seems to be working so far, though. Just another day on the farm...

  13. #13
    Join Date
    Oct 2006
    Posts
    26

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    I have the same problem. After trying your tar, I can now compile error-free but get the following errors:

    Code:
    Job failed. See system logs and 'systemctl status' for details.".
    #systemctl status vmware
    Failed to issue method call: Unit name vmware is not valid.
    Unfortunately, in my case my vmware does not start. The error is :
    Code:
    Version mismatch with vmmon module: expecting 264.0, got 238.0.
    You have an incorrect version of the `vmmon' kernel module.
    Try reinstalling VMware Workstation.
    I'm running VMWare 8 .0.0 on 2.6.41.1-1.fc15.x86_64 #1 SMP Fri Nov 11 21:36:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
    Last edited by aghorash; 23rd November 2011 at 03:22 PM.

  14. #14
    Join Date
    Apr 2005
    Posts
    344

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    Quote Originally Posted by jmtw000
    I had the same problem with vmplayer 4.0.1. Thanks kernel devs for changing APIs so often! I really LOVE having to wrestle with recompiling stuff after minor kernel updates. And people wonder why no one uses Linux on the desktop. Anyhow, enough ranting. Everything was compiling for me except the vmnet module. http://weltall.heliohost.org/wordpre...for-linux-3-2/ had some patches, but they didn't seem to work. So, I manually patched the vmnet sources with the changes that seemed to make sense from those patch files and everything compiled and seems to function...so far. I'm attaching my vmnet.tar file if anyone wants to try it. Just backup your existing /usr/lib/vmware/modules/source/vmnet.tar and put this one in it's place and run the compile. Try it at your own risk though. It works so far for me, but I make no claims that it won't screw anything up
    Thanks... that worked for me too...

  15. #15
    Join Date
    Oct 2007
    Posts
    37

    Re: vmware does not compile with 2.6.41.1-1.fc15.x86_64 kernel

    jmtw000,
    Great job, man! Thanks for packaging this up. It works with VMware Player: 3.1.5 build-491717
    cheers,
    'sodo

Similar Threads

  1. Replies: 5
    Last Post: 17th February 2012, 08:58 PM
  2. kernel-2.6.40.6-0.fc15.x86_64 won't boot.
    By dwightpaige79 in forum Using Fedora
    Replies: 4
    Last Post: 7th November 2011, 09:10 AM
  3. [SOLVED]
    Boot error with new kernel-2.6.40.6-0.fc15.x86_64
    By Doug Hutcheson in forum Using Fedora
    Replies: 8
    Last Post: 8th October 2011, 07:24 AM
  4. Issues using VGA Switcheroo with kernel-2.6.40.4-5.fc15.x86_64
    By elementj in forum Hardware & Laptops
    Replies: 0
    Last Post: 26th September 2011, 08:42 PM
  5. Kernel 2.6.38.4-20.fc15.x86_64
    By VastOne in forum F15 Development
    Replies: 0
    Last Post: 30th April 2011, 05:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •