Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 37
  1. #1
    Join Date
    Nov 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    I've upgraded to Fedora 16 and my sound stop working.

    Code:
    lspci | grep -i audio
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
    Code:
    cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xf9ff8000 irq 45
    Code:
    lsmod | grep snd
    snd_hda_codec_realtek   217968  1 
    snd_hda_intel          19751  6 
    snd_hda_codec          71413  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep               4757  1 snd_hda_codec
    snd_pcm                57940  3 snd_hda_intel,snd_hda_codec
    snd_timer              14625  1 snd_pcm
    snd                    46292  17 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
    soundcore               5027  1 snd
    snd_page_alloc          6147  2 snd_hda_intel,snd_pcm
    Code:
    uname -a
    Linux ekalosha.dev.solartxit.com 3.1.1-1.fc16.i686.PAE #1 SMP Fri Nov 11 22:04:40 UTC 2011 i686 i686 i386 GNU/Linux
    Code:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    when I am trying
    Code:
    cat /dev/urandom > /dev/dsp
    I don't hear any noise.

    Mixer levels are setup properly.

    To modprobe.conf added the following line:
    Code:
    options snd-hda-intel model=alc883-6stack-dig
    Result of alsa-info.sh attached.

    Please advice.
    Attached Files Attached Files

  2. #2
    Join Date
    Aug 2007
    Location
    Novosibirsk
    Age
    52
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    What are the access rights for
    /dev/snd
    ?

    In my case, when I had similar sound loss after F15 to F16 upgrade, adding my user to sound group solved the problem.

  3. #3
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    How do you add your user to the group? Sorry if it's a silly question.

    ---------- Post added at 12:16 PM ---------- Previous post was at 12:09 PM ----------

    Got it. It solved. I added my user to "audio" group and it worked.

  4. #4
    Join Date
    Nov 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Sorry, in my case all is not so simple

    Code:
    ls -l /dev | grep snd
    drwxr-xr-x  3 root audio        240 Nov 15 15:10 snd
    Code:
    id ekalosha
    uid=500(ekalosha) gid=500(ekalosha) groups=500(ekalosha),499(jackuser),502(audio),507(nginx),485(pulse),484(pulse-rt),483(pulse-access),39(video)

  5. #5
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by thereddevil85
    How do you add your user to the group? Sorry if it's a silly question.

    ---------- Post added at 12:16 PM ---------- Previous post was at 12:09 PM ----------

    Got it. It solved. I added my user to "audio" group and it worked.
    Actually it's not resolved. what resolved the issue was giving permission to these files:
    chmod o+rw /dev/snd/*

    but I have to do it everytime I login.

    I have added my user to "audio" group with no luck

  6. #6
    Join Date
    Aug 2007
    Location
    Novosibirsk
    Age
    52
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by thereddevil85
    Actually it's not resolved. what resolved the issue was giving permission to these files:
    chmod o+rw /dev/snd/*

    but I have to do it everytime I login.

    I have added my user to "audio" group with no luck
    What are the rights assigned to /dev/snd/* files? In my case those are

    Code:
    $ ls -al /dev/snd
    total 0
    drwxr-xr-x.  3 root root      260 Nov 18 06:52 .
    drwxr-xr-x. 19 root root     3680 Nov 18 06:57 ..
    drwxr-xr-x.  2 root root       60 Nov 18 06:52 by-path
    crw-rw----+  1 root audio 116,  9 Nov 18 06:52 controlC0
    crw-rw----+  1 root audio 116,  8 Nov 18 06:52 hwC0D0
    crw-rw----+  1 root audio 116,  7 Nov 18 06:52 hwC0D3
    crw-rw----+  1 root audio 116,  6 Nov 18 06:56 pcmC0D0c
    crw-rw----+  1 root audio 116,  5 Nov 18 08:27 pcmC0D0p
    crw-rw----+  1 root audio 116,  4 Nov 18 06:56 pcmC0D1p
    crw-rw----+  1 root audio 116,  3 Nov 18 06:52 pcmC0D2c
    crw-rw----+  1 root audio 116,  2 Nov 18 06:56 pcmC0D3p
    crw-rw----+  1 root audio 116,  1 Nov 18 06:52 seq
    crw-rw----+  1 root audio 116, 33 Nov 18 06:52 timer
    I noted that on a fresh F16 installation no such 'permission tricks' are required, sound works fine.

  7. #7
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by Sagari
    What are the rights assigned to /dev/snd/* files? In my case those are

    Code:
    $ ls -al /dev/snd
    total 0
    drwxr-xr-x.  3 root root      260 Nov 18 06:52 .
    drwxr-xr-x. 19 root root     3680 Nov 18 06:57 ..
    drwxr-xr-x.  2 root root       60 Nov 18 06:52 by-path
    crw-rw----+  1 root audio 116,  9 Nov 18 06:52 controlC0
    crw-rw----+  1 root audio 116,  8 Nov 18 06:52 hwC0D0
    crw-rw----+  1 root audio 116,  7 Nov 18 06:52 hwC0D3
    crw-rw----+  1 root audio 116,  6 Nov 18 06:56 pcmC0D0c
    crw-rw----+  1 root audio 116,  5 Nov 18 08:27 pcmC0D0p
    crw-rw----+  1 root audio 116,  4 Nov 18 06:56 pcmC0D1p
    crw-rw----+  1 root audio 116,  3 Nov 18 06:52 pcmC0D2c
    crw-rw----+  1 root audio 116,  2 Nov 18 06:56 pcmC0D3p
    crw-rw----+  1 root audio 116,  1 Nov 18 06:52 seq
    crw-rw----+  1 root audio 116, 33 Nov 18 06:52 timer
    I noted that on a fresh F16 installation no such 'permission tricks' are required, sound works fine.
    I have the same permissions:

    Code:
    crw-rw----+ 1 root audio 116,  6 Nov 18 10:56 /dev/snd/controlC0
    crw-rw----+ 1 root audio 116,  5 Nov 18 10:56 /dev/snd/hwC0D0
    crw-rw----+ 1 root audio 116,  4 Nov 18 10:56 /dev/snd/hwC0D1
    crw-rw----+ 1 root audio 116,  3 Nov 18 11:29 /dev/snd/pcmC0D0c
    crw-rw----+ 1 root audio 116,  2 Nov 18 11:45 /dev/snd/pcmC0D0p
    crw-rw----+ 1 root audio 116,  1 Nov 18 10:55 /dev/snd/seq
    crw-rw----+ 1 root audio 116, 33 Nov 18 10:55 /dev/snd/timer
    But still the sound doesn't work unless I change the permissions to:

    Code:
    drwxr-xrwx. 2 root root       60 Nov 18 10:56 by-path
    crw-rw-rw-+ 1 root audio 116,  6 Nov 18 10:56 controlC0
    crw-rw-rw-+ 1 root audio 116,  5 Nov 18 10:56 hwC0D0
    crw-rw-rw-+ 1 root audio 116,  4 Nov 18 10:56 hwC0D1
    crw-rw-rw-+ 1 root audio 116,  3 Nov 18 11:52 pcmC0D0c
    crw-rw-rw-+ 1 root audio 116,  2 Nov 18 11:52 pcmC0D0p
    crw-rw-rw-+ 1 root audio 116,  1 Nov 18 10:55 seq
    crw-rw-rw-+ 1 root audio 116, 33 Nov 18 10:55 timer
    Mine is not a fresh installation, I upgraded from F15 to F16.

  8. #8
    Join Date
    Aug 2007
    Location
    Novosibirsk
    Age
    52
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by thereddevil85
    ...

    Mine is not a fresh installation, I upgraded from F15 to F16.
    Alas, I am out of ideas at this moment.
    Hope someone will advice how to handle that. From what I see in the forum, sound absence after F15 to F16 preupgrade isn't a rare event.

  9. #9
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by Sagari
    Alas, I am out of ideas at this moment.
    Hope someone will advice how to handle that. From what I see in the forum, sound absence after F15 to F16 preupgrade isn't a rare event.
    I am hoping that myself Thanks aton for all your assistance, really appreciate it.

  10. #10
    Join Date
    May 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Mixer levels are setup properly.

    To modprobe.conf added the following line:
    Code:

    options snd-hda-intel model=alc883-6stack-dig

    Result of alsa-info.sh attached.

    I had a similar issue with having no sound after upgrading to F16. Everything looked to be configured correctly yet I was getting no sound.

    My sound hardware is slightly different and older on a Toshiba Satellite laptop:

    Code:
    [root@arrow ~]# lspci -v |grep Audio
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    I had to create a file called "/etc/modprobe.d/snd_hda_intel.conf" and add the folowing to get sound working:

    Code:
    options snd_hda_intel model=generic
    I hope it helps someone get the sound working after F16 upgrade, since it drove me crazy for a few days with no sound.

  11. #11
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by viduliya
    I had a similar issue with having no sound after upgrading to F16. Everything looked to be configured correctly yet I was getting no sound.

    My sound hardware is slightly different and older on a Toshiba Satellite laptop:

    Code:
    [root@arrow ~]# lspci -v |grep Audio
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    I had to create a file called "/etc/modprobe.d/snd_hda_intel.conf" and add the folowing to get sound working:

    Code:
    options snd_hda_intel model=generic
    I hope it helps someone get the sound working after F16 upgrade, since it drove me crazy for a few days with no sound.
    This is the first thing that I am gonna try after going home. Hope this works!

  12. #12
    Join Date
    Aug 2009
    Posts
    8,486
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    interesting..

    You said it doesn't work if you add your user to the audio group with the default permissions that gives members of the audio group rw permissions, but if you extend those permissions to other users, then it works?

    the default settings on those files is owned by root user and audio group. So any member of the audio group should have rw access with the default permissions.

    what do you get from the output of the groups command run from your user, not root?

    Code:
    groups

  13. #13
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by DBelton
    interesting..

    You said it doesn't work if you add your user to the audio group with the default permissions that gives members of the audio group rw permissions, but if you extend those permissions to other users, then it works?

    the default settings on those files is owned by root user and audio group. So any member of the audio group should have rw access with the default permissions.

    what do you get from the output of the groups command run from your user, not root?

    Code:
    groups
    This is what i get:-

    Code:
    [Shaolin@Grid12 ~]$ groups
    Shaolin daemon disk lp wheel cdrom mail games mysql video apache ftp audio asterisk vboxusers

  14. #14
    Join Date
    Aug 2009
    Posts
    8,486
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    It definitely is showing you as a member of the audio group.

    I am wondering if this bug may be related to them changing the default user numbering in Fedora 16. In F15 and below, default user numbering started at 500, and in F16 they changed it to 1000. On a fresh install, your user would be number 1000, but on an upgrade, it probably keeps it at 500

    Or if it did update your user number to 1000, and you are using the same /home the old files in /home would be set to user 500.

    You could find out what number is assigned to your user with the id command

    Code:
    [Me@tower11 ~]$ id
    uid=1000(Me) gid=1000(Me) groups=1000(Me),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

  15. #15
    Join Date
    Nov 2011
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 16. HDA Intel(ALC833). Sound stop working after upgrade.

    Quote Originally Posted by viduliya
    I had a similar issue with having no sound after upgrading to F16. Everything looked to be configured correctly yet I was getting no sound.

    My sound hardware is slightly different and older on a Toshiba Satellite laptop:

    Code:
    [root@arrow ~]# lspci -v |grep Audio
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    I had to create a file called "/etc/modprobe.d/snd_hda_intel.conf" and add the folowing to get sound working:

    Code:
    options snd_hda_intel model=generic
    I hope it helps someone get the sound working after F16 upgrade, since it drove me crazy for a few days with no sound.
    This didn't work

    ---------- Post added at 09:31 PM ---------- Previous post was at 09:30 PM ----------

    Quote Originally Posted by DBelton
    It definitely is showing you as a member of the audio group.

    I am wondering if this bug may be related to them changing the default user numbering in Fedora 16. In F15 and below, default user numbering started at 500, and in F16 they changed it to 1000. On a fresh install, your user would be number 1000, but on an upgrade, it probably keeps it at 500

    Or if it did update your user number to 1000, and you are using the same /home the old files in /home would be set to user 500.

    You could find out what number is assigned to your user with the id command

    Code:
    [Me@tower11 ~]$ id
    uid=1000(Me) gid=1000(Me) groups=1000(Me),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
    You are right, my numbering still seems to be 500, here is the output:
    Code:
    [Shaolin@Grid12 ~]$ id
    uid=500(Shaolin) gid=500(Shaolin) groups=500(Shaolin),2(daemon),6(disk),7(lp),10(wheel),11(cdrom),12(mail),20(games),27(mysql),39(video),48(apache),50(ftp),63(audio),491(asterisk),501(vboxusers) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c102


    ---------- Post added at 09:52 PM ---------- Previous post was at 09:31 PM ----------

    @DBelton: What do I do about it now? Any workaround?

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. Sound not working on Fedora 11, HDA Intel
    By mmattax in forum Hardware & Laptops
    Replies: 1
    Last Post: 8th July 2009, 12:13 AM
  2. Sound stop working on fedora 9
    By netphilic in forum Hardware & Laptops
    Replies: 10
    Last Post: 2nd March 2009, 06:40 PM
  3. Kernal upgrade to 2.6.22-4 causes ndiswrapper to stop working
    By bike_head in forum Hardware & Laptops
    Replies: 1
    Last Post: 29th August 2007, 01:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •