FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2008
    Posts
    28

    using EPEL in Fedora 16

    Is there a way to use EPEL in Fedora 16?

    Following the instructions here: http://fedoraproject.org/wiki/EPEL/F..._repository.3F

    I run this command
    Code:
    su -c 'rpm -Uvh http://download.fedora.redhat.com/pub/epel/6/i386/epel-release-6-5.noarch.rpm'
    But I get the result
    Code:
    error: Failed dependencies:
    	fedora-release conflicts with epel-release-6-5.noarch
    Not sure what to do here...

  2. #2
    Join Date
    Nov 2011
    Posts
    1

    Re: using EPEL in Fedora 16

    This seems to be an issue with every new release of Fedora. I googled for "fedora-release conflicts with epel-release" and found this page:
    http://www.geekdevs.com/2011/09/solv...-on-fedora-15/
    ...which is specific to Fedora 15, but those directions worked for my instance of Fedora 16. All the rpm does, apparently, is write some conf files to /etc/yum.repos.d/ and import a GPG key. The linked page shows you how to do this manually.

  3. #3
    leigh123linux Guest

    Re: using EPEL in Fedora 16

    Why do you want EPEL? , theres nothing additional to the fedora repos there.

  4. #4
    Join Date
    Dec 2008
    Posts
    28

    Re: using EPEL in Fedora 16

    h5py is not in the fedora repos. I tried downloading and installing the h5py package from EPEL but it has dependencies on older versions of stuff in the fedora repo (don't remember which). So I just built from source. Not my ideal solution but it works.

  5. #5
    Join Date
    Dec 2006
    Location
    Pennsylvania
    Posts
    382

    Re: using EPEL in Fedora 16

    According to rpm.pbone.net, h5py is only available for RHEL 6 and Mandrivia. Chances are, it's pulling the RHEL version, so the libraries for Fedora 16 are too new. Yeah yeah, the wonders of Linux backwards compatibility.....

    It looks likes it needs Python 2.6 specifically for some odd reason.

  6. #6
    Join Date
    Mar 2009
    Location
    Broomfield, CO
    Posts
    438

    Re: using EPEL in Fedora 16

    EPEL is add on packages for RHEL and clones. It will not work at all on Fedora. We specifically added the conflicts there to prevent people messing up their machines.

    You can always file a bug asking for Fedora support...

Similar Threads

  1. Announcing EPEL 6 - Kevin Fenzi
    By bob in forum News
    Replies: 0
    Last Post: 20th January 2011, 06:34 PM
  2. Using EPEL Repo on Fedora: Problems
    By tc@cs in forum Using Fedora
    Replies: 4
    Last Post: 29th January 2010, 03:11 PM
  3. How to enable EPEL on CentOS 5.4
    By bendib in forum Linux Chat
    Replies: 6
    Last Post: 22nd November 2009, 01:46 AM
  4. EPEL Problem
    By Metropolis in forum Linux Chat
    Replies: 11
    Last Post: 9th September 2009, 06:43 PM
  5. Problem with epel.repo
    By TommyV in forum Using Fedora
    Replies: 1
    Last Post: 29th June 2009, 10:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •