Edit xorg.config file for 1680x1050 Monitor
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Edit xorg.config file for 1680x1050 Monitor

    This is my old xorg.conf file in ubuntu and now it is not working in Fedora 15. Does anyone know how to get this to work? Thanks!

    Section "Device"
    Identifier "Configured Video Device"
    Option "ModeDebug" "True"
    Driver "intel"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
    Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
    EndSection #made by cvt

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    SubSection "Display"
    Depth 24
    Modes "1680x1050_60"
    EndSubSection
    EndSection

  2. #2
    pete_1967 Guest

    Re: Edit xorg.config file for 1680x1050 Monitor

    You shouldn't need xorg.conf for basic sceen setup. Try renaming it to something else and restart your x-server (logging out and back in is usually sufficient) and see if the monitor is correctly detected and configured. Only if it isn't, start worrying about manual configuration.

  3. #3
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    I tried that and it still is not working. Any other ideas?

  4. #4
    Join Date
    May 2010
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    What is your monitor setting?

  5. #5
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    Quote Originally Posted by mrdaler
    What is your monitor setting?
    Everything is either on auto or is standard.

  6. #6
    Join Date
    May 2010
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    This probably means that you have only one mode which is less than 1608x1050. This is not a square monitor is it?

    One other question: Was that xorg.conf file from your older linux? The reason why I say that is that you don't have quotation marks with the other modes. Or did you make this file?

    One other thing. 1608x1050 would be wrong. It should be "1600x1050". Try this.

    Dale

  7. #7
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    Quote Originally Posted by mrdaler
    This probably means that you have only one mode which is less than 1608x1050. This is not a square monitor is it?

    One other question: Was that xorg.conf file from your older linux? The reason why I say that is that you don't have quotation marks with the other modes. Or did you make this file?

    One other thing. 1608x1050 would be wrong. It should be "1600x1050". Try this.

    Dale
    It is a widescreen 1680x1050 monitor. The xorg.conf file I first stated was from my old Ubuntu box written for me by someone on ubuntuforms.com.

  8. #8
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    so what errors are reported in your Xorg.x.log file?

  9. #9
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    Quote Originally Posted by jpollard
    so what errors are reported in your Xorg.x.log file?
    There is no log because I have to delete my xorg conf file in order to have the monitor work.

  10. #10
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    There is always a log.

    Just look in /var/log/Xorg.0.log. There should even be multiple files out there (Xorg.1.log, Xorg.2.log ...)

  11. #11
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Re: Edit xorg.config file for 1680x1050 Monitor

    Quote Originally Posted by jpollard
    There is always a log.

    Just look in /var/log/Xorg.0.log. There should even be multiple files out there (Xorg.1.log, Xorg.2.log ...)
    This is my Xorg.1.log (There are 4 others):

    [ 31.149]
    X.Org X Server 1.10.4
    Release Date: 2011-08-19
    [ 31.149] X Protocol Version 11, Revision 0
    [ 31.150] Build Operating System: x86-16 2.6.32-131.2.1.el6.x86_64
    [ 31.150] Current Operating System: Linux DOMINICK-BETA 2.6.40.6-0.fc15.i686 #1 SMP Tue Oct 4 00:51:19 UTC 2011 i686
    [ 31.150] Kernel command line: ro root=/dev/mapper/vg_dominickbeta-lv_root rd_LUKS_UUID=luks-b02b0f4a-f324-4c37-8e6c-fe6b2d86569a rd_LVM_LV=vg_dominickbeta/lv_root rd_LVM_LV=vg_dominickbeta/lv_swap rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us nomodeset rhgb quiet
    [ 31.150] Build Date: 07 September 2011 04:13:44PM
    [ 31.150] Build ID: xorg-x11-server 1.10.4-1.fc15
    [ 31.150] Current version of pixman: 0.20.2
    [ 31.150] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 31.150] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 31.150] (==) Log file: "/var/log/Xorg.1.log", Time: Sat Oct 15 18:58:38 2011
    [ 31.152] (==) Using config file: "/etc/X11/xorg.conf"
    [ 31.152] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 31.152] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [ 31.153] (==) No Layout section. Using the first Screen section.
    [ 31.153] (**) |-->Screen "Screen[0]" (0)
    [ 31.153] (**) | |-->Monitor "VGA-0"
    [ 31.154] (==) No device specified for screen "Screen[0]".
    Using the first device section listed.
    [ 31.154] (**) | |-->Device "Configured Video Device"
    [ 31.154] (==) Automatically adding devices
    [ 31.154] (==) Automatically enabling devices
    [ 31.154] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
    [ 31.154] (==) ModulePath set to "/usr/lib/xorg/modules"
    [ 31.154] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 31.154] (II) Loader magic: 0x8229f20
    [ 31.154] (II) Module ABI versions:
    [ 31.154] X.Org ANSI C Emulation: 0.4
    [ 31.154] X.Org Video Driver: 10.0
    [ 31.154] X.Org XInput driver : 12.2
    [ 31.154] X.Org Server Extension : 5.0
    [ 31.156] (--) PCI:*(0:0:2:0) 8086:2972:17aa:1015 rev 2, Mem @ 0xd0000000/1048576, 0xc0000000/268435456, I/O @ 0x000018c0/8, BIOS @ 0x????????/131072
    [ 31.157] (II) LoadModule: "extmod"
    [ 31.159] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [ 31.159] (II) Module extmod: vendor="X.Org Foundation"
    [ 31.159] compiled for 1.10.4, module version = 1.0.0
    [ 31.159] Module class: X.Org Server Extension
    [ 31.160] ABI class: X.Org Server Extension, version 5.0
    [ 31.160] (II) Loading extension SELinux
    [ 31.160] (II) Loading extension MIT-SCREEN-SAVER
    [ 31.160] (II) Loading extension XFree86-VidModeExtension
    [ 31.160] (II) Loading extension XFree86-DGA
    [ 31.160] (II) Loading extension DPMS
    [ 31.160] (II) Loading extension XVideo
    [ 31.160] (II) Loading extension XVideo-MotionCompensation
    [ 31.160] (II) Loading extension X-Resource
    [ 31.160] (II) LoadModule: "dbe"
    [ 31.161] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    [ 31.161] (II) Module dbe: vendor="X.Org Foundation"
    [ 31.161] compiled for 1.10.4, module version = 1.0.0
    [ 31.161] Module class: X.Org Server Extension
    [ 31.161] ABI class: X.Org Server Extension, version 5.0
    [ 31.161] (II) Loading extension DOUBLE-BUFFER
    [ 31.161] (II) LoadModule: "glx"
    [ 31.162] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [ 31.163] (II) Module glx: vendor="X.Org Foundation"
    [ 31.163] compiled for 1.10.4, module version = 1.0.0
    [ 31.163] ABI class: X.Org Server Extension, version 5.0
    [ 31.163] (==) AIGLX enabled
    [ 31.163] (II) Loading extension GLX
    [ 31.163] (II) LoadModule: "record"
    [ 31.164] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    [ 31.164] (II) Module record: vendor="X.Org Foundation"
    [ 31.164] compiled for 1.10.4, module version = 1.13.0
    [ 31.164] Module class: X.Org Server Extension
    [ 31.164] ABI class: X.Org Server Extension, version 5.0
    [ 31.164] (II) Loading extension RECORD
    [ 31.165] (II) LoadModule: "dri"
    [ 31.165] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    [ 31.166] (II) Module dri: vendor="X.Org Foundation"
    [ 31.166] compiled for 1.10.4, module version = 1.0.0
    [ 31.166] ABI class: X.Org Server Extension, version 5.0
    [ 31.166] (II) Loading extension XFree86-DRI
    [ 31.166] (II) LoadModule: "dri2"
    [ 31.167] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [ 31.167] (II) Module dri2: vendor="X.Org Foundation"
    [ 31.167] compiled for 1.10.4, module version = 1.2.0
    [ 31.168] ABI class: X.Org Server Extension, version 5.0
    [ 31.168] (II) Loading extension DRI2
    [ 31.168] (II) LoadModule: "intel"
    [ 31.168] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [ 31.169] (II) Module intel: vendor="X.Org Foundation"
    [ 31.169] compiled for 1.10.2, module version = 2.15.0
    [ 31.169] Module class: X.Org Video Driver
    [ 31.169] ABI class: X.Org Video Driver, version 10.0
    [ 31.169] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
    i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
    E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
    965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
    4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
    Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
    Sandybridge, Sandybridge
    [ 31.172] (--) using VT number 2

    [ 31.214] (EE) No devices detected.
    [ 31.214]
    Fatal server error:
    [ 31.214] no screens found
    [ 31.214]
    Please consult the Fedora Project support
    at http://wiki.x.org
    for help.
    [ 31.214] Please also check the log file at "/var/log/Xorg.1.log" for additional information.
    [ 31.214]

  12. #12
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Re: Edit xorg.config file for 1680x1050 Monitor

    I ran the following commands:

    Code:
    Xorg :1 -configure
    and

    Code:
    cp /root/xorg.conf.new /etc/X11/xorg.conf
    which created a template xorg.conf file (below).

    Code:
    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        Screen      2  "Screen2" RightOf "Screen1"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "catalogue:/etc/X11/fontpath.d"
        FontPath     "built-ins"
    EndSection
    
    Section "Module"
        Load  "record"
        Load  "dri"
        Load  "dbe"
        Load  "extmod"
        Load  "dri2"
        Load  "glx"
    EndSection
    
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
    EndSection
    
    Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option        "Protocol" "auto"
        Option        "Device" "/dev/input/mice"
        Option        "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
    EndSection
    
    Section "Monitor"
        Identifier   "Monitor1"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
    EndSection
    
    Section "Monitor"
        Identifier   "Monitor2"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "AccelMethod"            # [<str>]
            #Option     "DRI"                    # [<bool>]
            #Option     "ColorKey"               # <i>
            #Option     "VideoKey"               # <i>
            #Option     "FallbackDebug"          # [<bool>]
            #Option     "Tiling"                 # [<bool>]
            #Option     "LinearFramebuffer"      # [<bool>]
            #Option     "Shadow"                 # [<bool>]
            #Option     "SwapbuffersWait"        # [<bool>]
            #Option     "XvMC"                   # [<bool>]
            #Option     "XvPreferOverlay"        # [<bool>]
            #Option     "DebugFlushBatches"      # [<bool>]
            #Option     "DebugFlushCaches"       # [<bool>]
            #Option     "DebugWait"              # [<bool>]
            #Option     "HotPlug"                # [<bool>]
            #Option     "RelaxedFencing"         # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        BusID       "PCI:0:2:0"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "ShadowFB"               # [<bool>]
            #Option     "Rotate"                 # <str>
            #Option     "fbdev"                  # <str>
            #Option     "debug"                  # [<bool>]
        Identifier  "Card1"
        Driver      "fbdev"
        BusID       "PCI:0:2:0"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "ShadowFB"               # [<bool>]
            #Option     "DefaultRefresh"         # [<bool>]
            #Option     "ModeSetClearScreen"     # [<bool>]
        Identifier  "Card2"
        Driver      "vesa"
        BusID       "PCI:0:2:0"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier "Screen1"
        Device     "Card1"
        Monitor    "Monitor1"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier "Screen2"
        Device     "Card2"
        Monitor    "Monitor2"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    Can you please inform me on how to edit this for my 1680x1050 monitor? Thanks for the help!

  13. #13
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    Looks like it can't find your video card as your configuration files specify -
    PCI:0:2:0, doesn't look like a video card.

    I think your best bet is to delete /etc/X11/xorg.conf and see if it works.

  14. #14
    Join Date
    Oct 2011
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    Quote Originally Posted by jpollard
    Looks like it can't find your video card as your configuration files specify -
    PCI:0:2:0, doesn't look like a video card.

    I think your best bet is to delete /etc/X11/xorg.conf and see if it works.
    When I delete it, it works, it just have the wrong resolution and I'm back in the same place.

  15. #15
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Edit xorg.config file for 1680x1050 Monitor

    No, you aren't in the same place.

    You have a working device. What remains is to identify what resolutions have been identified, and why it can't identify the resolution you want.

    What are the contents of the new log file?

Page 1 of 2 1 2 LastLast

Similar Threads

  1. edit sudo config file
    By mohammedessam in forum Using Fedora
    Replies: 3
    Last Post: 3rd March 2011, 07:34 PM
  2. F10 ATI Redeon X1650 Pro Xorg Config File
    By Harley51 in forum Hardware & Laptops
    Replies: 3
    Last Post: 28th November 2008, 10:07 AM
  3. Can't get 1680x1050 monitor resolution
    By Jugmun in forum Hardware & Laptops
    Replies: 3
    Last Post: 11th March 2008, 02:26 AM
  4. How do I log in as root and edit xorg file?
    By braveerudite in forum Security and Privacy
    Replies: 21
    Last Post: 1st July 2005, 01:06 AM
  5. i can't edit a file! pico / edit bad commands?
    By virtuoso in forum Using Fedora
    Replies: 8
    Last Post: 9th November 2004, 09:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •