FC3 with i815 = corruption
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 12 of 12
  1. #1
    Join Date
    Oct 2004
    Location
    Minneapolis, MN USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    FC3 with i815 = corruption

    Heyo.

    I'm running on a Dell Inspiron 2500. X worked fine with FC2, FC1, Redhat 9 (and 8...).

    Running it now on my 815 chipset (Intel) I get corruption of video galore. system-config-display is a clear Display Settings dialog on a total mess of a background. If I use my previous xorg.conf from FC2, I can log in, get my background, and then things like gnome-terminal don't display a full white window, but only in the areas I type, etc.

    Any ideas?

    M0b

  2. #2
    Join Date
    Mar 2004
    Location
    Westland, Michigan
    Age
    46
    Posts
    2,317
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    m0bilitee,

    Just an FYI, I have a Dell GX110 desktop with Intel i810 chipset and am having major X problems with FC3 as well. It ran fine on FC1 and FC2, but so far, FC3 is a no-go.

    My menus are transparent, screen not redrawing, buttons not availble until mouse clicks over, etc. I have tried both gnome and KDE.

    I have multiple machines doing the same thing, so I know this isn't a video card that is shot.

    I have run both setup and system-config-display. I have tried all screen resolutions and color depth and results are the same.

    I'd really like to get playing with this new version, but unless I can get this video problem fixed, I am SOL.

  3. #3
    Join Date
    Mar 2004
    Location
    Westland, Michigan
    Age
    46
    Posts
    2,317
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    somebody responded in another post that this is a kernel problem with 2.6.9 kernel shipping with FC3. Looks like we must wait for kernel update. I have found some support evidence of frame buffer problems on 2.6.9 with intel video.

  4. #4
    Join Date
    Mar 2004
    Location
    Westland, Michigan
    Age
    46
    Posts
    2,317
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My coworker discovered the following workaround which might help most of you until a kernel update is out.

    In /etc/X11/xorg.conf, make sure your video section includes
    Options "noaccel"

    See my section below: This worked for me

    Section "Device"
    Identifier "Videocard0"
    Driver "i810"
    VendorName "Videocard vendor"
    BoardName "Intel 810"
    Option "noaccel"
    EndSection

  5. #5
    Join Date
    Oct 2004
    Location
    Minneapolis, MN USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pparks1
    m0bilitee,

    My menus are transparent, screen not redrawing, buttons not availble until mouse clicks over, etc. I have tried both gnome and KDE.

    Bingo. You're describing my plight as well.

    I have a FIC cube machine at home running FC3, it's got an 845 chipset with the i810 driver, and it works fine, so there is a subtle difference.

  6. #6
    Join Date
    Oct 2004
    Location
    Minneapolis, MN USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pparks1
    My coworker discovered the following workaround which might help most of you until a kernel update is out.

    In /etc/X11/xorg.conf, make sure your video section includes
    Options "noaccel"
    That worked great for me, no acceleration stinks as I tend to run mplayer but we'll make progress.

    Thanks!

  7. #7
    Join Date
    Oct 2004
    Location
    Minneapolis, MN USA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In case anyone reads this, the kernel released recently 2.6.9-1.678_FC3 along with the recent Xorg patches don't improve this at all. Option "noaccel" is still required.

  8. #8
    Join Date
    Mar 2004
    Location
    Westland, Michigan
    Age
    46
    Posts
    2,317
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Everybody,

    New version of the kernel which works without the noaccel trick

    kernel-2.6.9-1.681_FC3

  9. #9
    x3r0 Guest
    Quote Originally Posted by pparks1
    Everybody,

    New version of the kernel which works without the noaccel trick

    kernel-2.6.9-1.681_FC3
    erm yeah i tried that it dident work any other ideal i still needed the noaccel to get it to work right

  10. #10
    Codfather Guest
    New kernal, 2.6.9-1.681_FC3, doesn't fix my system either.

  11. #11
    heimdall Guest
    It is a known bug with the i810 card driver and xorg:
    https://bugzilla.redhat.com/bugzilla....cgi?id=132267

    Try this instead of the noaccel option:
    I added this to /etc/X11/xorg.conf in the Section "Screen":

    Option "XaaNoScanlineCPUToScreenColorExpand" "true"
    Option "XaaNoSolidFillRect" "true"
    Option "XaaNoScreenToScreenCopy" "true"
    Option "XaaNoMono8x8PatternFillRect" "true"

    Worked OK for me.

  12. #12
    tshark7 Guest
    I have the same problem with my Dimension L700cx. On my dell inspiron laptop, I just needed a bios update to get the screen fixed, but I seem to remember that it might have been a i845 card. We'll see if this helps with my desktop. It's really hard to have to mouse over everything to see what I'm doing.

Similar Threads

  1. DVD-RAM corruption problem
    By DavidMcCann in forum Using Fedora
    Replies: 0
    Last Post: 30th August 2008, 10:44 PM
  2. Memory Corruption
    By operationbinary in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 11th November 2007, 07:43 PM
  3. Intel i815 not working on FC3
    By rmmcgr in forum Hardware & Laptops
    Replies: 7
    Last Post: 6th December 2004, 09:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •