"Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Join Date
    Aug 2011
    Posts
    8

    Unhappy "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Hi there! ^___^

    Short history, my boss ran some updates and afterwards the machine wouldn't get past the splash screen. When I did an 'esc' to watch the bootup process, I noticed it could not find the nvidia.ko drivers.
    Following Leigh123's guide and doing a whole lot of work around, I finally got that error to disappear, but instead of working, it was replaced with...

    Code:
    Enabling the nvidia driver: /etc/rc.d/init.d/functions line 530 3130 Segmentation fault "$@" [FAILED]
    It still wont boot up.

    So then I tried doing a 'nvidia-config-display disable' and 'enable' and I got a "Segmentation fault" error.

    So then I tried to follow some other guide that mentioned...
    mv /etc/X11/xorg.conf /etc/x11/xorg.conf.broken which fixed most of their problems..
    However, when I type that in on my F2 Kernal (Sorry, I'm a Linux noob, I falter in the language ) it says no such file exists...

    I'm not sure what else to do. I have a Nvidia Corporation G86 Quadro NVS 290. Any help would be greatly appreciated!

  2. #2
    leigh123linux Guest

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Moved to EOL (End Of Life) Versions

    Try
    Code:
    su
    rm -f  /etc/X11/xorg.conf
    nvidia-config-display disable
    nvidia-config-display enable

  3. #3
    Join Date
    Aug 2011
    Posts
    8

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Still get 'Segmentation Fault' error. After I did the 'disable' and 'enable' I did a rm -i /etc/x11/xorg.conf and no file or directory was found, does 'enable' and disable rebuild that file? And if so... that's strange that the file does not exist >_< ...

  4. #4
    leigh123linux Guest

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Post


    Code:
    rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf

  5. #5
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,811

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Quote Originally Posted by ethabelle
    I did a rm -i /etc/x11/xorg.conf and no file or directory was found,....
    Yeah, that's because it's /etc/X11/xorg.conf, with a capital X.

  6. #6
    Join Date
    Aug 2011
    Posts
    8

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Code:
    kmod-nvidia-2.6.33.3-85.fe13.x86_64-195.36.24-1.fe13.5.x86_64
    kmod-nvidia-2.6.34.7-61.fe13.x86_64-260.19.21-1.fc13.x86_64
    nvidia-settings-1.0-9.fe13.x86_64
    nvidia-xconfig-1.0-6.fe13.x86_64
    xorg-x11-drv-nvidia-260.19.36-1.fe13.x86_64
    xorg-x11-drv-nvidia-libs-260.19.36-1.fe13.x86_64
    2.6.33.3-85.fe13.x86_64
    
    nouveau               381523    1
    ttm                        53215      1 nouveau
    drm_kms_helper  23936      1 nouveau
    drm                       169073    3 nouveau, ttm, drm_kms_helper
    i2c_algo_bit           4781        1 nouveau
    video                    20741      1 nouveau
    i2c_core                24427     5 i2c_i801, nouveau, drm_kms_helper, drm, i2c_algo_bit
    
    cat: /etc/x11/xorg.conf: no such file or directory
    Thanks for your help by the way ^_^!

  7. #7
    leigh123linux Guest

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Try this ( don't alter any syntax this time!!! )

    Code:
    cat: /etc/x11/xorg.conf: no such file or directory
    Run to get rid of nouveau.
    Code:
    su -
    sed -i '/root=/s|$| rdblacklist=nouveau nouveau.modeset=0|' /boot/grub/grub.conf 
    mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname   -r)-nouveau.img 
    dracut /boot/initramfs-$(uname -r).img $(uname -r)
    reboot

  8. #8
    Join Date
    Aug 2011
    Posts
    8

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Sorry, I'm having to type this in by hand... that X didn't look capitalized !
    There was a lot, I assume device information was what was needed...

    Code:
    Section "Device"
    
    Identifier
    "Videocard0"
    Driver
    "nvidia"
    End Section Section "Device"
    Identifier
    "Device0"
    Driver
    "nvidia"
    VendorName
    NVIDIA Corporation
    Boardname
    Quadro NVS 290
    BusID
    PCI:1:0:0:0
    Screem
    0
    End Section Section "Device"
    Identifier
    "Device1"
    Driver
    "nvidia"
    VendorName
    NVIDIA Corporation
    Boardname
    Quadro NVS 290
    BusID
    PCI:1:0:0:0
    Screem
    1
    End Section Section "Device"
    Identifier
    "Device2"
    Driver
    "nvidia"
    VendorName
    NVIDIA Corporation
    Boardname
    Quadro NVS 290
    BusID
    PCI:2:0:0:0
    Screem
    0
    End Section Section "Device"
    Identifier
    "Device3"
    Driver
    "nvidia"
    VendorName
    NVIDIA Corporation
    Boardname
    Quadro NVS 290
    BusID
    PCI:2:0:0:0
    Screem
    1
    End Section
    Is that the correct info you wanted? The other info was about Screens...

    I also ran your latter command. The only thing that changed was I now get the same error, but a different line (1005)...

    Code:
    Enabling the nvidia driver: /etc/rc.d/init.d/functions line 1005 Segmentation fault "$@" [FAILED]

  9. #9
    leigh123linux Guest

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Try

    Code:
    su 
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old 
    nvidia-config-display disable 
    nvidia-config-display enable

  10. #10
    Join Date
    Aug 2011
    Posts
    8

    Re: "Segmentation Fault" for Nvidia Quadro Driver, Fedora13 unable to boot.

    Ok. So I got really upset, and did a yum remove of all the drivers at yum list install | nvidia ...
    Then I redid akmod.
    Plus all the steps you listed.

    It's fine and dandy now.

    Thanks for all your help!

Similar Threads

  1. Nvidia driver segmentation fault at boot
    By Kakao in forum Using Fedora
    Replies: 5
    Last Post: 11th October 2010, 08:58 PM
  2. segmentation fault in "locale -a"
    By rshartog in forum Using Fedora
    Replies: 3
    Last Post: 1st February 2009, 03:15 PM
  3. Replies: 11
    Last Post: 27th November 2007, 04:47 AM
  4. metacity "segmentation fault"
    By ekimd in forum Using Fedora
    Replies: 0
    Last Post: 13th April 2006, 05:42 AM
  5. "Segmentation Fault" error preventing boot
    By UED77 in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 22nd September 2005, 08:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •