F15 LiveCD on a USB stick won't boot on a MacBook Pro 8,2
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    F15 LiveCD on a USB stick won't boot on a MacBook Pro 8,2

    Hi,

    I have a brand spanking new MacBook Pro 2011 15". The only hardware peculiarities are that it's got the slightly fancier Radeon HD 6750M graphics chip, the high-res screen, and an OCZ Vertex 3 SSD i installed myself.

    I downloaded a LiveCD image (Fedora-15-x86_64-Live-Desktop.iso), and put it on a USB stick using livecd-iso-to-disk --mactel --format on another machine which is already running Fedora. I put the stick in the Mac, option-rebooted, and picked the USB stick in the Mac's boot menu.

    The boot process starts - the boot loader tells me it's about to start Fedora, and i can hit a key to go into its menu. So far so good. But when the countdown hits zero, or if i enter the menu and choose an option, everything stops. There's no sign of Linux loading.

    The fact that the boot loader comes up and offers to boot Fedora tells me that i have successfully navigated the maze of creating a bootable disk. But it seems that the kernel that the loader is trying to load is not at all happy. And yet, there are reports on this forum of people successfully installing Fedora 15 on MacBook Pro 8,2s (well, with minor hitches - they wouldn't be on this forum if it had gone flawlessly!).

    I have no idea how to approach this problem. The fact that nothing at all happens gives me no clues as to what's going wrong. I don't have any sort of logging or diagnostic output.

    Any thoughts on what might be the problem, or how i can approach this?

    I'm going to try burning a CD from the ISO, to see if that works any better.

    ---------- Post added at 02:04 PM ---------- Previous post was at 12:40 PM ----------

    I tried burning a CD, and that was a little more successful. The disc boots, and i get quite a bit of Fedora loading action, but then it drops out to a debug shell with little explanation. The last thing in the output of dmesg is:

    Code:
    dracut Warning: No root device "live:/dev/disk/by-label/Fedora-15-x86_64-Live-Desktop.is"
    That looks a bit like a path is a character too long for some sort of limit - something has sliced an 'o' off the end of that path somewhere along the line. I tried renaming the ISO file to something shorter and burning it again (a pretty desperate move!), but the result was the same.

    So, what is this dracut thing, and why is it messing with me?

  2. #2
    Join Date
    Aug 2011
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F15 LiveCD on a USB stick won't boot on a MacBook Pro 8,2

    I hope you've already solved this problem, but if not check out the link below.

    http://forums.fedoraforum.org/showpo...97&postcount=7

Similar Threads

  1. Live CD failed to run on MacBook, now MacBook won't boot
    By noname in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 4th November 2009, 04:19 PM
  2. howto enable/manage persistence--livecd on usb stick
    By fredex in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 15th June 2009, 09:24 PM
  3. Replies: 1
    Last Post: 12th July 2008, 08:30 AM
  4. Corrupt persistence layer in F9 LiveCD on usb stick
    By sideways in forum Using Fedora
    Replies: 7
    Last Post: 25th June 2008, 10:41 PM
  5. 5 STARS! Fedora 7 i386 livecd - how to boot from livecd - need SERIOUS help please!
    By newfedorahat in forum Installation, Upgrades and Live Media
    Replies: 14
    Last Post: 25th June 2007, 07:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •