ATI Radeon Xpress 1250
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Nov 2008
    Location
    Southend on Sea, Essex, UK
    Posts
    124
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    ATI Radeon Xpress 1250

    I have a Samsung R20 laptop with other Linux distros this graphics card is detected fine and there are no anomalies. However after installing Fedora 15 64bit I get this...



    Now I can get a perfectly clear screen if I fall back, but I don't want to miss out on all those lovely desktop effects.

    You can see the words are not displaying properly.

    What do I need to do to install or update this barely working graphics card?

    I'm assuming the standard procedure using Leigh's ATI method for installing drivers will not work, isn't my graphics card under the HD versions of Radeon?

    Thanks for any help.
    "We are what we think.
    All that we are arises with our thoughts."

    Buddha in The Dhammapada.

    ChrisC

  2. #2
    Join Date
    Sep 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ATI Radeon Xpress 1250

    I have EXACTLY the same laptop/gpu/problems check out my screenshot



    I have tried all sorts of things to get it working but no joy.

    ANYONE know what to do to fix this?

    Cheers

  3. #3
    Join Date
    Sep 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ATI Radeon Xpress 1250

    I am running Fedora 15 on a Dell Latitude XT that also sports an ATI Radeon Xpress 1250. I had these exact issues on ubuntu as well. Setting "nomodeset" as a kernel option made the garbled text disappear but it also disables a lot of the other features in gnome.

    I've also tried installing the catalyst drivers from the repos but haven't had any luck, as those just cause the system to hang during boot.

    Any help would be greatly appreciated.

  4. #4
    Join Date
    Sep 2011
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ATI Radeon Xpress 1250

    I haven't tried nomodeset, I will give it a go.

    I tried the drivers from the rpmfusion repositories as well, but as you said it hangs on boot. I did some digging and I guess those drivers don't support the x1250.

    The proprietary drivers from ATI/AMD are also incompatible with the version of x org that ships with F15.

    I've also tried Ubuntu and had spotty results as you describe, ttilby. In that case I managed to get a bug report published, ill see if I can find it.

    HELP, ANYONE!
    I love Gnome 3, and I want to use it!

    ---------- Post added at 10:12 PM ---------- Previous post was at 10:03 PM ----------

    Tried nomodeset, all it did was disable GNOME3 completely for me

    Here is the unity bug report from ubuntu natty narwhal https://bugs.launchpad.net/ubuntu/+s...ty/+bug/801356

  5. #5
    Join Date
    Sep 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ATI Radeon Xpress 1250

    Same problem here using same chipset, Xpress 1250 (RS600). Been following this bug for months and the developers have basically washed their hands of it. This issue is present on a wide range of radeon hardware, and as such a large population of users will now be unable to use Gnome 3.0

  6. #6
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ATI Radeon Xpress 1250

    hi guys, this could be the worst first post in the world but does anyone have a fix for this yet?

  7. #7
    Join Date
    Apr 2012
    Location
    Florida
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: ATI Radeon Xpress 1250

    i am having the same issue very bad, but i have an intel on board card that came in my lenovo spare machine... i have two of these machines doing the same exact thing extremely bad... anyone get a fix for it?

Similar Threads

  1. ATI Radeon XPRESS 200M Help
    By Draper in forum Hardware & Laptops
    Replies: 6
    Last Post: 25th April 2012, 04:49 PM
  2. Fedora install on ATI Radeon Xpress 1250 graphics card
    By ABHAYM in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 2nd February 2010, 12:28 AM
  3. need ATI Radeon XPress 1250 series in fedora 10
    By bnousilal in forum Hardware & Laptops
    Replies: 0
    Last Post: 30th July 2009, 12:18 PM
  4. WoW with ATi Radeon Xpress 200m
    By heetly in forum Gamers' Lounge
    Replies: 5
    Last Post: 18th August 2007, 03:18 PM
  5. Ati Radeon Xpress 200
    By jgf621 in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 27th December 2006, 10:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •