[SOLVED] How do you disable control-alt-delete in F15?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    May 2011
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    How do you disable control-alt-delete in F15?

    It used to be in /etc/inittab... but how is it configured in systemd now?

  2. #2
    Join Date
    Feb 2010
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How do you disable control-alt-delete in F15?

    From "systemd.special":

    ctrl-alt-del.target
    systemd starts this target whenever Control+Alt+Del is pressed on the console. Usually this should be aliased (symlinked) to reboot.target.
    Maybe(!) "rm /lib/systemd/system/ctrl-alt-del.target" will do the trick. (It's only a symlink to "reboot.target".)

  3. #3
    Join Date
    Aug 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How do you disable control-alt-delete in F15?

    Quote Originally Posted by ewasser
    From "systemd.special":



    Maybe(!) "rm /lib/systemd/system/ctrl-alt-del.target" will do the trick. (It's only a symlink to "reboot.target".)
    I'm not 100% familiar with the systemd yet either, but as I understand it the defaults in /lib are not to be touched by end users, only the package maintainers. You can override the defaults by creating a link named /etc/systemd/system/ctrl-alt-del.target that points to /dev/null:

    ln -sf /dev/null /etc/systemd/system/ctrl-alt-del.target

    This will be used when you press ctrl-alt-delete and do nothing (hence the /dev/null) You could also create another target and link it to that so that pressing ctrl-alt-delete would do something other than reboot the system.

  4. #4
    Join Date
    May 2011
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How do you disable control-alt-delete in F15?

    Quote Originally Posted by TyBoyack
    ln -sf /dev/null /etc/systemd/system/ctrl-alt-del.target
    Thanks. This looks like the "canonical" way to handle it.

  5. #5
    Join Date
    Nov 2011
    Location
    Brisbane
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How do you disable control-alt-delete in F15?

    I found this solution didn't fix my issue to disable Ctrl-Alt-Delete; I used the following in System Settings:

    Start System Settings, Select Keyboard, Select Shortcuts, Select System
    You will see an entry for Log Out with Ctrl+Alt+Delete on the right hand side
    To Disable:
    select the "Ctrl+Alt+Delete", it will change to "New Shortcut", press backspace and it will change to "Disabled"
    No restart required.

Similar Threads

  1. fedora real disable ipv6 and disable sit0
    By ssb in forum Servers & Networking
    Replies: 2
    Last Post: 27th January 2011, 02:43 PM
  2. voice-control or speech-control
    By xenotrax in forum Using Fedora
    Replies: 0
    Last Post: 29th August 2010, 09:25 AM
  3. Replies: 1
    Last Post: 15th July 2009, 12:24 AM
  4. F9: control alt delete does nothing at all
    By jhhadc in forum Using Fedora
    Replies: 0
    Last Post: 31st December 2008, 02:12 AM
  5. How to "Control Alt Delete"
    By letmein in forum Using Fedora
    Replies: 19
    Last Post: 18th March 2006, 01:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •