Samsung/Splix printer no longer works after F14-F15 upgrade
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2006
    Posts
    170
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    SOLVED: Samsung/Splix printer no longer works after F14-F15 upgrade

    I have a Samsung CLP-500, which was working using the Splix driver under F14.

    I upgraded to F15 and now it doesn't print. Cups has an error message:

    Code:
    E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot open CMS file /opt/OpenPrinting-SpliX/ppds/samsung/cms/CLP-500cms (2)
    E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot open CMS file /opt/OpenPrinting-SpliX/ppds/samsung/cms/CLP-500cms2 (2)
    W [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX CMS data are missing. Color correction aborted
    E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot execute pstoraster (2)
    E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot get input slot information.
    E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot open job
    E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Error while rendering the request. Check the previous message
    SELinux is in permissive mode.

    Any ideas what the problem might be? What has changed F14-15 that might cause this?

    thanks
    M.

    ---------- Post added at 05:45 AM ---------- Previous post was at 05:09 AM ----------

    More info:

    Splix has a file pstoraster that is a symlink to /usr/lib/cups/filters/pstoraster

    However /usr/lib/cups/filters/pstoraster doesn't exist on my F15 system.

    As i understand, pstoraster is a shell script that call's ghostscript. I have ghostscript installed, so why wouldn't pstoraster be included?

    yum whatprovides */pstoraster

    doesn't give any output.

    Is this likely to be something to do with it? Or am I barking up the wrong tree?

    cheers
    M.

    ---------- Post added at 05:45 AM ---------- Previous post was at 05:09 AM ----------

    Ok, sorted it:

    According to the ghostscript changelog the *toraster commands were replaced by one binary gstoraster.

    so solved by symlinking the splix pstoraster to gstoraster:

    Code:
    cd /usr/lib/cups/filter
    ln -s gstoraster pstoraster
    Printer works fine now, but MAN that was a waste of a few hours.

    HTH someone else!
    M.
    Last edited by mps2006; 15th June 2011 at 03:47 PM. Reason: SOLVED

  2. #2
    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile Re: Samsung/Splix printer no longer works after F14-F15 upgrade

    Hi M,

    Your solution worked for me too - so thank you for posting it.

    I too had a Samsung, and I was using SpliX. No problem with the older Fedora, but on upgrading to FC16 I just could not print.

    Only when I googled:

    SpliX Cannot open CMS file /opt/OpenPrinting-SpliX/ppds/samsung/cms/CLP-500cms (2)
    I found your post, and hey presto it worked.

    Thanks
    Trystan

  3. #3
    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Samsung/Splix printer no longer works after F14-F15 upgrade

    Quote Originally Posted by trystan
    Hi M,

    Your solution worked for me too - so thank you for posting it.

    I too had a Samsung, and I was using SpliX. No problem with the older Fedora, but on upgrading to FC16 I just could not print.

    Only when I googled:



    I found your post, and hey presto it worked.

    Thanks
    Trystan
    Well it's me again, some years later!

    So now I'm up to Fedora 28 and suddenly I'm getting the same error message again - even though the symbolic link that I created those years ago is still there.

    Any help at all (please) would be much appreciated.

    Thank you.

    Trystan

  4. #4
    Join Date
    May 2012
    Location
    United Kingdom
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Samsung/Splix printer no longer works after F14-F15 upgrade

    Right.

    I found the answer in the end.

    So I went into "Printers", then "Unlocked" with the root password.

    I selected the Printer, Samsung CLP-500 SpliX 2-0-0

    So this is as far as I would normally have to go.

    But then, just by chance I looked at "Printer Details" and selected "Select from Database"

    The exact same dialogue comes up again, and again I select the very same printer option Samsung CLP-500 SpliX 2-0-0

    So that worked.

    There is somehow a glitch in the the way that the SpliX pdd file is installed the first time it is selected.

    Trystan

  5. #5
    Join Date
    Feb 2006
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Samsung/Splix printer no longer works after F14-F15 upgrade

    BTW
    Since F15 we got splix package with [1] will install the same OpenPrinting-SpliX

    [1]
    dnf install splix

Similar Threads

  1. After Upgrade to F12, X no longer works
    By klee in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 19th November 2009, 05:38 AM
  2. Sound no longer works after Fedora 10 upgrade
    By jspot in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 24th January 2009, 05:02 PM
  3. HP 1018 printer suddenly no longer works
    By mard666 in forum Hardware & Laptops
    Replies: 1
    Last Post: 20th August 2007, 04:54 PM
  4. Printer no longer works after upgrade from FC3 to FC4
    By da644 in forum Hardware & Laptops
    Replies: 4
    Last Post: 16th July 2005, 08:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •