FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2007
    Location
    Berkeley, California
    Posts
    690

    How to handle a gnome-shell lock up?

    Sooner or later you may experience a Gnome shell lock up. After two weeks of daily use I experienced my first one today: the cursor turned to a hand, and no amount of clicking and pressing Esc would have any effect; Windows key didn't bring Activities in focus either.

    If you experience these or similar symptoms you can restart the gnome-shell in order to unlock the Gnome session:

    1) pass to a console (press Ctrl+Alt+F2)

    2) log in

    3) execute: ps -ef | grep gnome-shell in order to find the gnome-shell process id (PID); the output may look something like

    Code:
    thoe      1539  1354  1 **:** ?        **:**:** /usr/bin/gnome-shell
    thoe      1632     1 0  **:** ?        00:00:00 /usr/libexec/gnome-shell-calendar-server
    thoe      8691  1894  0 **:** pts/2    00:00:00 grep --color=auto gnome-shell
    The gnome-shell PID is marked in red.

    4) execute: kill -9 <PID>

    In the above example it would be: kill -9 1539


    Pressing Ctrl+ALt+F1 (or, if that doesn't work -- Ctrl+ALt+F7) should take you back to the Gnome session. You should see the restarted gnome-shell. (You can now return to the console, log out from the console, and return to the Gnome session).
    Last edited by Mariusz W; 7th June 2011 at 06:30 PM.

  2. #2
    Join Date
    Aug 2009
    Posts
    8,464

    Re: How to handle a gnome-shell lock up?

    Good information, Mariusz

    I have on occasion found that the gnome shell restarts on the Ctrl-ALT-F7 console instead of the Ctrl-ALT-F1 sometimes. I haven't figured out what causes it to change yet, but just thought I would mention it in case someone didn't get back to it by using Ctrl-Alt-F1, they can try the other.

  3. #3
    Join Date
    Nov 2007
    Location
    Berkeley, California
    Posts
    690

    Re: How to handle a gnome-shell lock up?

    Quote Originally Posted by DBelton
    I have on occasion found that the gnome shell restarts on the Ctrl-ALT-F7 console instead of the Ctrl-ALT-F1 sometimes. I haven't figured out what causes it to change yet, but just thought I would mention it in case someone didn't get back to it by using Ctrl-Alt-F1, they can try the other.
    I noticed that too and with several desktop environments, not just GNOME: either Ctrl+Alt+F1 or Ctrl+Alt+F7 take you back to the desktop session; I first try Ctrl+Alt+F1, and if that doesn't work, then I try the other one.

    I accordingly edited my post. Thank you for the comment.
    Last edited by Mariusz W; 7th June 2011 at 06:32 PM.

Similar Threads

  1. Replies: 5
    Last Post: 26th June 2011, 10:23 AM
  2. Replies: 1
    Last Post: 28th April 2011, 07:21 PM
  3. Gnome shell or unity shell?
    By jan1024188 in forum Using Fedora
    Replies: 9
    Last Post: 18th April 2011, 11:57 PM
  4. GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.
    By piopio in forum Installation, Upgrades and Live Media
    Replies: 12
    Last Post: 21st November 2010, 09:00 AM
  5. GNOME Shell - Preview of GNOME 3 - Accelerated 3D graphics is not available
    By flokip in forum Fedora 12 Alpha, Beta & Release Candidates
    Replies: 14
    Last Post: 29th October 2009, 06:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •